Dear All,
I receive this error (ERROR: account.AUTH_FAILED (authentication failed for zimbra)) when i use zmprov command. I had searched the error on Forum and followed the guide on forum to reset password of zimbra ldap. However, the issue not solved. Marcmac say that this is a bug in zmldappasswd but i see the version which i am operating (4.5.4 OSS), it don't have this bug:
This is ldappasswd command in my zmldappasswd script:

ldappasswd -H ${ldap_url} -w ${ldap_root_password} -D ${zimbra_ldap_userdn} \
-x -s ${zimbra_ldap_password} ${zimbra_ldap_userdn} > /dev/null 2>&1

I think that i don't need to modify anything in this script.

I receive this error in mailbox.log:
com.zimbra.cs.account.AccountServiceException: authentication failed for zimbra
at com.zimbra.cs.account.AccountServiceException.AUTH _FAILED(AccountServiceException.java:87)
at com.zimbra.cs.account.ldap.LdapProvisioning.checkA ccountStatus(LdapProvisioning.java:2202)
at com.zimbra.cs.account.ldap.LdapProvisioning.authAc count(LdapProvisioning.java:2256)
at com.zimbra.cs.account.ldap.LdapProvisioning.authAc count(LdapProvisioning.java:2242)
at com.zimbra.cs.service.admin.Auth.handle(Auth.java: 97)
at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:270)
at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:168)
at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:90)
at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:162)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
at java.lang.Thread.run(Thread.java:595)


My system still operate normally. i can't use zmprov command.

Please help me.