I have set email filters but this does not work.

does this have something to do with my spam settings?

I have selected an email and marked as junk, but it continues to come in to inbox

thanks