Results 1 to 3 of 3

Thread: AntiVirus won't run - error accessing mail queues

  1. #1
    Join Date
    May 2007
    Location
    Michigan
    Posts
    10
    Rep Power
    8

    Default AntiVirus won't run - error accessing mail queues

    We're running zcs-4.5.5_GA_838.RHEL4 on CentOS4.5 (since around a month ago). Has been working great.

    We had a power failure (including the UPS) on the 22nd. Since then A/V has failed to start which has left us unable to send or receive email. I see the following in the logs:

    zmmtaconfig.log
    Sun Jul 22 14:51:15 2007 Section antivirus did not change skipping
    Sun Jul 22 14:52:23 2007 Section antivirus did not change skipping
    Sun Jul 22 14:53:30 2007 Section antivirus did not change skipping
    Sun Jul 22 17:44:59 2007 Watchdog adding antivirus to restart list
    Sun Jul 22 17:44:59 2007 Section antivirus did not change skipping
    Sun Jul 22 17:46:16 2007 Watchdog adding antivirus to restart list
    Sun Jul 22 17:46:16 2007 Section antivirus did not change skipping

    ... with the last 2 lines repeating over again for thousands of times.

    clamd.log
    Sun Jul 22 13:47:45 2007 -> SelfCheck: Database status OK.
    Sun Jul 22 14:19:47 2007 -> SelfCheck: Database status OK.
    Sun Jul 22 14:51:07 2007 -> SelfCheck: Database status OK.
    Sun Jul 22 17:43:59 2007 -> +++ Started at Sun Jul 22 17:43:59 2007
    Sun Jul 22 17:43:59 2007 -> clamd daemon 0.90.2 (OS: linux-gnu, ARCH: i386, CPU: i686)
    Sun Jul 22 17:43:59 2007 -> Log file size limited to 20971520 bytes.
    Sun Jul 22 17:43:59 2007 -> Reading databases from /opt/zimbra/clamav/db
    Sun Jul 22 17:45:08 2007 -> +++ Started at Sun Jul 22 17:45:08 2007
    Sun Jul 22 17:45:08 2007 -> clamd daemon 0.90.2 (OS: linux-gnu, ARCH: i386, CPU: i686)
    Sun Jul 22 17:45:08 2007 -> Log file size limited to 20971520 bytes.
    Sun Jul 22 17:45:08 2007 -> Reading databases from /opt/zimbra/clamav/db

    ... with the last 4 lines repeating over again for thousands of times.


    In addition, when I try to look at the mail queues I get this error:

    Server error encountered

    Message: system failure: exception during auth {RemoteManager: pandora.lsd.k12.mi.us->zimbra@pandora.lsd.k12.mi.us:22}
    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver


    I don't see any obvious damage and am at a loss where else to look.

    Thanks in advance for the help.

  2. #2
    Join Date
    May 2007
    Location
    Michigan
    Posts
    10
    Rep Power
    8

    Default Partly fixed

    Taking hints from another similar thread I have deleted /opt/zimbra/clamav/db/* and upgraded to 4.5.6.

    AV starts up now.
    We can send/receive mail now.

    However the other problem I originally described remains. Whenever I click on mail queues via web admin I see the error documented in my previous post.

    Any ideas?

  3. #3
    Join Date
    May 2007
    Location
    Michigan
    Posts
    10
    Rep Power
    8

    Default re: error accessing mail queues

    Perhaps this will help with the mail queue access error.

    Found this in mailbox.log. I get one of these every time I click on the mail queue icon.

    2007-07-25 11:40:30,649 INFO [http-7071-Processor48] [name=admin@pandora.lsd.k12.mi.us;ip=216.157.209.62 ;ua=ZimbraWebClient - FF2.0 (Linux)/undefined;] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: system failure: exception during auth {RemoteManager: pandora.lsd.k12.mi.us->zimbra@pandora.lsd.k12.mi.us:22}
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:175)
    at com.zimbra.cs.rmgmt.RemoteManager.getSession(Remot eManager.java:197)
    at com.zimbra.cs.rmgmt.RemoteManager.execute(RemoteMa nager.java:134)
    at com.zimbra.cs.service.admin.GetMailQueueInfo.handl e(GetMailQueueInfo.java:56)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:270)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:168)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:90)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:162)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.io.IOException: auth failed
    at com.zimbra.cs.rmgmt.RemoteManager.getSession(Remot eManager.java:190)
    ... 24 more


    An auth failure? Of what? How to fix?

    Thanks.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 04:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •