Results 1 to 4 of 4

Thread: Corrupted Mailbox

Hybrid View

  1. #1
    Join Date
    Nov 2005
    Rep Power

    Default Corrupted Mailbox

    Using the Admin Console I selected an account and clicked on the view webmail button. As normal a new window popped open and after the inital zimbra loading screen finished and error popped up that said "No such conversation exists"

    Here is the output
    Any ideas??

    msg - no such conversation: -1
    com.zimbra.cs.mailbox.MailServiceException$NoSuchI temException: no such conversation: -1
    at com.zimbra.cs.mailbox.MailServiceException.NO_SUCH _CONV(
    at com.zimbra.cs.mailbox.MailItem.noSuchItem(MailItem .java:752)
    at com.zimbra.cs.db.DbMailItem.getById(DbMailItem.jav a:1121)
    at com.zimbra.cs.mailbox.MailItem.getById(MailItem.ja va:703)
    at com.zimbra.cs.mailbox.Mailbox.getItemById(Mailbox. java:1692)
    at com.zimbra.cs.mailbox.Mailbox.getItemById(Mailbox. java:1661)
    at com.zimbra.cs.mailbox.Mailbox.getConversationById(
    at com.zimbra.cs.index.ConversationHit.getConversatio n(
    at com.zimbra.cs.service.mail.Search.addConversationH it(
    at com.zimbra.cs.service.mail.Search.putHits(Search.j ava:267)
    at com.zimbra.cs.service.mail.Search.handle(Search.ja va:117)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:226)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at ternalDoFilter(
    at Filter(
    at org.apache.catalina.core.StandardWrapperValve.invo ke(
    at org.apache.catalina.core.StandardContextValve.invo ke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke (
    at org.apache.catalina.core.StandardEngineValve.invok e(
    at org.apache.catalina.valves.AccessLogValve.invoke(A
    at org.apache.catalina.connector.CoyoteAdapter.servic e(
    at org.apache.coyote.http11.Http11Processor.process(H
    at org.apache.coyote.http11.Http11Protocol$Http11Conn ectionHandler.processConnection(Http11Protocol.jav a:738)
    at Socket(
    at ead.runIt(
    at org.apache.tomcat.util.threads.ThreadPool$ControlR

    code - mail.NO_SUCH_CONV
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Sender

  2. #2
    Join Date
    Aug 2005
    San Mateo, CA
    Rep Power


    Hi Matt, Is this something you can reproduce everytime? Does it also happen if you just login directly to the user's inbox?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Nov 2005
    Rep Power


    Hey Kevin.

    It appeared to be only via the administration console, and i tried it on a few users and it was hit and miss, (NOTE i also noticed if you do not implicitly logout of the session no matter who's email it will cache the login session so I dont believe i was getting an acurate view of who this was effecting.)

    In any event, with no intervention from myself it appears to have fixed itself. I can now log in via administrative console and via zimbra webmail with out any problems. If problems persist i'll let you know

  4. #4
    Join Date
    Sep 2005
    Rep Power


    This sounds like the same issue as Bug 4033 and Bug 4909. In those cases, a message in the message cache has an invalid conversation ID for some reason -- even though the on-disk version of the message is fine.

    We think this is some kind of a race condition either with IMAP or with the MAPI connector (Network Edition only) --- can you tell me if the affected account was using either of these? How about POP3?

    Since the conversation ID is only corrupted in the in-memory cache, you can fix the account by forcing the cache to reload: the message cache is a max of 500 messages (per account) and so paging through other folders will do it...alternatively, as a last resort bouncing your server should also fix the problem.

Similar Threads

  1. Replies: 210
    Last Post: 01-17-2012, 12:19 AM
  2. Restore mail to another user's mailbox
    By zaf in forum Administrators
    Replies: 4
    Last Post: 02-08-2008, 07:26 AM
  3. MTA and Mailbox die periodically...
    By andreturpin in forum Administrators
    Replies: 3
    Last Post: 06-21-2006, 06:31 PM
  4. Internet Explorer waits forever to load mailbox
    By shanson in forum Administrators
    Replies: 7
    Last Post: 04-07-2006, 09:27 AM
  5. The mailbox and mta dies in FC4 GA version
    By meikka in forum Installation
    Replies: 72
    Last Post: 03-16-2006, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts