Results 1 to 4 of 4

Thread: LDAP: error code 80 - index generation failed - Howto rebuild LDAP index?

  1. #1
    Join Date
    Nov 2006
    Location
    Vienna, Austria (Europe)
    Posts
    59
    Rep Power
    8

    Default LDAP: error code 80 - index generation failed - Howto rebuild LDAP index?

    I discovered being unable to add new Users via the Admin Webinterface.
    Troubleshooting shows thatsomething with the LDAP index is wrong.

    Can one of thepro's help me how to repair the indexissueon LDAP, as I have no LDAP KnowHow? Thanx for any help.

    Code:
    Zimbra Administration
    Server error encountered
    Message: system failure: createAccount
    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver
    Code:
    Caused by: javax.naming.NamingException:
    [LDAP: error code 80 - index generation failed];
    remaining name 'uid=office,ou=people,dc=examplea,dc=com'
    Code:
    zimbra@server7:~$ /opt/zimbra/sleepycat/bin/db_stat -c -h /opt/zimbra/openldap-data
    1921 Last allocated locker ID.
    2147M Current maximum unused locker ID.
    9 Number of lock modes.
    1000 Maximum number of locks possible.
    1000 Maximum number of lockers possible.
    1000 Maximum number of lock objects possible.
    9 Number of current locks.
    203 Maximum number of locks at any one time.
    31 Number of current lockers.
    86 Maximum number of lockers at any one time.
    4 Number of current lock objects.
    4294M Maximum number of lock objects at any one time.
    32M Total number of locks requested.
    32M Total number of locks released.
    0 Total number of lock requests failing because DB_LOCK_NOWAIT was set.
    9 Total number of locks not immediately available due to conflicts.
    0 Number of deadlocks.
    0 Lock timeout value.
    0 Number of locks that have timed out.
    0 Transaction timeout value.
    0 Number of transactions that have timed out.
    440KB The size of the lock region..
    1585 The number of region locks granted after waiting.
    51M The number of region locks granted without waiting.
    running OS 4.5.4_GA_763.DEBIAN
    uname -r = 2.6.19.1
    Attached Images Attached Images

  2. #2
    Join Date
    Nov 2006
    Location
    Vienna, Austria (Europe)
    Posts
    59
    Rep Power
    8

    Default Workaround for creating new users?

    In the meantime. Is there a possibility to create new users?

  3. #3
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    You're on 4.5.4, and should upgrade to 4.5.6.
    Let's see what that does.

    john

  4. #4
    Join Date
    Nov 2006
    Location
    Vienna, Austria (Europe)
    Posts
    59
    Rep Power
    8

    Thumbs up Can add users again after Upgrade from 454 to 456

    Thank you John for the quick reply.

    After Upgrading from
    4.5.4_GA_763.DEBIAN3.1 (OS) to
    4.5.6_GA_1044_DEBIAN3.1 (OS)
    on
    tail /etc/debian_version
    3.1
    uname -r
    2.6.19.1

    creating of new users through the webadmin is now working again.

    greetings, Robert

Similar Threads

  1. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 10:23 PM
  2. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  4. Error message in Server status
    By Max Ma in forum Installation
    Replies: 20
    Last Post: 04-19-2007, 09:55 AM
  5. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 11:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •