Results 1 to 4 of 4

Thread: SSL questions

  1. #1
    Join Date
    Jul 2007
    Posts
    44
    Rep Power
    8

    Default SSL questions

    I can not seem to find anything about the SSL features for the web client. By default I see a normal connection on port 80 to the server. This would mean any traffic regarding credentials and maybe more is unencrypted? What steps should be taken to enable a SSL connection?

    Besides this, I see in the master.cf configuration of postfix that SSL for smtp is on by default. I am correct that all of the credentials sended out by a mail client trough a SMTP secure port is encrypted? I have opened port 465 on my firewall for this, is that correct?

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Quote Originally Posted by bramm View Post
    I can not seem to find anything about the SSL features for the web client. By default I see a normal connection on port 80 to the server. This would mean any traffic regarding credentials and maybe more is unencrypted? What steps should be taken to enable a SSL connection?

    Besides this, I see in the master.cf configuration of postfix that SSL for smtp is on by default. I am correct that all of the credentials sended out by a mail client trough a SMTP secure port is encrypted? I have opened port 465 on my firewall for this, is that correct?
    Hi Bramm, and welcoem to the Zimbra forums!

    All of this depends on how you configure Zimbra. Unlike a normal postfix install, Zimbra manages the master.cf file, so any changes will be overwritten.

    The command that tells zimbra to use SSL/TLS is
    su - zimbra
    zmtlsctl http
    or
    zmtlsctl https

    So, if you use https, the port is 443, if you use http, the port is 80.

    Cheers,
    jh

  3. #3
    Join Date
    Jul 2007
    Posts
    44
    Rep Power
    8

    Default

    After rebooting Zimbra (I think tomcat should be enough) it works. Thanks for the quick response.

  4. #4
    Join Date
    Aug 2007
    Posts
    15
    Rep Power
    0

    Default Enabling https - error - coneection refused

    Hi,

    I have installed zimbra with zcs-4.0.4_GA_457.FC4.tgz on FC4. It's running pretty fine & impressed on it's featurs . Thanks to Zimbra team :-)

    Now I'm trying to use "https" for zimbra web login(it is http now).

    For that I did like this,

    zmtlsctl https

    zmcontrol stop
    zmcontrol start

    But I got a connection refused error.

    and when I did "zmtlsctl http" , it works back again.


    My requirmet is like this,

    ----
    Server is behind NAT & firewall (IP Tables)
    web login url = http://mydomain.com:8081 (we have our web server running on the port 80 - behind the same NAT firewall and can't use port 80 for zimbra)

    Now I want to change the zimbra web login url to https://mydomain.com:8081

    Possible?

    Please help me to do that ...

    Regards
    -Vivek

Similar Threads

  1. Install a commercial SSL certificate ??
    By nick20 in forum Installation
    Replies: 6
    Last Post: 06-23-2010, 04:08 AM
  2. Installing commercial ssl on zimbra cs (network ed.)
    By keithop in forum Administrators
    Replies: 4
    Last Post: 04-28-2009, 05:16 PM
  3. Certificate Change Kicks Moto Q off of SSL Synch
    By theasbcguy in forum Zimbra Mobile
    Replies: 3
    Last Post: 04-14-2008, 01:01 PM
  4. Disable SSL on the Admin Port 7071
    By rasputin in forum Installation
    Replies: 2
    Last Post: 04-06-2008, 04:29 AM
  5. Help with tomcat ssl errors...
    By sgtstadanko in forum Administrators
    Replies: 4
    Last Post: 03-19-2007, 10:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •