Results 1 to 5 of 5

Thread: Samba Posix account configuration problem

  1. #1
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Unhappy Samba Posix account configuration problem

    Hi Everybody,

    I m in grave trouble and would like u expert guys to pls help me out.

    I have installed Zimbra open source on FC4 and is working fine. Now i m looking forward for integration with Samba and Posix account zimlets. I could deploy the adm extension but they are not getting executed. I followed Greg 's guide UNIX and Windows Accounts in Zimbra LDAP and Zimbra Admin UI - ZimbraWiki

    The samba domain does not feature readily in domain list.
    The following is the error message.
    Message: invalid request: createLDAPEntry invalid schema change: [LDAP: error code 65 - object class 'sambaDomain' requires attribute 'sambaSID']
    Error code: service.INVALID_REQUEST
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Sender

    I have refered some forums and had taken the precausion not to repeat those mistakes.

    include "/opt/zimbra/openldap/etc/openldap/schema/core.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/cosine.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/inetorgperson.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/amavisd.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/zimbra.schema"
    include "/opt/zimbra/lib/conf/zimbra-ext.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/nis.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/samba.schema"

    Also pls advice me if I have to specifically define SID in any file.

    Thanks in Advance.
    Audi.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    What version of Zimbra are you running?

  3. #3
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default

    Hi Sir,

    I m using the latest ver i.e. ZCS 4.5.6

    Thanx
    Audi.

  4. #4
    Join Date
    Sep 2005
    Location
    Tucson - San Francisco - Moscow
    Posts
    127
    Rep Power
    10

    Default

    Quote Originally Posted by audi View Post
    Hi Everybody,
    The samba domain does not feature readily in domain list.


    If everything was configured correctly (which is not trivial at first attempt) the Samba Domain record should have appeared in the LDAP after Samba is restarted.

    Quote Originally Posted by audi View Post
    The following is the error message.
    Message: invalid request: createLDAPEntry invalid schema change: [LDAP: error code 65 - object class 'sambaDomain' requires attribute 'sambaSID']
    Error code: service.INVALID_REQUEST
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Sender
    Quote Originally Posted by audi View Post
    I have refered some forums and had taken the precausion not to repeat those mistakes.

    include "/opt/zimbra/openldap/etc/openldap/schema/core.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/cosine.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/inetorgperson.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/amavisd.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/zimbra.schema"
    include "/opt/zimbra/lib/conf/zimbra-ext.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/nis.schema"
    include "/opt/zimbra/openldap/etc/openldap/schema/samba.schema"

    Thanks in Advance.
    Audi.

    Where do you see this error message? Do you get it in Zimbra Admin UI when you are trying to create a Samba Domain manually? Is it from smb.log file? Is it from zimbra.log file? Or some other log file?

    Quote Originally Posted by audi View Post
    Also pls advice me if I have to specifically define SID in any file.
    No, you do not have to define SID in any file. SID is generated by samba. After Samba is installed and configured, you can run
    >net getlocalsid
    and it will print out the SID of your Samba domain, but lets first deal with adding Samba domain to the LDAP tree.
    Bugzilla - Wiki - Downloads - Before posting... Search!
    P.S.: don't forget to vote on this bug
    add Samba LDAP entries to Exchange Migration Tool

  5. #5
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default

    Hi Greg,

    Thnx for showing your interest.
    Well I got the error message when i tried to add the Samba Domain in Zimbra admin GUI manually as it was not getting reflected automatically.

    The message were pulled from the /opt/zimbra/log/mailbox.log

    I dont know wht n where I m making mistake.

    pls guide

    Thanx n regards,
    Audi.

Similar Threads

  1. Problem with user account
    By chowdah in forum Administrators
    Replies: 3
    Last Post: 11-05-2009, 04:31 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  3. Tight samba integration with zimbra
    By daniellawson in forum Administrators
    Replies: 21
    Last Post: 06-14-2007, 05:06 PM
  4. Two server locked account problem
    By lfasci in forum Administrators
    Replies: 1
    Last Post: 04-23-2007, 02:57 PM
  5. Problem sending mail from another account in Outlook
    By UTSCSE in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 01-25-2007, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •