Results 1 to 9 of 9

Thread: [SOLVED] https

  1. #1
    Join Date
    Jul 2007
    Location
    Buffalo, NY
    Posts
    91
    Rep Power
    8

    Default [SOLVED] https

    We would like to connect to all acounts via https. Can someone point me to directions on how to do this?

    Thanks

  2. #2
    Join Date
    Mar 2007
    Location
    Regina, Sask.
    Posts
    215
    Rep Power
    8

    Default

    CLI zmtlsctl to set Web Server Mode - ZimbraWiki


    The wiki is actually pretty amazing do you have anything else on that port as it is now?

    Code:
    # lsof -i :443
    does that show anything?

  3. #3
    Join Date
    Jul 2007
    Location
    Buffalo, NY
    Posts
    91
    Rep Power
    8

    Default

    Thanks. When I run the command I recieve a bash: zmtlsctl: command not found error. I am running this from root. Is this where I should run this command?

    Thanks again

  4. #4
    Join Date
    Mar 2007
    Location
    Regina, Sask.
    Posts
    215
    Rep Power
    8

    Default

    Quote Originally Posted by mclain View Post
    Thanks. When I run the command I recieve a bash: zmtlsctl: command not found error. I am running this from root. Is this where I should run this command?

    Thanks again
    Ahh sorry I should have mentioned that ;-) you need to run it as user zimbra:

    Code:
    # su - zimbra
    $

  5. #5
    Join Date
    Jul 2007
    Location
    Buffalo, NY
    Posts
    91
    Rep Power
    8

    Default

    Perfect . Thanks alot.

  6. #6
    Join Date
    Apr 2007
    Posts
    32
    Rep Power
    8

    Default

    Is it possible to get zmtlsctl to redirect http://server to https://server for everything (not just logins).

    The nearest I can get is zmtlsctl mixed, but that just redirects for the login. It would be good if zmtlsctl included the redirect.

    I guess I could set something up without too much trouble, but it would be nice if it happened by default.

    Rob

  7. #7
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    That is the point of mixed mode (just https for logins)
    Your looking for the 'redirect' mode that is in v5.

    Using 4.5 one method to redirect http>https & continue to use https after the login would be:
    -Edit /opt/zimbra/tomcat/webapps/zimbra/public/Login.jsp and comment out this statement so that http connections are *never redirected back* to http:
    qs = emptyQs? "?initMode=" + currentProto: qs + "&initMode=" + currentProto;
    zmcontrol stop/start

    Though you've already done this-be sure to set the mail mode to mixed to allow the initial http connections that will be redirected to https:
    zmtlsctl mixed
    tomcat restart
    See other methods in this RFE:
    Bug 7631 - redirect to https mode problem
    Thus we now have http, https, both, mixed, redirect
    Last edited by mmorse; 09-05-2007 at 10:08 AM.

  8. #8
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  9. #9
    Join Date
    Apr 2007
    Posts
    32
    Rep Power
    8

    Default

    That did it - thanks.

Similar Threads

  1. https ???
    By CatiaL in forum Administrators
    Replies: 7
    Last Post: 09-16-2009, 07:47 PM
  2. https & Newbie Question
    By swu in forum Administrators
    Replies: 5
    Last Post: 04-17-2007, 08:07 AM
  3. HTTPS problem
    By EnglishDude in forum Installation
    Replies: 5
    Last Post: 11-25-2006, 08:40 AM
  4. Switching From Https to Http Protocol in JSP
    By Shyam in forum Administrators
    Replies: 1
    Last Post: 10-10-2006, 07:58 AM
  5. Changing browser access from HTTPS to Both HTTPS and HTTP
    By kelley.ch in forum Administrators
    Replies: 5
    Last Post: 09-19-2006, 12:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •