Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: zimbra as default client on linux instead of evolution

  1. #1
    Join Date
    Oct 2005
    Location
    Marietta, GA
    Posts
    28
    Rep Power
    9

    Default zimbra as default client on linux instead of evolution

    How do I get zimbra as the default client when a user selects an e-mail link address while in their browser. Can this only be done from a linux desktop or can you do it from a windows desktop also. Please advise. Thanks.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    It can be done from both technically. In both cases we'd need to add the ability to go directly to compose from a URL. We'd only need to change the registry on win32 to send mailto: links to Zimbra's compose URL. On Linux you'd need to reconfigure mailto: links to go to Zimbra. Bottom line is that we need to direct compose URL to try any of this.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Oct 2005
    Location
    Marietta, GA
    Posts
    28
    Rep Power
    9

    Default

    Is this something others are interested in doing. If so, will it be in a future release for both versions or just the network version of zimbra? If not, is this something that can be done via revising code or is this a new code implementation all together?

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    It's something of general use and we plan to add it in the future. My guess is it would be in both the OSS and Network versions.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Feb 2006
    Location
    middle of a corn field, IL
    Posts
    111
    Rep Power
    9

    Default mailto: links

    Is it currently possible to manually change the registry to correctly handle mailto links and also for M$ Office and OpenOffice to send as attachment from their file menus? What is the correct URL to put in?

  6. #6
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Try this...

    Code:
    https://SERVER/zimbra/mail?view=compose&to=TO&subject=SUBJECT
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  7. #7
    Join Date
    Feb 2006
    Location
    middle of a corn field, IL
    Posts
    111
    Rep Power
    9

    Default Registry keys

    What are all the reigstry keys that need to be edited?

  8. #8
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  9. #9
    Join Date
    Feb 2006
    Location
    middle of a corn field, IL
    Posts
    111
    Rep Power
    9

    Default Almost there

    How do I link to just the compose window without all of the rest loading? (like when you compose in its own window)

    I am almost there as I have this in the mailto registry key:
    firefox.exe -new-window https://SERVER/zimbra/mail?view=compose

    Now how do we get it to work that M$ Office and OpenOffice will call it?

  10. #10
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by dagar
    Now how do we get it to work that M$ Office and OpenOffice will call it?
    If they don't use the regkey then you'll need to find an app specific way to make that change.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 06:29 PM
  2. Replies: 8
    Last Post: 02-27-2007, 03:10 AM
  3. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •