I couldn't see much in a forum search on tasks apart from requesting the feature. There doesn't seem to be this sort of behavior in the bug tracker entries.

Has anyone else seen this? Should I submit as a bug?.........

I initially had an extra task list on my account called IT. I then shared with 3 people view only and with 1 person as manager.

That all worked fine.

I then created another tasks list for a largish project and shared it with manager rights. Rather than specifying individuals, I used a distribution list (all members were zimbra users on our domain).

The invite went out, people clicked on accept and they could see the extra task list in their account. When they click on it though they get back

msg - system failure: Invalid hit type, can only task-sort Tasks
code - service.FAILURE
method - ZmCsfeCommand.prototype.invoke
detail - soap:Receiver


Now all shared tasks act like this unless it is an empty task list. I tested with another new list and just invited one person. As soon as I add any tasks to the list, they get the same error as above.

I've tried restarting all services with zmcontrol.

I might try a server restart and then an upgrade install with the 5 beta 2 installer again to see if it gets tasks working again. (I'll wait until people aren't using the system.... probably in about 5 hours)

I'm not sure if the behaviour was triggered by me using a distribution list (from GAL) instead of individual invites.