Results 1 to 7 of 7

Thread: operation sent to wrong host

  1. #1
    dje007 Guest

    Default operation sent to wrong host

    [zimbra@valerian /]$ zmprov -v GetAllCalendarResources
    projector-sharp@XXX.com
    mcal@XXX.com
    conferenceroom1@XXX.com
    conferenceroom2@XXX.com
    [zimbra@valerian /]$ zmprov deleteCalendarResource conferenceroom2@XXX.com
    ERROR: service.WRONG_HOST (operation sent to wrong host (you want 'YYY'))


    I can't dell a Cal Resources since hosts name change.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    What version of Zimbra are you using?

  3. #3
    dje007 Guest

    Default

    Quote Originally Posted by jholder View Post
    What version of Zimbra are you using?
    Current
    4.5.6

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    could we get the full string?
    in the search bar: $set:get version
    at the command line: zmcontrol -v
    (you could add it to your forum profile while your at it-saves time later)

    Everything else go smooth with your server name change? (I assume you did: ZmSetServerName - ZimbraWiki)
    Last edited by mmorse; 08-20-2007 at 08:34 AM.

  5. #5
    dje007 Guest

    Default

    [zimbra@valerian ~]$ zmcontrol -v


    Release 4.5.6_GA_1044.RHEL4_20070706161941 CentOS5{i} NETWORK edition

  6. #6
    dje007 Guest

    Default

    Quote Originally Posted by mmorse View Post
    could we get the full string?
    in the search bar: $set:get version
    at the command line: zmcontrol -v
    (you could add it to your forum profile while your at it-saves time later)

    Everything else go smooth with your server name change? (I assume you did: ZmSetServerName - ZimbraWiki)

    Is there an update on this ?

  7. #7
    Join Date
    Jun 2007
    Location
    Oregon
    Posts
    51
    Rep Power
    8

    Default

    I just had that error as well. In my case, one of my calendar resources had gotten it's mailstore set to the wrong server. So it was trying to send the delete command to the MTA.

    To see if this is what is happening to you, run this command:
    Code:
    zmprov ga | grep MailTransport
    That will tell you where it thinks that conference room address lives. Now, take a look at the other calendar resources. Are they the same or different? Is the server listed a valid mailstore? If its wrong, you will need to reset it to a real mailstore before you can delete it.

    In my case, it was like this:
    Code:
    zmprov ma conferenceroom@server.com zimbraMailTransport lmtp:my.mail.server.com:7025
    After it is moved you should be able to take care of it. I'd make sure to check all of your resources. In my case, I was not able to send messages to it.

Similar Threads

  1. InitNotebookRequest error: sent to wrong host
    By cstolley in forum Developers
    Replies: 0
    Last Post: 07-10-2007, 10:30 AM
  2. HSM Error - "operation sent to wrong host"
    By ewlooney in forum Administrators
    Replies: 2
    Last Post: 02-13-2007, 05:59 AM
  3. Installation Cancelled - Zimbra-spell !
    By Ledg in forum Installation
    Replies: 4
    Last Post: 10-19-2006, 02:54 AM
  4. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM
  5. Unknown Host ?
    By msentissi in forum Administrators
    Replies: 5
    Last Post: 03-18-2006, 02:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •