Results 1 to 6 of 6

Thread: admin reports being sent to MTA relay

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Posts
    23
    Rep Power
    9

    Default admin reports being sent to MTA relay

    Since my upgrade to 4.5.6 Opensource from 4.0.5, the daily reports are being sent to the "Relay MTA for External delivery" which in turn returns an error about relaying. Normal outgoing mails gets delivered fine using this setup.

    For my MTA trusted networks I have 127.0.0.0/8 and two other networks that have interfaces connected to the mail server (172.20.200.0/24 and 192.168.200.0/24).

    I have Enable DNS Lookups unchecked.

    I have searched through the forums and just have not come across a post that has resolved this.

    Attached is a log of what occurs. Mail from the root account gets delivered just fine. I have some reports that run as root (from cron) and the emails get delivered.

    My logwatch report and daily mail report no longer get delivered because they are sent to the MTA relay.

    Any ideas or links that could help me out would be greatly appreciated.

    Thanks

    Don Hickey
    Attached Files Attached Files

  2. #2
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    It looks like your zimbra doesn't believe that "mail.oneidatel.net" is a valid domain.

    Do you have that setup as a domain? If not, do that and create an admin@mail.oneidatel.net account (or an alias on another account) for that mail to be dropped into.

  3. #3
    Join Date
    Feb 2006
    Posts
    23
    Rep Power
    9

    Default

    I got the admin reports working. I had a typo. They are now being delivered to my admin account.

    I still need to get the logwatch reports working...

    Thanks

    Don

  4. #4
    Join Date
    Feb 2006
    Posts
    23
    Rep Power
    9

    Default

    I got my logwatch reports working by changing the

    MailTo =

    to my user account in zimbra.

    This was located in /etc/log.d/conf/logwatch.conf

    I know something is still wrong since this all worked before my upgrade to 4.5.6. So now I am just doing work-arounds to get around the problem...

    I have a couple other programs (nagios and rancid) that email items also. I need to see if those work. I just can't figure out what might have changed when I did the upgrade...

    Don

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Can you file an enhancement for this?
    I looked and couldn't find an easy way (I just might be missing it).

    john

  6. #6
    Join Date
    Feb 2006
    Posts
    23
    Rep Power
    9

    Default

    I am by now means a email expert, but I am wondering if my /etc/aliases is not being used. For instance when I configured rancid I had to make these changes to my /etc/aliases file...



    # Rancid groups
    rancid-admin-oneida: rancid-oneida
    rancid-oneida: dhickey


    rancid-admin-wiv: rancid-wiv
    rancid-wiv: dhickey
    dhickey: dhickey@mynospamdomain.net

    When I was running 4.0.5 this worked fine. The reports on the differences on my cisco configs were emailed to that email address. Now they are being sent the the mail relay I have configured for our out going mail and of course they are being rejected because of the relaying.

    I could be way off on this, I am going to work on my nagios setup and see what it does. All if this worked before I did my upgrade....

    Hmmm the nagios account works fine.
    Don
    Last edited by dhickey; 09-14-2007 at 12:41 PM. Reason: update

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. Relay MTA for external delivery
    By endorphine44 in forum Administrators
    Replies: 16
    Last Post: 05-08-2009, 08:24 AM
  3. Broken? Max msg/attachment size in admin MTA page
    By Henrik in forum Installation
    Replies: 5
    Last Post: 09-26-2006, 08:45 AM
  4. send *all* email through relay mta ?
    By keithop in forum Administrators
    Replies: 7
    Last Post: 07-24-2006, 02:27 AM
  5. Server Stats Cont...
    By DMRDave in forum Administrators
    Replies: 15
    Last Post: 02-16-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •