Results 1 to 4 of 4

Thread: Could not start kstartupconfig error!

  1. #1
    Join Date
    May 2007
    Posts
    40
    Rep Power
    8

    Default Could not start kstartupconfig error!

    Hello, Dear all,

    I got error message : "could not start kstartupconfig, check your installation" when I logon to linux system after deployment of ldap and samba extension on my OpenSuse10.2


    all extensions package deployed successully, and samba domain created and I can see two addtional tab in Zimbra Admin UI,

    I enable ldap-client on one desktop(nss_ldap and pam_ldap installedI ), when logon with the created username from linux desktop, always get this error message. What 's the problem? do I need copy all .conf file to client pc also? thanks!

    by the way, I'd like to answer one thread that I post last week about where the nss_ldap.conf and pam_ldap.conf are, now I found that only one file called /etc/ldap.conf used in opensuse.


    the all related .conf file that located on the server installed samba as below.

    /etc/ldap.conf

    Code:
    # The distinguished name of the search base.
    base dc=roquette,dc=cn
    host 192.168.2.161
    binddn uid=zimbra,cn=admins,cn=zimbra
    bindpw roquette
    rootbinddn uid=zimbra,cn=admins,cn=zimbra
    /etc/nsswitch.conf
    Code:
    # passwd: files nis
    # shadow: files nis
    # group:  files nis
    
    #passwd: compat
    #group:  compat
    
    passwd: files ldap
    group: files ldap
    
    hosts:  	files dns
    networks:	files dns
    
    services:	files
    protocols:	files
    rpc:		files
    ethers:		files
    netmasks:	files
    netgroup:	files nis
    publickey:	files
    
    bootparams:	files
    automount:	files nis
    aliases:	files
    /etc/samba/smb.conf

    Code:
    [global]
    	workgroup = roquette.cn
    	printing = cups
    	printcap name = cups
    	printcap cache time = 750
    	cups options = raw
    	map to guest = Bad User
    	include = /etc/samba/dhcp.conf
    	logon path = \\%L\profiles\.msprofile
    	logon home = \\%L\%U\.9xprofile
    	logon drive = P:
    	usershare allow guests = Yes
    	add machine script = /sbin/yast /usr/share/YaST2/data/add_machine.ycp %m$
    	domain logons = Yes
    	domain master = Yes
    	ldap admin dn = "uid=zimbra,cn=admins,cn=zimbra"
    	ldap delete dn = No
    	ldap group suffix = ou=groups
    	ldap idmap suffix = 
    	ldap machine suffix = ou=machines
    	ldap passwd sync = No
    	ldap replication sleep = 1000
    	ldap ssl = Start_tls
    	ldap suffix = dc=roquette,dc=cn
    	ldap timeout = 5
    	ldap user suffix = ou=people
    	local master = Yes
    	netbios name = stf03a
    	os level = 65
    	passdb backend = ldapsam:ldap://192.168.2.161
    	preferred master = Yes
    	security = user
    [homes]
    	comment = Home Directories
    	valid users = %S, %D%w%S
    	browseable = No
    	read only = No
    	inherit acls = Yes
    /etc/pam.d/common-account
    Code:
    account	sufficient	pam_unix2.so	
    account sufficient      pam_ldap.so
    /etc/pam.d/common-auth

    Code:
    auth    sufficient      pam_ldap.so
    auth	sufficient	pam_unix2.so
    /etc/pam.d/common-password

    Code:
    # password	requisite	pam_pwcheck.so	nullok cracklib 
    # password	required	pam_unix2.so	nullok use_authtok 
    password	sufficient	pam_unix2.so	
    password        sufficient      pam_ldap.so
    /etc/pam.d/common-session

    Code:
    #session	required	pam_limits.so
    #session	required	pam_unix2.so	
    #session	optional	pam_umask.so
    session         sufficient      pam_unix2.so
    session         sufficient      pam_ldap.so
    #session	        optional	pam_umask.so
    session         required        pam_mkhomedir.so skel=/etc/skel umask=0077
    Attached Images Attached Images

  2. #2
    Join Date
    May 2007
    Posts
    40
    Rep Power
    8

    Default addtional information!

    other informat:

    if I logon with root and create one folder the name as username in home direcotry, e.g /home/bylong , bylong is a username.
    and change owner by issuing command # chown bylong /home/bylong
    then everything is ok.

    thus, I guess there are something wrong with
    /etc/pam.d/common-session file

    Code:
    #session	required	pam_unix2.so	
    #session	optional	pam_umask.so
    session         sufficient      pam_unix2.so
    session         sufficient      pam_ldap.so
    #session	        optional	pam_umask.so
    session         required        pam_mkhomedir.so skel=/etc/skel umask=0077
    system seems did not invoke pam_makhomedir.so to create user home folder when user fisrt logon.

    what 's that reason? many thanks in advance!

  3. #3
    Join Date
    May 2007
    Posts
    40
    Rep Power
    8

    Default

    no one answer? help please!

  4. #4
    Join Date
    May 2007
    Posts
    40
    Rep Power
    8

    Default

    the problem sovled by myself, now it is ok. I 'd like to share it with you all, especially with Suse user.

    in fact , it is very simple, no need exactly follow the steps on the guide to config common-account,common-auth, common-account and common-session. just enable ldap client in Yast, and make sure to tick 'make home directory' option is on. all settings for these files automatically be written. after that run SuSEconfig to make all configuration reloaded.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. Error Installing Outlook Connector
    By DanO in forum Zimbra Connector for Outlook
    Replies: 17
    Last Post: 08-28-2007, 10:35 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  4. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-15-2005, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •