We just installed the Zimbra M2 Network beta and I have been testing it for performance, and ease of migration. I have all of my old email stored locally in Thunderbird (v1.0.7), and I am trying to copy them through an IMAP connection to the Zimbra server. If I just copy a few messages at a time, things seem to work smoothly. Large copies (1665 messages) cause problems however. The copy process takes quite a long time, an sometimes stops before it finishes. (In my latest attempt, 1556 messages were copied out of 1665).

The second problem is that many of the messages I've copied in have no text or anything else. Under Thunderbird, the subject is blank, the sender is blank, and the date is 12/31/1969 5:00 PM. Strangly the web interface shows the proper time, but also no subject etc. Of the 1556 messages that I copied, roughly 1/4 are blanks.

I have my view set to show 50 messages at a time in the web interface. If I select 50 of the blank messages and delete them, Firefox (or IE) works for a bit, and then an error appears which reads "Could not complete operation". The dropdown error message reads
0 - P
1 - e
2 - r
3 - m
4 - i
5 - s
6 - s
7 - i
8 - o
9 - n
10 -
11 - d
12 - e
13 - n
14 - i
15 - e
16 - d
17 -
18 - t
19 - o
20 -
21 - g
22 - e
23 - t
24 -
25 - p
26 - r
27 - o
28 - p
29 - e
30 - r
31 - t
32 - y
33 -
34 - U
35 - n
36 - n
37 - a
38 - m
39 - e
40 - d
41 - C
42 - l
43 - a
44 - s
45 - s
46 - .
47 - f
48 - i
49 - l
50 - e
51 - n
52 - a
53 - m
54 - e

If I click OK on the error message, the web interface gets stuck (with hourglass), and I have to refresh to get anything back from it. The messages DO get deleted, and are gone when I refresh. Deleting non-blank messages, or doing any other multi-message operations seem to cause this problem as well. For instance, I just moved 50 messages into a new folder, and got the same error.

Large deletes via IMAP seem to work fine.

Is anyone else having similar problems when they attempt operations with large sets of email?

thanks,

Sam