Results 1 to 4 of 4

Thread: Indexing - Search problem

  1. #1
    Join Date
    Dec 2005
    Posts
    94
    Rep Power
    10

    Default Indexing - Search problem

    Running 4.5.6 OSS on Centos4

    Having some trouble with searches on at least two different accounts.
    For example:

    • Right Click a message in the inbox and choose the "Search" option.
    • That will create a search "from:(someuser@someisp.net)", but no results.


    It doesn't matter if you manually input the search critera or if you use the GUI Advanced Search still no results.

    Re-Indexed the mailbox from the admin UI - 0 messages failed, still no results.

    For many (most?) messages search works fine - there are just a few that don't. Haven't been able to find any common feature with the ones that don't show up.

    Here's another example - "has:attachments" returns many messages with attachments, but not all. I have to manually scroll through a few hundred messages to find a particular attachment.

    I'm not sure where to go hunting from here
    Last edited by brained; 09-12-2007 at 12:58 AM. Reason: Details Added

  2. #2
    Join Date
    Dec 2005
    Posts
    94
    Rep Power
    10

    Default

    Still having problems after an update to 4.5.7

    I've been continuing my research into this issue and have found this.
    Is it related to the problem I am having?

    Code:
    2007-10-04 10:32:31,709 WARN  [LmtpServer-118] [] ParsedMessage - exception while analyzing message; message will be partially indexed
    java.lang.NullPointerException
            at com.zimbra.cs.mime.MimeHandler$HandlerInfo.getInstance(MimeHandler.java:401)
            at com.zimbra.cs.mime.MimeHandler.getMimeHandler(MimeHandler.java:117)
            at com.zimbra.cs.mime.ParsedMessage.analyzePart(ParsedMessage.java:587)
            at com.zimbra.cs.mime.ParsedMessage.analyzeMessage(ParsedMessage.java:532)
            at com.zimbra.cs.mime.ParsedMessage.analyze(ParsedMessage.java:252)
            at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliverMessageToLocalMailboxes(ZimbraLmtpBackend.java:249)
            at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver(ZimbraLmtpBackend.java:122)
            at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHandler.java:420)
            at com.zimbra.cs.lmtpserver.LmtpHandler.processCommand(LmtpHandler.java:197)
            at com.zimbra.cs.tcpserver.ProtocolHandler.processConnection(ProtocolHandler.java:231)
            at com.zimbra.cs.tcpserver.ProtocolHandler.run(ProtocolHandler.java:198)
            at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Thread.java:619)
    Last edited by brained; 10-04-2007 at 11:17 PM.

  3. #3
    Join Date
    May 2008
    Location
    Tallahassee, Florida
    Posts
    89
    Rep Power
    7

    Default

    Did you come up with a solution to this problem?

  4. #4
    Join Date
    Aug 2007
    Posts
    103
    Rep Power
    8

    Default

    Do you see errors in the mailbox.log when trying to index?

Similar Threads

  1. [SOLVED] Searching message headers?
    By gkra in forum Users
    Replies: 2
    Last Post: 08-11-2007, 09:26 AM
  2. Shared Contact Search Problem
    By chalkboy in forum Administrators
    Replies: 1
    Last Post: 07-31-2007, 04:24 PM
  3. Problem with resource search
    By hlandgar in forum Installation
    Replies: 7
    Last Post: 04-26-2007, 09:24 PM
  4. Search problem for ZCS documents
    By bellzerr in forum Users
    Replies: 3
    Last Post: 09-27-2006, 06:38 AM
  5. A problem about the Search.
    By sshgz in forum Users
    Replies: 7
    Last Post: 08-02-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •