Results 1 to 2 of 2

Thread: Two remaining problems with Zimbra+Samba

  1. #1
    Join Date
    Jul 2007
    Rep Power

    Default Two remaining problems with Zimbra+Samba

    I have it installed, I have it working, and I have everything almost how I want it with two exceptions.

    1. New user home directories are not being created automatically. My /etc/pam.d/common-session does contain the line
    session         required        skel=/etc/skel umask=0077
    but it doesn't seem to work.

    I currently have a bash script that I run after creating new users
    sudo mkdir /home/$1
    sudo cp /etc/skel/.* /home/$1/
    sudo chown -R $1:mvstaff /home/$1
    but that really doesn't make sense and is prone to error (I forgot one and now even after fixing it whenever that user tries to log on to the first laptop he tried to use, his profile is totally borked)

    2. I have no idea how to assign a user to multiple groups. I'm used to "The UNIX Way" where each user has a group named after themself immediately upon creation and I can 'adduser <user> <group>' to provide them with access to various things that I've given to other groups. I can deal without the user-named groups as I've never really seen a point to that, but I have a plethora of shared drives where different users need to have different permissions on a group by group basis. Right now, my users can access our company-wide share RW, but myself and the other admin (who are in the group domainadmins rather than mvstaff) only have RO permission. Previously, I had 'staff', 'admins', 'accounting', etc. and could construct my shared folders nouser:<group> with 775 or 770 permissions as the situation demanded.

    edit: I guess this might be important --

    Zimbra: Latest NE on Ubuntu 7.04
    Samba host: Debian Etch x86-64 fully up to date

    Both the Debian and Ubuntu boxes are kept 100% within their respective packaging repositories with the exception of obviously Zimbra on the Ubuntu box and VMware Server on the Debian box. Everything else is installed straight from packages and thus should be fully duplicable.
    Last edited by wolrah; 09-17-2007 at 02:09 PM.

  2. #2
    Join Date
    Jan 2008
    Ashland, Oregon
    Rep Power

    Default Same place/same problems

    Works great except for the homes and groups. Did you ever figure the Group thing out? as it makes file permissions soooo much easier.

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  2. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  3. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM
  4. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts