Results 1 to 8 of 8

Thread: sending mail failed (mail for mydomain.com loops back to myself)

Hybrid View

  1. #1
    Join Date
    Sep 2007
    Posts
    5
    Rep Power
    8

    Default sending mail failed (mail for mydomain.com loops back to myself)

    Dear Expert,

    I have problem with Zimbra sending mail, at the zimbra log it write :
    sep 24 17:..:.. mail2 postfix/smtp[295xx] 95BE....... to=<somebody@mydomain.com>, relay=none, delay=2, status=bounced (mail for mydomain.com loops back to myself)
    sep 24 17:..:.. mail2 slapd[59xx] <=bdb_equality_candidates: (ZimbraMailStatus) index_param failed (18)
    sep 24 17:..:.. mail2 slapd[59xx] <=bdb_equality_candidates: (ZimbraDomainType) index_param failed (18)
    sep 24 17:..:.. mail2 slapd[59xx] <=bdb_equality_candidates: (ZimbraMailStatus) index_param failed (18).....

    after that my queued mail has been deleted

    for your known this zimbra mail server which has domain mail2.mydomain.com to backup mail.mydomain.com at different server
    this mail2.mydomain.com running as guest at vmware server
    my NS record ready like this:
    mydomain.com 86400 IN MX 10 mail.mydomain.com
    mydomain.com 86400 IN MX 10 mail2.mydomain.com

    mail.mydomain.com 86400 IN A xxx.xxx.xxx.172
    mail2.mydomain.com 86400 IN A xxx.xxx.xxx.165

    i can received email from somebody@mydomain.com

    appreciate you can help me

    regard
    Choeer

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Welcome to the forums.

    This has been covered before in the forums, a quick search would find the answer. If you're behind a router you will need a split DNS setup, you should also check the 'mynetworks' setting (search the forum or wiki for that.

    You can also check if your DNS (and hostname) settings are correct by running the following commands on the Zimbra server:

    Code:
    host `hostname`  <-- run that command 'as-is' with backticks not single quotes
    dig yourdomain.com mx
    dig yourdomain.com any
    You can check the /etc/host settings in the forums or in the Quick Start Installation Guide.

    It would also help if you updated your profile with the version of Zimbra you're running, you can get that with 'zmcontrol -v' and tell us which operating system you're running.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2007
    Posts
    5
    Rep Power
    8

    Default

    Hi Bill,

    My system use Linux Ubuntu 6.06 LTS, and zimbra i use zcs-4.5.5_GA_838.Ubuntu6, my vmware guest I use Ubuntu 6.06 LTS too

    what i want to know is : what zimbra doing on install when it check DNS, because i have check it with your suggest

    Host 'mail2.mydomain.com' returned
    mail2.mydomain.com has address xxx.xxx.xxx.165
    i use single
    '
    not back
    `
    because this not
    valid command

    dig mydomain.com mx
    ........
    ;; QUESTION SECTION:
    ;mydomain.com. IN MX

    ;; ANSWER SECTION:
    ;mydomain.com. 86400 IN MX 10 mail.mydomain.com.
    ;mydomain.com. 86400 IN MX 10 mail2.mydomain.com.

    ;; AUTHORITY SECTION:
    ;mydomain.com 86400 IN NS ns1.mydomain.com.
    ;mydomain.com 86400 IN NS ns2.mydomain.com.

    ;; ADDITIONAL SECTION:
    ;mail.mydomain.com 86400 IN A xxx.xxx.xxx.172
    ;mail2.mydomain.com 86400 IN A xxx.xxx.xxx.165
    ;ns1.mydomain.com 86400 IN A xxx.xxx.xxx.174
    ;ns2.mydomain.com 86400 IN A xxx.xxx.xxx.173
    I think my vmware guest with bridge can resolve my NS address as well

    but i will try to change like wiki MyNetworks change the SMTP relay my loopback 127.0.0.1 to xxx.xxx.xxx.165

    if i should use dns split i will try it later.

    thankyou for your great way out

    Regards
    Choeer

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You'll need a Split DNS setup as I mentioned earlier. The problem you're experiencing is that Zimbra (postfix) can not resolve the LAN IP address of the server. Run this command exactly as you see it:

    Code:
    host `hostname`  <-- copy/past this command and run it.
    Do not put your host name in there, use the word hostname.

    Do NOT remove the 127.0.0.1 from the mynetworks config, you need that in there as well as your LAN subnet. Do not make changes unless you need to, I asked you to check the settings for mynetworks not modify it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jul 2006
    Location
    New York, NY
    Posts
    122
    Rep Power
    9

    Default

    I've seen this recently by a mistake I made in the Admin.

    What do you have set for

    Web mail MTA Hostname:
    Web mail MTA Port: 25
    Relay MTA for external delivery:

    In the administration console under global settings and the MTA tab?
    Also check each server under "Servers" cause there is a MTA tab there to.
    Because we all can't be geniuses, I'll go first.

  6. #6
    Join Date
    Sep 2007
    Posts
    5
    Rep Power
    8

    Default

    hi Glitch23

    After check my

    servers>mail2.mydomain.com MTA tab :
    Web mail MTA hostname : mail2.mydomain.com
    Web mail MTA Port : 25
    Relay MTA for external Delivery : (blank)

    Global Settings MTA Tab :
    Web mail MTA hostname : localhost
    Web mail MTA Port : 25
    Relay MTA for external Delivery : (blank)

  7. #7
    Join Date
    Sep 2007
    Posts
    5
    Rep Power
    8

    Default

    hi Bill,


    Quote Originally Posted by phoenix View Post
    You'll need a Split DNS setup as I mentioned earlier. The problem you're experiencing is that Zimbra (postfix) can not resolve the LAN IP address of the server.
    As i know if my vmware guest use bridge network i can use public IP not LAN IP (not use NAT networking)

    Quote Originally Posted by phoenix View Post
    Run this command exactly as you see it:
    Code:
    host `hostname`  <-- copy/past this command and run it.
    Do not put your host name in there, use the word hostname.
    Sorry for my mistaken about your instruction, here the result :
    host `hostname`
    mail2.mydomain.com has address 'xxx.xxx.xxx.165'

    Quote Originally Posted by phoenix View Post
    Do NOT remove the 127.0.0.1 from the mynetworks config, you need that in there as well as your LAN subnet. Do not make changes unless you need to, I asked you to check the settings for mynetworks not modify it.
    I check on WIKI>Mynetworks i found zimbra setting on Debian's Vserver (Install VServer - ZimbraWiki) rules... i try as instruction there, after that i can look at console that my mail has deferred(before i didn't see this), now i change it back to the default isntall
    Last edited by choeer; 09-28-2007 at 02:34 AM.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 04:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •