Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: [SOLVED] Some Outside emails are being delayed.

  1. #1
    Join Date
    Oct 2006
    Posts
    151
    Rep Power
    9

    Default [SOLVED] Some Outside emails are being delayed.

    HELP!!!

    using open source ubuntu version 4.5.6

    all internal mail is being delivered, only SOME of external, (appears to be completely random.) is being delivered.

    Turned of spam And AV with no luck, senders are getting "gave up trying to send" or "will send later", or nothing at all.

    Server seems to respond correctly when testing with hotmail/yahoo etc.

    has been working for a month, we turned off on friday to move it to the server room, then this happened.

    Please help.. Will pay for support!!

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by tbovingdon
    Will pay for support!!
    -that's what the NE version is for afterall

    I'm going to assume 'outside' & 'external' means 'incoming' (& we're not talking about a mynetworks problem)

    -first some excerpts from your /var/log/zimbra.log (any error code #'s would be helpful)

    -what dns & protocal checks to you have enabled in the mta tab?
    Last edited by mmorse; 10-02-2007 at 07:17 PM.

  3. #3
    Join Date
    Oct 2006
    Posts
    151
    Rep Power
    9

    Default

    No DNS checks
    protocols are:
    Hostname in greeting violates RFC (reject_invalid_hostname)
    Sender address must be fully qualified (reject_non_fqdn_sender)
    actuall domain has been removed and replaced with example.* if we could remove all email addresses that would be great i am horrible with regular expressions

    please pm if you need actual

    !!log file removed due to actual email addresses ... don't want to add to spam problem!!!
    Last edited by tbovingdon; 10-03-2007 at 12:14 PM.

  4. #4
    Join Date
    Oct 2006
    Posts
    151
    Rep Power
    9

    Default example of bounce back

    Code:
    Recipient: <dennis@example.com>
        Reason:    5.1.1 <dennis@example.com>: Recipient address rejected: mail
    for example.com is not deliverable
    Code:
    Sorry. Your message could not be delivered to:
    
    example.com
            (could not contact host after 4 attempt(s))
    Code:
    Hi. This is the qmail-send program at yahoo.com.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.
    
    <dave@example.com>:
    216.183.x.x failed after I sent the message.
    Remote host said: 421 mail.example.ca Error: timeout exceeded I'm not going to try again; this message has been in the queue too long.
    Last edited by tbovingdon; 10-02-2007 at 01:33 PM. Reason: added bounces

  5. #5
    Join Date
    Oct 2006
    Posts
    151
    Rep Power
    9

    Default update

    i can telnet successfully to server through local network
    but cannot access through dns

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    nothing makes it into the queue's?

    is your domain by chance hosted off of w------n.ca?
    I also saw some references to i-------s.ca & t----s.ca & b--s.com
    Last edited by mmorse; 10-02-2007 at 06:40 PM.

  7. #7
    Join Date
    Oct 2006
    Posts
    151
    Rep Power
    9

    Default

    no..

    apparently i need to type more that "no"

  8. #8
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    ya that 10 char min...

    Just wanted to check/make sure you weren't hosting at/using the name servers returned from the domain off the end of your present ip address-as it looks like that provider has some dns issues they need to fix
    -you could just be on tor or a proxy anyway
    -or it could be from home
    -etc, etc

    run some dig's
    you can check your own mx records here as well: Quick Check - Pingability.com
    Last edited by mmorse; 10-02-2007 at 09:01 PM.

  9. #9
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    In your log & one of the bounces "timeout after DATA" & "lost connection after DATA" & "421 mail.example.ca Error: timeout exceeded" would have me thinking smtpd_timeout values

    but then your one bounce 'recipient address rejected' would usually be something in smtpd_recipient_restrictions/smtpd_client_restrictions

    attempting to combine those random thoughts-do you have anything in a smtpd_data_restrictions value?

    hm-some web searches find a lot a MTU issues for people with 'timeout after DATA'
    Last edited by mmorse; 10-02-2007 at 06:06 PM.

  10. #10
    Join Date
    Oct 2006
    Posts
    151
    Rep Power
    9

    Default

    smtpd_timeout .... this server is just behind a regular dsl connection.. is it possible the server doesn't have enough time to respond with all the other connections in and out of the router etc?

Similar Threads

  1. Errors because of Deffered emails
    By mansuper in forum Administrators
    Replies: 0
    Last Post: 11-20-2006, 03:08 PM
  2. Deleting emails before a particular date
    By mansuper in forum Zimbra in Education
    Replies: 6
    Last Post: 11-16-2006, 01:57 PM
  3. zmpurgemessages leaving emails in inbox
    By brousky in forum Administrators
    Replies: 2
    Last Post: 11-02-2006, 10:02 AM
  4. Not receiving emails
    By koby in forum Installation
    Replies: 2
    Last Post: 08-28-2006, 03:29 AM
  5. emails don't show up in inbox in browser
    By pstelzer in forum Installation
    Replies: 10
    Last Post: 12-13-2005, 09:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •