Results 1 to 8 of 8

Thread: upgrading from zimbra 5 beta 3 to rc1 (suse 10) failing

  1. #1
    Join Date
    Mar 2006
    Posts
    67
    Rep Power
    9

    Default upgrading from zimbra 5 beta 3 to rc1 (suse 10) failing

    I tried to upgrade from zcs 5 b3 to rc1 on suse 10 and got:

    /opt/zimbra/openldap/sbin/slapcat: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

    then during the install I get this loop:

    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.log.32530
    Checking ldap status
    Starting ldap
    ldap startup failed with exit code 256
    Checking ldap status
    Starting ldap
    ldap startup failed with exit code 256
    Setting defaults...Checking ldap status
    Starting ldap
    ldap startup failed with exit code 256
    Checking ldap status
    Starting ldap
    ldap startup failed with exit code 256

    I'm trying to go back to b3, but that is not working either at the moment.

    any ideas on fixing this?

  2. #2
    Join Date
    Mar 2006
    Posts
    67
    Rep Power
    9

    Default

    now I see what happened. I wasn't paying attention and it looks like zimbra has 10.0 download link pointed to the 10.2 installer and the suse 10.2 link pointing to the 10.0 installer. Hmm. I think I message my zimbra install. I finally noticed (should have looked closer) that it was saying it was installing on a diff platform. arrgh.

  3. #3
    Join Date
    Mar 2006
    Posts
    67
    Rep Power
    9

    Default

    ok how do I install rc1 ontop of a messed up install - aren't the emails and accounts still there?

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  5. #5
    Join Date
    Jun 2007
    Location
    Hong Kong
    Posts
    62
    Rep Power
    8

    Red face

    HI, I also got the upgrade problem.... in which I noticed that we have wrongly installed the 5.0.0_BETA3_1276.SuSEES10_20070822161025 on our OpenSUSE 10.2 box in previous upgrade from 4.5.x .....

    That would be the reason why we cannot upgrade from 5.0 beta 3 to 5.0 rc1 as we have downloaded the file of zcs-5.0.0_RC1_1538.openSUSE_10.2.20071002165254.tgz for the upgrade, error found while upgrading the core component...

    So now, can we change back ZCS to use the openSUSE version? What should we do to correct previous fault? Many thanks~

    comptekki: For a messed system (After the failed upgrade, we even cannot uninstall the zcs or startup it...), what we do is re-install the original version of ZCS, and then swap the new zimbra folder (bad one) with the original one from backup tar file! Need to take care is, we found the three files (zmsyslogsetup, zmlogrotate, zimbra) are changed back to fresh installed look....) so we just re-performed the installation procedure EXCEPT the actual ZCS install part, it works now with the original version before upgrade! And ALL of the emails, shared documents & briefcase, accounts, dist. lists... are all remain the same~

    Hope this could give you some hints~
    Last edited by wcbenyip; 10-08-2007 at 10:47 PM. Reason: [update]
    OS=Ubuntu 8.04 LTS
    Current: Release 5.0.10_GA_2638.UBUNTU8 UBUNTU8 FOSS edition
    OS=openSUSE 10.3
    Current: Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN FOSS edition
    Prior: Release 4.5.6_GA_1044.SuSE10_20070706142147 openSUSE_10.2 FOSS edition

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    It seems he moved his convo to here /forums/administrators/11984-fix-hosed-zimbra-putting-10-2-10-0-suse.html
    But that got a little complicated, hold on a sec and someone will explain some solutions you have.
    Last edited by mmorse; 10-08-2007 at 10:53 PM.

  7. #7
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    It all depends on where the install failed at. Odds are, it failed early. If that's the case, then reinstall your old version using the -s option. You need to install OVER the failed install. If you uninstall, you'll wipe your data.

    Before you do ANYTHING, backup your data.

    Your LDAP/MySQL passwords are likely out of sync, so you'll need to fix that.
    See here for more: Resetting LDAP & MySQL Passwords - ZimbraWiki

    Most importantly, when you get an error, copy and paste it.
    Last edited by jholder; 10-08-2007 at 10:54 PM.

  8. #8
    Join Date
    Jun 2007
    Location
    Hong Kong
    Posts
    62
    Rep Power
    8

    Exclamation

    [Re-post]

    HI, I also got the upgrade problem.... in which I noticed that we have wrongly installed the 5.0.0_BETA3_1276.SuSEES10_20070822161025 on our OpenSUSE 10.2 box in previous upgrade from 4.5.x .....

    That would be the reason why we cannot upgrade from 5.0 beta 3 to 5.0 rc1 as we have downloaded the file of zcs-5.0.0_RC1_1538.openSUSE_10.2.20071002165254.tgz for the upgrade, error found while upgrading the core component...

    So now, can we change back ZCS to use the openSUSE version? What should we do to correct previous fault? Many thanks~

    comptekki: For a messed system (After the failed upgrade, we even cannot uninstall the zcs or startup it...), what we do is re-install the original version of ZCS, and then swap the new zimbra folder (bad one) with the original one from backup tar file! Need to take care is, we found the three files (zmsyslogsetup, zmlogrotate, zimbra) are changed back to fresh installed look....) so we just re-performed the installation procedure EXCEPT the actual ZCS install part, it works now with the original version before upgrade! And ALL of the emails, shared documents & briefcase, accounts, dist. lists... are all remain the same~

    Hope this could give you some hints~
    OS=Ubuntu 8.04 LTS
    Current: Release 5.0.10_GA_2638.UBUNTU8 UBUNTU8 FOSS edition
    OS=openSUSE 10.3
    Current: Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN FOSS edition
    Prior: Release 4.5.6_GA_1044.SuSE10_20070706142147 openSUSE_10.2 FOSS edition

Similar Threads

  1. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  2. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 07:29 PM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  4. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 07:47 AM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •