Results 1 to 3 of 3

Thread: sending and receiving email out multiple internet connections

Hybrid View

  1. #1
    Join Date
    Nov 2005
    Posts
    175
    Rep Power
    10

    Default sending and receiving email out multiple internet connections

    Ok guys, I have myself thoroughly confused. Maybe someone out there can help me. Zimbra's insistence on caring a lot about DNS settings combined with my fear of changing its hostname (due to past bad experiences) and my desire to use multiple internet connections for sending out email has gotten me all fouled up.

    First of all, my old mail server's name was mail.mydomain.com, so while building up the Zimbra server, I called it mail2.mydomain.com, so I could do some live testing. Afraid to change the Zimbra server's FQDN after I got it all running, I just left it that way. Things are actually working ok, but I do anticipate a few problems (see below).

    I have 3 internet connections for load balancing and failover. Sometimes the one my Zimbra server uses gets a bit full, so I'd like to sometimes utilize the bandwidth of my other connections. I set up PTR and A records for all 3 connections, calling them mail.mydomain.com, mail2.mydomain.com, and mail3.mydomain.com, thinking that was a good idea. Well, the first problem with that is that my Zimbra server is claiming to be mail2.mydomain.com, which, of course, if you do a reverse lookup, you get back an IP address that the Zimbra server isn't currently sending mail out on (currently it's only using the connection that reverses back as mail.mydomain.com). Some AS filters may not like that. I guess I'd better change mail2.mydomain.com to point to the same thing as mail.mydomain.com for the time being, to alleviate that problem.

    However, that begs the question. What IF I want to send mail out on any or all of the connections? Can't I do that without infuriating AS filters? How should my PTR records be set up? My A records? And how are those PTR and A records for all 3 internet connections supposed to match up with the FQDN that my Zimbra server claims to be when it sends its HELO?

    Seems that receiving mail on all 3 connections ought to be easy. Just set up multiple MX records with the same priority (or not, depending on what your intentions are with regards to load balancing or failover). Perhaps sending email out on all 3 connections is not so easy? At any rate, I'm confused. Any thoughts?

  2. #2
    Join Date
    Nov 2005
    Posts
    175
    Rep Power
    10

    Default

    This is a shameless bump.

  3. #3
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default

    Is your server hooked directly to the internet or through a nat router?

    Do you have multiple NIC's in your server?

Similar Threads

  1. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  2. Replies: 3
    Last Post: 08-23-2006, 05:42 PM
  3. Sending but not receiving
    By pbwebguy in forum Administrators
    Replies: 11
    Last Post: 06-22-2006, 01:58 AM
  4. Not receiving email
    By dlsalter in forum Administrators
    Replies: 4
    Last Post: 06-08-2006, 11:57 PM
  5. Problem sending and Receiving mail
    By geroshea in forum Installation
    Replies: 3
    Last Post: 03-06-2006, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •