Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: FC4 New Install : Send OK but No receive

  1. #11
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default connection refused

    This is an lmtp failure - is this resolving to a firewall? The firewall needs to forward port 7025 to the zimbra server. (Or, is the zimbra server running the default redhat firewall? If so, you'll need to either turn it off, or allow port 7025 through.)

  2. #12
    Join Date
    Dec 2005
    Location
    Worthing, West Sussex, UK
    Posts
    16
    Rep Power
    9

    Default

    I have already added a port forwarding rule from my dsl modem router from port 7025 to my Zimbra box (Ip 192.168.0.5)

    I will investigate to see if the FC4 firewall is indeed installed and blocking the port.

    Time for a google i guess!

    Happy New Year from the UK.

    Matthew

  3. #13
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If you're behind a router then the firewall is only a hindrance while you're testing stuff. If you want to disable it the run System Settings -> Security Level and set the firewall to disabled. I believe that's correct for FC4 but I don't actually use that soo apologies in advance if it doesn't work.

    Happy New Year to you from France.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    Join Date
    Dec 2005
    Location
    Worthing, West Sussex, UK
    Posts
    16
    Rep Power
    9

    Default

    Bon soir Bill,

    I have checked the Firewall in FC4 as you have suggested and it was already disabled.

    Any more thoughts or ideas from you or anyone else? I feel that it is something relatively straightforward that is not set up quite right.

    Matthew

  5. #15
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Hello Matthew

    Is this IP address your 'home' PC or a hosted machine? I did ask you earlier if you could telnet to that PC on port 25, does that get rejected or do you see a connection? Can you also telnet on port 7025 and see if the LMTP gives a response or not?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #16
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default telnet

    That's a good question - can you telnet to the hostname that shows up in the error, from the zimbra box, on port 7025?

  7. #17
    Join Date
    Dec 2005
    Location
    Worthing, West Sussex, UK
    Posts
    16
    Rep Power
    9

    Default

    Ok here are some telnet results;-

    On the Zimbra box
    telnet mail.greenwayschool.co.uk 7025
    trying 81.21.76.51............
    timeout exceeded connection closed by foreign host.

    telnet 192.168.0.5 7025 (local Ip of Zimbra box)
    trying 192.168.0.5...
    Connected to mail (192.168.0.5).
    Escape character etc
    220 mail Zimbra LMTP ready

    Also tried telnet 192.168.0.5 7025 from another box on home LAN and got
    220 mail Zimbra LMTP ready


    Is there any way I can check to see if fetchmail is retrieving the mail ok (from the external POP3 server) and that perhaps it is not getting into the zimbra users although it has made it into the box?

    Matthew

  8. #18
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    How did you set-up fetchmail? I use fetchmail to get mail from my ISP and webmin to manage that sort of thing, you can run a fetchmail from webmin and see the output listed when it gets the mail and what it retrieved.

    That output from telnet would indicate to me that the port is 'blocked' somewhere. You also don't have anything like SElinux on the box as well do you? Are you absolutely certain that port 7025 is forwarded through your router to the Zimbra box? What's also in your hosts file?
    Last edited by phoenix; 01-02-2006 at 09:17 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #19
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default telnet results

    The mail is not being delivered, since the postfix server can't access the host on it's public IP on port 7025. This is most likely a firewall issue. Can you telnet to that hostname on port 25?

  10. #20
    Join Date
    Dec 2005
    Location
    Worthing, West Sussex, UK
    Posts
    16
    Rep Power
    9

    Default

    Bill,

    I started with a fresh install of FC4 and I think fetchmail came as part of that. I created a fetchmail.rc file in home directory. I based the file on a fetchmail.rc file that I was using successfully on a ubuntu/hula-project mail server. The file content is as follows.

    poll pop.myisp.co.uk with proto POP3 and options uidl
    user myusername there with password mypassword is
    zimbra@schooldomain.co.uk


    The following port forwards on my home router are going to the local ip of the zimbra box. 25,80,110, 7071, 7025 & 7075. Each forward is straight i.e. 25->25.

    On the install I definitely chose to disable SELinux.

    Matthew

Similar Threads

  1. Only receive mail if I send it to hostname.domainname.com
    By mikeklingler in forum Administrators
    Replies: 6
    Last Post: 05-25-2007, 11:58 AM
  2. Replies: 3
    Last Post: 01-09-2007, 01:24 AM
  3. Can receive but send by using outlook express
    By mcmick in forum Administrators
    Replies: 0
    Last Post: 11-09-2006, 01:40 AM
  4. Can send but not receive
    By dbo in forum Installation
    Replies: 33
    Last Post: 08-15-2006, 11:05 AM
  5. Install Zimbra on FC4 by binaries file
    By vpoorboy in forum Developers
    Replies: 1
    Last Post: 10-20-2005, 11:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •