I've set up sqlgrey with Zimbra, and it works greyt.

However, in order to get sqlgrey running, you have to run the following command

zmprov mcf zimbraMtaRestriction "check_policy_service inet:127.0.0.1:2501"

Whenever I run that and restart Zimbra everything works great. It seems to survive reboots, etc.

However, every once in a while I realize that if I do a "gcf" on that setting it comes back blank and the email headers show no greylisting headers as they should. If I run the above command again, and restart Zimbra, everything works fine again. Is there anything that should be clearing out this setting? Am I setting it in the right place? It seems to survive reboots (at least sometimes), but maybe when I add a domain it gets upset? I really can't quite pin it down....

I'm running CE 4.5.8 by the way.