Results 1 to 10 of 22

Thread: [SOLVED] Maximum message size

Hybrid View

  1. #1
    Join Date
    Feb 2007
    Posts
    28
    Rep Power
    8

    Default [SOLVED] Maximum message size

    Hey folks,

    I'm having a problem with the Maximum message size not being honored.

    Current settings in the Admin -> Global Settings -> MTA:

    Maximum message size (kb):* 10240
    Maximum size of an uploaded file(kb):* 10240

    If I use Imap/Thunderbird to upload a file that is: 8,987 KB I get a message:

    "The size of the message you are trying to send exceeds the global size limit (10485760 bytes) of the server. The message was not sent, try to reduce the message size and try again."

    If I use the web client, I get the error:

    Could not send message: mail.SEND_FAILURE

    msg - SMTP server reported: null
    code - mail.SEND_FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Sender
    data - [object Object]

    Anything over roughly 6MB fails to upload.

    Any ideas on whats going on?

    Thanks,

    -Ken

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by mmorse View Post
    So, you might to set zimbraFileUploadMaxSize 10-30% > than your attachment.
    Also as a general rule, I set zimbraMtaMaxMessageSize 10% larger than the zimbraFileUploadMaxSize.

    If I understand this right...say both are set to 10MB (and you tell everyone they can send 10MB attachments):
    An email with a 9MB attachment and 100KB message body text. The attachment may be less than the 10MB zimbraFileUploadMaxSize, and so it'll get accepted by the file upload system. But when it's converted into a MIME message it ends up base64-encoded. Then add 100K of regular body text, and the resulting message (say 10.3MB or so) is then handed off to postfix, which checks zimbraMtaMaxMessageSize and promptly rejects the message if it's over the limit of 10MB.

    Of course that would mean that you would set zimbraMtaMaxMessageSize even larger if you want to allow emails with multiple large attachments.
    What are the attachments of (that their getting so big on conversion) ?

  3. #3
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  4. #4
    Join Date
    Feb 2007
    Posts
    28
    Rep Power
    8

    Default

    Quote Originally Posted by mmorse View Post
    What are the attachments of (that their getting so big on conversion) ?
    I've tried with both a tar.gz and an exe file. I'm not sure what the user that noticed the problem was originally trying to transfer though.

    The first two bugs aren't the issue, but the third 16225 looks to be the same issue.

    Thanks,

    -Ken

  5. #5
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    The first two are about fixing the error message in the web-client so it's more descriptive.
    Last edited by mmorse; 11-02-2007 at 04:53 PM. Reason: 'two' not 'to'

  6. #6
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default MIME inflation may explain this. . .

    You may not be dealing with a bug at all, Ken. Remember that when a binary attachment is sent by email it is first encoded into ASCII using either MIME or UUENCODE. Either results in fairly substantial inflation in message size, as explained in this article.

    Let's look at your specific example. You have a file that you tell us is 8,987 KB. Multiply that by 1,024 bytes per KB and you have 9,202,688 bytes. Now give that a 30% encoding overhead (the article I referenced says 30-40%) and you're up to 11,963,494 bytes. Sticking with kilobytes, though, since that's how the Zimbra system takes its settings, 8,987 kb times 30% inflation would be 11,683 KB, again over your stated limits.

    Let's do a real-world test. I have a message in my inbox that is reported by Zimbra as 10,544 KB. It's got only two lines of text, and a PDF attachment. When I save that attachment to my desktop and check its size with Windows, the resultant file is only 7.47 MB (7,835,426 bytes).

    Bottom line--file size and message size should not be confused. If you really want to limit your users to 10MB attachments, you probably need to limit the message size to more like 13 or 14 MB to allow that file size to come through. This is not a bug, it's how encoding of binary attachments works.

    Hope this helps,

    Dan

  7. #7
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    I think the thought on Bug 16225 - Discrepancy between zimbraFileUploadMaxSize and the actual upload size was to prevent anyone from setting 'FileUpload' less than 'MtaMax'

    And if that is implemented, then this will need to be done: Bug 19515 - Separate Max File Size for Briefcase

    ----
    UPDATE: See later post on why this should be warn instead of prevent! /forums/administrators/12600-maximum-message-size-2.html#post64950
    Last edited by mmorse; 11-05-2007 at 02:01 PM. Reason: don't want to prevent

  8. #8
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Quote Originally Posted by dwmtractor View Post
    You may not be dealing with a bug at all, Ken. Remember that when a binary attachment is sent by email it is first encoded into ASCII using either MIME or UUENCODE. Either results in fairly substantial inflation in message size, as explained in this article.

    Let's look at your specific example. You have a file that you tell us is 8,987 KB. Multiply that by 1,024 bytes per KB and you have 9,202,688 bytes. Now give that a 30% encoding overhead (the article I referenced says 30-40%) and you're up to 11,963,494 bytes. Sticking with kilobytes, though, since that's how the Zimbra system takes its settings, 8,987 kb times 30% inflation would be 11,683 KB, again over your stated limits.

    Let's do a real-world test. I have a message in my inbox that is reported by Zimbra as 10,544 KB. It's got only two lines of text, and a PDF attachment. When I save that attachment to my desktop and check its size with Windows, the resultant file is only 7.47 MB (7,835,426 bytes).

    Bottom line--file size and message size should not be confused. If you really want to limit your users to 10MB attachments, you probably need to limit the message size to more like 13 or 14 MB to allow that file size to come through. This is not a bug, it's how encoding of binary attachments works.

    What you say makes sense. The user reporting this issue hasn't replied so will repro this, this Monday, and check the behavior.

    Thanks for pointing to the article.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

Similar Threads

  1. Zimbra Email Size Limit
    By kurt2 in forum Administrators
    Replies: 7
    Last Post: 10-07-2009, 09:20 PM
  2. [SOLVED] message size error
    By reckless2k2 in forum Installation
    Replies: 3
    Last Post: 11-01-2007, 01:34 PM
  3. is there any way to show message size in column in inbox?
    By mike.suding in forum Administrators
    Replies: 2
    Last Post: 10-24-2007, 07:58 AM
  4. Replies: 0
    Last Post: 08-06-2007, 05:50 AM
  5. How to remove message size restrictions
    By djve in forum Administrators
    Replies: 4
    Last Post: 06-15-2007, 08:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •