Results 1 to 6 of 6

Thread: Server platform change RH to Ubuntu issues

  1. #1
    Join Date
    Nov 2007
    Posts
    11
    Rep Power
    7

    Unhappy Server platform change RH to Ubuntu issues

    Hi, I'm trying to migrate Zimbra 4.5.4 from RH Linux to Ubuntu. I've got the exact same version of Zimbra on RH and Ubuntu, and I've copy over all the files per this document:

    http://www.zimbra.com/blog/archives/...er_server.html

    However the upgrade process fails with this message (snipped the entire output to make it shorter):

    Code:
    zimbra-core......zimbra-core_4.5.4_GA_763.UBUNTU6_i386.deb...done
        zimbra-ldap......zimbra-ldap_4.5.4_GA_763.UBUNTU6_i386.deb...done
        zimbra-logger......zimbra-logger_4.5.4_GA_763.UBUNTU6_i386.deb...done
        zimbra-mta......zimbra-mta_4.5.4_GA_763.UBUNTU6_i386.deb...done
        zimbra-snmp......zimbra-snmp_4.5.4_GA_763.UBUNTU6_i386.deb...done
        zimbra-store......zimbra-store_4.5.4_GA_763.UBUNTU6_i386.deb...done
        zimbra-apache......zimbra-apache_4.5.4_GA_763.UBUNTU6_i386.deb...done
        zimbra-spell......zimbra-spell_4.5.4_GA_763.UBUNTU6_i386.deb...done
    
    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
       HOSTNAME=mail.domainname.com
       LDAPHOST=
       LDAPPORT=
       SNMPTRAPHOST=
       SMTPSOURCE=
       SMTPDEST=
       SNMPNOTIFY=0
       SMTPNOTIFY=0
       LDAPROOTPW=zimbra
       LDAPZIMBRAPW=zimbra
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...Restoring backup schedule...done
    Operations logged to /tmp/zmsetup.log.10772
    Setting defaults...Setting defaults from existing config...Warning: null valued key 'mysql_logger_root_password'
    Done
    Upgrading from  to 4.5.4_GA_763
    Stopping zimbra services
    Stop failed - exiting
    UPGRADE FAILED - exiting
    -----------
    
    
    So in the logfile it shows this (complete log) : 
    
    
    COMMAND: zmlocalconfig -s | sed -e "s/ = \(.*\)/=\'\1\'/" > /opt/zimbra/.saveconfig/config.save
    COMMAND: zmschedulebackup -s > /opt/zimbra/.saveconfig/backup.save
    crontabs/zimbra: Permission denied
    Rebuilding backup cron
    
    COMMAND: zmcontrol shutdown
    Host mail.medialogicsoftware.com
            Stopping mta...Done
            Stopping spell...Done
            Stopping snmp...Done
            Stopping antivirus...Done
            Stopping antispam...Done
            Stopping imapproxy...Done
            Stopping mailbox...Done
            Stopping logger...Done
            Stopping ldap...FAILED
    ldap_url and ldap_master_url cannot be the same on an ldap replica
    
    
    dpkg - warning, overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package zimbra-core.
    (Reading database ... 38739 files and directories currently installed.)
    Unpacking zimbra-core (from .../zimbra-core_4.5.4_GA_763.UBUNTU6_i386.deb) ...
    Setting up zimbra-core (4.5.4_GA_763.UBUNTU6) ...
    sh: /opt/zimbra/bin/zmfixperms.sh: No such file or directory
    mkdir: cannot create directory `/opt/zimbra/ssl': File exists
    mkdir: cannot create directory `/opt/zimbra/.ssh': File exists
    Loading classes to share ... done.
    Rewriting and unlinking classes ... done.
    Calculating hash values for String objects .. done.
    Calculating fingerprints ... done.
    Removing unshareable information ... done.
    Moving most read-only objects to shared space at 0xd09a0000 ... done.
    Moving common symbols to shared space at 0xd0d1c4f0 ... done.
    Moving remaining symbols to shared space at 0xd0e48280 ... done.
    Moving string char arrays to shared space at 0xd0e48d10 ... done.
    Moving additional symbols to shared space at 0xd0eca7b8 ... done.
    Read-only space ends at 0xd0f1eaf8, 5761784 bytes.
    Moving read-write objects to shared space at 0xd11a0000 ... done.
    Moving String objects to shared space at 0xd1729c50 ... done.
    Read-write space ends at 0xd1769d78, 6069624 bytes.
    Updating references to shared objects ... done.
    
    
    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    dpkg - warning, overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package zimbra-ldap.
    (Reading database ... 41082 files and directories currently installed.)
    Unpacking zimbra-ldap (from .../zimbra-ldap_4.5.4_GA_763.UBUNTU6_i386.deb) ...
    Setting up zimbra-ldap (4.5.4_GA_763.UBUNTU6) ...
    sh: /opt/zimbra/bin/zmfixperms.sh: No such file or directory
    
    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    dpkg - warning, overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package zimbra-logger.
    (Reading database ... 41370 files and directories currently installed.)
    Unpacking zimbra-logger (from .../zimbra-logger_4.5.4_GA_763.UBUNTU6_i386.deb) ...
    Setting up zimbra-logger (4.5.4_GA_763.UBUNTU6) ...
    chmod: cannot access `/opt/zimbra/postfix/conf/postfix-script': No such file or directory
    chmod: cannot access `/opt/zimbra/postfix/conf/post-install': No such file or directory
    
    dpkg - warning, overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package zimbra-mta.
    (Reading database ... 42979 files and directories currently installed.)
    Unpacking zimbra-mta (from .../zimbra-mta_4.5.4_GA_763.UBUNTU6_i386.deb) ...
    Setting up zimbra-mta (4.5.4_GA_763.UBUNTU6) ...
    umount2: Invalid argument
    umount: /opt/zimbra/amavisd/tmp: not mounted
    
    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    dpkg - warning, overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package zimbra-snmp.
    (Reading database ... 44218 files and directories currently installed.)
    Unpacking zimbra-snmp (from .../zimbra-snmp_4.5.4_GA_763.UBUNTU6_i386.deb) ...
    Setting up zimbra-snmp (4.5.4_GA_763.UBUNTU6) ...
    
    dpkg - warning, overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package zimbra-store.
    (Reading database ... 44762 files and directories currently installed.)
    Unpacking zimbra-store (from .../zimbra-store_4.5.4_GA_763.UBUNTU6_i386.deb) ...
    Setting up zimbra-store (4.5.4_GA_763.UBUNTU6) ...
    sh: /opt/zimbra/bin/zmfixperms.sh: No such file or directory
    
    dpkg - warning, overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package zimbra-apache.
    (Reading database ... 49750 files and directories currently installed.)
    Unpacking zimbra-apache (from .../zimbra-apache_4.5.4_GA_763.UBUNTU6_i386.deb) ...
    Setting up zimbra-apache (4.5.4_GA_763.UBUNTU6) ...
    
    dpkg - warning, overriding problem because --force enabled:
     package architecture (i386) does not match system (amd64)
    Selecting previously deselected package zimbra-spell.
    (Reading database ... 51483 files and directories currently installed.)
    Unpacking zimbra-spell (from .../zimbra-spell_4.5.4_GA_763.UBUNTU6_i386.deb) ...
    Setting up zimbra-spell (4.5.4_GA_763.UBUNTU6) ...
    
    COMMAND: zmlocalconfig -f -e calendar_outlook_compatible_allday_events='true'
    COMMAND: zmlocalconfig -f -e data_source_trust_self_signed_certs='false'
    COMMAND: zmlocalconfig -f -e debug_mailboxindex_use_new_locking='true'
    COMMAND: zmlocalconfig -f -e ldap_cache_account_maxage='15'
    COMMAND: zmlocalconfig -f -e ldap_cache_account_maxsize='5000'
    COMMAND: zmlocalconfig -f -e ldap_cache_cos_maxage='15'
    COMMAND: zmlocalconfig -f -e ldap_cache_cos_maxsize='100'
    COMMAND: zmlocalconfig -f -e ldap_cache_domain_maxage='15'
    COMMAND: zmlocalconfig -f -e ldap_cache_domain_maxsize='100'
    COMMAND: zmlocalconfig -f -e ldap_cache_server_maxage='15'
    COMMAND: zmlocalconfig -f -e ldap_cache_server_maxsize='100'
    COMMAND: zmlocalconfig -f -e ldap_cache_timezone_maxsize='100'
    COMMAND: zmlocalconfig -f -e ldap_cache_zimlet_maxage='15'
    COMMAND: zmlocalconfig -f -e ldap_cache_zimlet_maxsize='100'
    COMMAND: zmlocalconfig -f -e ldap_connect_pool_debug='false'
    COMMAND: zmlocalconfig -f -e ldap_connect_pool_initsize='1'
    COMMAND: zmlocalconfig -f -e ldap_connect_pool_maxsize='50'
    COMMAND: zmlocalconfig -f -e ldap_connect_pool_prefsize='0'
    COMMAND: zmlocalconfig -f -e ldap_connect_pool_timeout='120000'
    COMMAND: zmlocalconfig -f -e ldap_connect_timeout='30000'
    COMMAND: zmlocalconfig -f -e ldap_host=''
    COMMAND: zmlocalconfig -f -e ldap_is_master='false'
    COMMAND: zmlocalconfig -f -e ldap_log_level='32768'
    COMMAND: zmlocalconfig -f -e ldap_master_url=''
    COMMAND: zmlocalconfig -f -e ldap_port=''
    COMMAND: zmlocalconfig -f -e ldap_root_password='zimbra'
    COMMAND: zmlocalconfig -f -e ldap_url=''
    COMMAND: zmlocalconfig -f -e localized_msgs_directory='${zimbra_home}/conf/msgs'
    COMMAND: zmlocalconfig -f -e logger_mysql_bind_address='localhost'
    COMMAND: zmlocalconfig -f -e logger_mysql_data_directory='${zimbra_home}/logger/db/data'
    COMMAND: zmlocalconfig -f -e logger_mysql_directory='${zimbra_home}/logger/mysql'
    COMMAND: zmlocalconfig -f -e logger_mysql_mycnf='${zimbra_home}/conf/my.logger.cnf'
    COMMAND: zmlocalconfig -f -e logger_mysql_pidfile='${zimbra_home}/logger/db/mysql.pid'
    COMMAND: zmlocalconfig -f -e logger_mysql_port='7307'
    COMMAND: zmlocalconfig -f -e logger_mysql_socket='${zimbra_home}/logger/db/mysql.sock'
    COMMAND: zmlocalconfig -f -e mysql_bind_address='localhost'
    COMMAND: zmlocalconfig -f -e mysql_data_directory='${zimbra_db_directory}/data'
    COMMAND: zmlocalconfig -f -e mysql_directory='${zimbra_home}/mysql'
    COMMAND: zmlocalconfig -f -e mysql_innodb_log_buffer_size='8388608'
    COMMAND: zmlocalconfig -f -e mysql_innodb_log_file_size='104857600'
    COMMAND: zmlocalconfig -f -e mysql_memory_percent='40'
    COMMAND: zmlocalconfig -f -e mysql_mycnf='${zimbra_home}/conf/my.cnf'
    COMMAND: zmlocalconfig -f -e mysql_pidfile='${zimbra_db_directory}/mysql.pid'
    COMMAND: zmlocalconfig -f -e mysql_port='7306'
    COMMAND: zmlocalconfig -f -e mysql_read_buffer_size='1048576'
    COMMAND: zmlocalconfig -f -e mysql_root_password='zimbra'
    COMMAND: zmlocalconfig -f -e mysql_socket='${zimbra_db_directory}/mysql.sock'
    COMMAND: zmlocalconfig -f -e mysql_sort_buffer_size='1048576'
    COMMAND: zmlocalconfig -f -e mysql_table_cache='500'
    COMMAND: zmlocalconfig -f -e nio_imap_enable='false'
    COMMAND: zmlocalconfig -f -e nio_imap_log_buffers='false'
    COMMAND: zmlocalconfig -f -e nio_imap_write_queue_max_size='10240000'
    COMMAND: zmlocalconfig -f -e nio_imap_write_queue_max_size_unauth='20480'
    COMMAND: zmlocalconfig -f -e nio_write_buffer_compaction_percent='50'
    COMMAND: zmlocalconfig -f -e postfix_alias_maps='hash:/etc/aliases'
    COMMAND: zmlocalconfig -f -e postfix_broken_sasl_auth_clients='yes'
    COMMAND: zmlocalconfig -f -e postfix_command_directory='/opt/zimbra/postfix-${postfix_version}/sbin'
    COMMAND: zmlocalconfig -f -e postfix_daemon_directory='/opt/zimbra/postfix-${postfix_version}/libexec'
    COMMAND: zmlocalconfig -f -e postfix_header_checks='pcre:/opt/zimbra/conf/postfix_header_checks'
    COMMAND: zmlocalconfig -f -e postfix_mailq_path='/opt/zimbra/postfix-${postfix_version}/sbin/mailq'
    COMMAND: zmlocalconfig -f -e postfix_manpage_directory='/opt/zimbra/postfix-${postfix_version}/man'
    COMMAND: zmlocalconfig -f -e postfix_newaliases_path='/opt/zimbra/postfix-${postfix_version}/sbin/newaliases'
    COMMAND: zmlocalconfig -f -e postfix_queue_directory='/opt/zimbra/postfix-${postfix_version}/spool'
    COMMAND: zmlocalconfig -f -e postfix_sender_canonical_maps='ldap:/opt/zimbra/conf/ldap-scm.cf'
    COMMAND: zmlocalconfig -f -e postfix_sendmail_path='/opt/zimbra/postfix-${postfix_version}/sbin/sendmail'
    COMMAND: zmlocalconfig -f -e postfix_smtpd_client_restrictions='reject_unauth_pipelining'
    COMMAND: zmlocalconfig -f -e postfix_smtpd_data_restrictions='reject_unauth_pipelining'
    COMMAND: zmlocalconfig -f -e postfix_smtpd_helo_required='yes'
    COMMAND: zmlocalconfig -f -e postfix_smtpd_tls_cert_file='${zimbra_home}/conf/smtpd.crt'
    COMMAND: zmlocalconfig -f -e postfix_smtpd_tls_key_file='${zimbra_home}/conf/smtpd.key'
    COMMAND: zmlocalconfig -f -e postfix_smtpd_tls_loglevel='1'
    COMMAND: zmlocalconfig -f -e postfix_transport_maps='ldap:/opt/zimbra/conf/ldap-transport.cf'
    COMMAND: zmlocalconfig -f -e postfix_version='2.2.9'
    COMMAND: zmlocalconfig -f -e postfix_virtual_alias_domains='ldap:/opt/zimbra/conf/ldap-vad.cf'
    COMMAND: zmlocalconfig -f -e postfix_virtual_alias_maps='ldap:/opt/zimbra/conf/ldap-vam.cf'
    COMMAND: zmlocalconfig -f -e postfix_virtual_mailbox_domains='ldap:/opt/zimbra/conf/ldap-vmd.cf'
    COMMAND: zmlocalconfig -f -e postfix_virtual_mailbox_maps='ldap:/opt/zimbra/conf/ldap-vmm.cf'
    COMMAND: zmlocalconfig -f -e postfix_virtual_transport='error'
    COMMAND: zmlocalconfig -f -e search_dbfirst_term_percentage_cutoff='0.8'
    COMMAND: zmlocalconfig -f -e search_disable_database_hints='false'
    COMMAND: zmlocalconfig -f -e ssl_allow_untrusted_certs='false'
    COMMAND: zmlocalconfig -f -e stats_img_folder='${zimbra_home}/logger/db/work'
    COMMAND: zmlocalconfig -f -e timezone_file='${zimbra_home}/conf/timezones.ics'
    COMMAND: zmlocalconfig -f -e tomcat_directory='${zimbra_home}/tomcat'
    COMMAND: zmlocalconfig -f -e tomcat_java_heap_memory_percent='30'
    COMMAND: zmlocalconfig -f -e tomcat_java_home='${zimbra_java_home}'
    COMMAND: zmlocalconfig -f -e tomcat_java_options='-client -XX:NewRatio=2 -Djava.awt.headless=true'
    COMMAND: zmlocalconfig -f -e tomcat_keystore='${tomcat_directory}/conf/keystore'
    COMMAND: zmlocalconfig -f -e tomcat_pidfile='${zimbra_log_directory}/tomcat.pid'
    COMMAND: zmlocalconfig -f -e wiki_enabled='false'
    COMMAND: zmlocalconfig -f -e wiki_user='wiki'
    COMMAND: zmlocalconfig -f -e zimbra_admin_service_port='7071'
    COMMAND: zmlocalconfig -f -e zimbra_attrs_directory='${zimbra_home}/conf/attrs'
    COMMAND: zmlocalconfig -f -e zimbra_auth_always_send_refer='false'
    COMMAND: zmlocalconfig -f -e zimbra_class_mboxmanager='com.zimbra.cs.mailbox.MailboxManager'
    COMMAND: zmlocalconfig -f -e zimbra_class_provisioning='com.zimbra.cs.account.ldap.LdapProvisioning'
    COMMAND: zmlocalconfig -f -e zimbra_db_directory='${zimbra_home}/db'
    COMMAND: zmlocalconfig -f -e zimbra_extension_common_directory='${zimbra_home}/lib/ext-common'
    COMMAND: zmlocalconfig -f -e zimbra_extension_directory='${zimbra_home}/lib/ext'
    COMMAND: zmlocalconfig -f -e zimbra_gid='-1'
    COMMAND: zmlocalconfig -f -e zimbra_home='/opt/zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_index_directory='${zimbra_home}/index'
    COMMAND: zmlocalconfig -f -e zimbra_index_idle_flush_time='600'
    COMMAND: zmlocalconfig -f -e zimbra_index_lru_size='100'
    COMMAND: zmlocalconfig -f -e zimbra_index_max_uncommitted_operations='200'
    COMMAND: zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java'
    COMMAND: zmlocalconfig -f -e zimbra_ldap_password='zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_ldap_user='zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_ldap_userdn='uid=zimbra,cn=admins,cn=zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_log4j_properties='${zimbra_home}/conf/log4j.properties'
    COMMAND: zmlocalconfig -f -e zimbra_log_directory='${zimbra_home}/log'
    COMMAND: zmlocalconfig -f -e zimbra_logger_mysql_password='zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_mailbox_active_cache='500'
    COMMAND: zmlocalconfig -f -e zimbra_mailbox_groups='100'
    COMMAND: zmlocalconfig -f -e zimbra_mailbox_inactive_cache='30'
    COMMAND: zmlocalconfig -f -e zimbra_mailbox_purgeable='true'
    COMMAND: zmlocalconfig -f -e zimbra_mtareport_max_recipients='50'
    COMMAND: zmlocalconfig -f -e zimbra_mtareport_max_senders='50'
    COMMAND: zmlocalconfig -f -e zimbra_mysql_password='zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_mysql_user='zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_server_hostname='mail.medialogicsoftware.com'
    COMMAND: zmlocalconfig -f -e zimbra_spam_report_queue_size='100'
    COMMAND: zmlocalconfig -f -e zimbra_store_directory='${zimbra_home}/store'
    COMMAND: zmlocalconfig -f -e zimbra_store_sweeper_max_age='480'
    COMMAND: zmlocalconfig -f -e zimbra_throttle_op_concurrency='1000,1000,1000,1000,1000'
    COMMAND: zmlocalconfig -f -e zimbra_tmp_directory='/tmp/zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_uid='-1'
    COMMAND: zmlocalconfig -f -e zimbra_user='zimbra'
    COMMAND: zmlocalconfig -f -e zimbra_zmprov_default_soap_server='localhost'
    COMMAND: zmlocalconfig -f -e zimbra_zmprov_default_to_ldap='false'
    COMMAND: zmlocalconfig -f -e zimlet_directory='${tomcat_directory}/webapps/service/zimlet'
    COMMAND: cat /opt/zimbra/.saveconfig/backup.save | xargs zmschedulebackup -R
    crontabs/zimbra: Permission denied
    Rebuilding backup cron
    
    
    ERROR: Schedule specification required
    
    Schedule regular backups
    
    Usage: zmshedulebackup [-q|-s|-A|-R|-F|-D] [schedule] [schedule...]
            -q: query (default command) - prints existing schedule
            -s: save schedule (format applicable for restoring)
            -F: flush - remove current schedule (cancel all scheduled backups)
            -A: append - adds specified backup to current schedule
            -R: replace - replace current schedule with specified schedule
            -D: Default - replace current schedule with DEFAULT schedule
    
            schedule: <i|f|d arg> <time specifier>
            i: incremental backup
            f: full backup
            d <arg>: delete backups. <arg> is n{d|m|y}
            time specifier: crontab style time specifier, QUOTED.  See crontab(5)
                    Fields are:
                            minute         0-59
                            hour           0-23
                            day of month   1-31
                            month          1-12
                            day of week    0-7 (0 or 7 is Sun, or use names)
    
            Default schedule is:
            f    0 1 * * 6
            i    0 1 * * 0-5
            d 1m 0 0 * * *
    --------------------

    I don't see how to get around this problem. And interestingly enough there is no zmschedulebackup command on the RH system - if that even matters.

    Can anyone help?

    Mark
    Last edited by marke; 11-04-2007 at 07:34 AM. Reason: Added some clarification

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    If the LDAP pw is zimbra, it's likely that you had a failed install, and tried it again.

    Try to copy the following files from your backup into your new install:
    /opt/zimbra/.saveconfig
    /opt/zimbra/conf/localconfig.xml

    Place them in the new /opt/zimbra and rerun the installer.

  3. #3
    Join Date
    Nov 2007
    Posts
    11
    Rep Power
    7

    Default Tried again

    OK, I did what you said, copied those two files from the Zimbra backup that I made onto the new server. Then ran the install again, which asked me if I want to upgrade to which I replied yes.

    The same failure happpened, and the LDAP user and pw are still showing in the install process as 'zimbra'.

    Any other ideas on how to fix this ?

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    can you cat your localconfig.xml? Are there values in there? In particular, look for the password and ldap values.

    My guess is that your backup file is bad.

  5. #5
    Join Date
    Nov 2007
    Posts
    11
    Rep Power
    7

    Default config

    Here it is below. Also I wonder if my method backup made a difference? I used tar instead of rsync. Then I copied the tar file over to the new system, unpacked it, and proceeded to follow the instructions at Zimbra URL that I put in the first post of this thread.

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    
    <localconfig>
      <key name="zimbra_server_hostname">
        <value>mail.mydomain.com</value>
      </key>
      <key name="zimbra_user">
        <value>zimbra</value>
      </key>
      <key name="ssl_allow_untrusted_certs">
        <value>TRUE</value>
      </key>
      <key name="mysql_memory_percent">
        <value>30</value>
      </key>
      <key name="mysql_root_password">
        <value>JSUxos3ITU.5OIRSgakCoAWB9h_XOe6V</value>
      </key>
      <key name="ldap_port">
        <value>389</value>
      </key>
      <key name="zimbra_uid">
        <value>500</value>
      </key>
      <key name="ldap_root_password">
        <value>lXhrgGtx4r</value>
      </key>
      <key name="ldap_is_master">
        <value>true</value>
      </key>
      <key name="ldap_url">
        <value>ldap://mail.mydomain.com:389</value>
      </key>
      <key name="smtp_destination">
        <value>admin@mail.mydomain.com</value>
      </key>
      <key name="tomcat_java_heap_memory_percent">
        <value>40</value>
      </key>
      <key name="ldap_master_url">
        <value>ldap://mail.mydomain.com:389</value>
      </key>
      <key name="av_notify_user">
        <value>admin@mail.mydomain.com</value>
      </key>
      <key name="zimbra_mysql_connector_maxActive">
        <value>10</value>
      </key>
      <key name="zimbra_mysql_password">
        <value>QMDzwx0dqUSBPx7MFAgc41pJFKY</value>
      </key>
      <key name="snmp_notify">
        <value>yes</value>
      </key>
      <key name="smtp_notify">
        <value>yes</value>
      </key>
      <key name="zimbra_gid">
        <value>500</value>
      </key>
      <key name="snmp_trap_host">
        <value>mail.mydomain.com</value>
      </key>
      <key name="ldap_host">
        <value>mail.mydomain.com</value>
      </key>
      <key name="zimbra_java_home">
        <value>/opt/zimbra/java</value>
      </key>
      <key name="mysql_logger_root_password">
        <value>AlHHT0oluGvlYxFzbfTMCPxme</value>
      </key>
      <key name="smtp_source">
        <value>admin@mail.mydomain.com</value>
      </key>
      <key name="zimbra_ldap_password">
        <value>lXhrgGtx4r</value>
      </key>
      <key name="zimbra_logger_mysql_password">
        <value>kolKtzK8w0kSbPNS8.2fKvFRYTG6h</value>
      </key>
    </localconfig>

  6. #6
    Join Date
    Nov 2007
    Posts
    11
    Rep Power
    7

    Default [Resolved] Here's how I did the migration from RH to Ubuntu

    I migrated from RH (CentOS) to Ubuntu x64. I followed the instructions here:

    http://www.zimbra.com/forums/install...t-install.html

    Except that I loaded Zimbra 4.5.9 on Ubuntu and Zimbra 4.5.4 was running on CentOS.

    After installing 4.5.9, this is what I did (as opposed to the suggested 'upgrade' routine) :

    First install 4.5.9 on the new server.

    Then stop all the services (zmcontrol stop)

    Copy backup/mysql.sql from the old server to the new server into the backup/ directory

    Copy all the mysql psws (there are a few of them) from conf/localconfig.xml on the old server into conf/localconfig.xml on the new server (cut and paste the psw strings without touching the other XML tags)

    Start mysql server on the new server (bin/mysql.server start)

    Import the mysql.sql file into the new database server (running on port 7306):

    mysql --port=7306 --socket=/opt/zimbra/db/mysql.sock -u root -p (use mysql_root_password from localconfig.xml file)
    at the prompt inside mysql do this commmand to import the database:

    source /opt/zimbra/backup/mysql.sql

    Export the ldap data on the old server:

    su - zimbra
    openldap/sbin/slapcat -f /opt/zimbra/conf/slapd.conf -l /opt/zimbra/backup/ldap.ldif

    Copy the /opt/zimbra/backup/ldap.ldif file to the new server into the /opt/zimbra/backup directory

    Import the ldap data into the new server

    rm -f openldap-data/*
    su - zimbra
    openldap/sbin/slapadd -f /opt/zimbra/conf/slapd.conf -l /opt/zimbra/backup/ldap.ldif

    Copy /opt/zimbra/store/* from the old server into the new server

    delete the logger db (rm /opt/zimbra/logger/db/*)

    reinit the logger db (/opt/zimbra/libexec/zmloggerinit)

    stop zimbra services (zmcontrol stop)

    make sure none are left running
    ps ax | grep zim
    ps ax | grep mysql
    ps ax | grep ldap

    kill any running services.

    restart services (zmcontrol start)

    That's what worked for me. Pretty simple compared to all the other problems I encountered with the usual upgrade path - which repeatedly failed.
    Last edited by marke; 11-07-2007 at 12:07 PM.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •