Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: server hostname change

  1. #1
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default server hostname change

    hi

    i have a server running on an internally-addressed network (192.168.192.x) and split-horizon dns such that internally the workstations and servers think they live on a xxx-intranet.com domain which resolves fine locally but does not exist officially on the internet. this all works fine, and also from the outside works fine, but i have two issues i would like to resolve.

    1) the postfix server considers itself 'hostname.xxx-intranet.com' and writes smtp headers as that, however because this fqdn doesn't exist on the internet, some remote servers with strict domain checking will reject the email. i would like to change postfix to consider itself 'anotherhostname.xxx.com'. normally i would hack main.cf but i suspect there's another way to do this in zimbra.

    2) ditto for smtp/https certs, you get a domain name mismatch warning from the outside. how do you specify an fqdn to the cert setup?

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default changing hostname

    1 - postconf -e myhostname=real.host.name.com

    2 - the cert creation scripts don't really support that, but you could hack it in the creates ssl.conf - read the scripts for more info...

  3. #3
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default

    Hello,

    tryied it, but it does not work. After postconf -e .... the change is written to /opt/zimbra/postfix/conf/main.cf, but it does not work. After zmcontrol stop/start the change in Postfix's main.cf is rolled back. When I edit main.cf and add myhostname above #Zimbra changes section, it does not work either. After Zimbra restart the change is overwritten. Using 3.0.1 open source edition.

    I would like to see this work. We have Zimbra server in internal network (m1.internal.company.com) and want it to Hello to outside like our registered internet MX (mail.company.com).

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by PNE
    Hello,

    tryied it, but it does not work. After postconf -e .... the change is written to /opt/zimbra/postfix/conf/main.cf, but it does not work. After zmcontrol stop/start the change in Postfix's main.cf is rolled back. When I edit main.cf and add myhostname above #Zimbra changes section, it does not work either. After Zimbra restart the change is overwritten. Using 3.0.1 open source edition.

    I would like to see this work. We have Zimbra server in internal network (m1.internal.company.com) and want it to Hello to outside like our registered internet MX (mail.company.com).
    After a postconf try "postfix reload" and not a zimbra restart. This should not rewrite the file but force a reload of the config.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Oct 2005
    Posts
    67
    Rep Power
    10

    Default

    If I want Zimbra not to overwrite the config, I use "libexec/zmsetup.pl" ?

  6. #6
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default

    So the hostname change will be overwritten anyway after next zimbra restart, is this right? Any better solution?

  7. #7
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by PNE
    So the hostname change will be overwritten anyway after next zimbra restart, is this right? Any better solution?
    Well setting the right hostname at install is one way. For us if you change it in the config it sticks. Not sure why this doesn't work for you.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    looks like a restart of zimbra rewrites the config (zmmtaconfig?) so the change doesn't stay. i tried doing 'zmlocalconfig -e zimbra_server_hostname=new.hostname.xxx' but that doesnt work because zimbra doesn't know anthing else about the new hostname.

    i've setup split-horizon dns such that the outside fqdn is resolved correctly internally for the internal ip address. so i can change the zimbra hostname to a hostname that is correct both inside and outside, hurrah. how do i do this? rerun setup.pl?

  9. #9
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Just realized that this thread(and Marc's response) was over 3mo old and we now ship a script:

    libexec/zmsetservername

    Not tested too much so take a backup but it should do the trick.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  10. #10
    Join Date
    Mar 2006
    Location
    Czech Republic
    Posts
    81
    Rep Power
    9

    Default

    Just tryied zmsetservername on test box. After the change Zimbra does not work, only ldap runs, everything else not. Just like is described at http://www.zimbra.com/forums/showthr...msetservername thread. I changed name back and Zimbra works now.

    When the script should be run? What is supposed use of script and what conditions must be met?

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 11:27 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  3. Change hostname and IP Address!
    By celeron in forum Administrators
    Replies: 6
    Last Post: 07-15-2007, 10:27 PM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  5. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 10:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •