Results 1 to 9 of 9

Thread: [SOLVED] Zimbra on OSX - returned mail, hostname problem?

Threaded View

  1. #1
    Join Date
    Mar 2007
    Location
    Riga, Latvia
    Posts
    10
    Rep Power
    8

    Thumbs up [SOLVED] Zimbra on OSX - returned mail, hostname problem?

    At first, thank you, Zimbra people, for good work and continous efforts... :-)
    Congrats for your business victory! Ummm...

    My OpenSource Zimbra installation (4.5.3 GA) works on client OSX Tiger (10.4.9) installation for 6 months.
    I have ~ 30 accounts, exchanging ~300 e-mails every day.
    Several accounts grow on size over 1 Gb now, but Zimbra and PPC G4 coping with it quite OK.
    (Machine - Mac G4 700 MHz, 1.25 Gb RAM, 120 Gb HD, directly connected to internet)

    There are no big issues with workflow, only few - sometimes logger stops working by itself, but server continues normally, and thats all... EXCEPT:

    Just SOME other MTAs is returning/not accepting mail from my Zimbra because on wrong/not qualified HOSTNAME.

    I have static IP and FQDN both for "mail.mydomain.com" and "webmail. mydomain.com".
    (Notice: I choose name "webmail" because I felt it good for my purpose and then registered that name "webmail.mydomain.com" with my TLD. In this way I got address "webmail.mydomain.com" pointing to my machine for user access to webmail interface).

    My HOSTS file:
    Code:
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##
    127.0.0.1       localhost
    255.255.255.255 broadcasthost
    xx.xx.xxx.xxx webmail.mydomain.com webmail
    When I installed Zimbra, I found that ONLY way to get Zimbra installation working is to set OSX Computer Name to "webmail", NOT "mail.mydomain.com", webmail.mydomain.com" or just "mydomain.com". When I set Computer Name to other than "webmail", installation never succeeded. I don't remember exact reasons but there was issues about LDAP not finding localhost and something like.
    OSX, as always, automagically adds .local to Computer Name.
    So, I notice in logs that Postfix manifests to outside world as "webmail.local". And this is not good.
    And I see that it is problem here:

    --sample from returned mail--
    Code:
    <mma@mgn.ru>: host relay.mgn.ru[62.165.51.253] refused to talk to me: 501 5.7.1
        <webmail.local>: Helo command rejected: Host not found
    Reporting-MTA: dns; webmail.local
    X-Postfix-Queue-ID: C6FE76C4022
    X-Postfix-Sender: rfc822; user@mydomain.com
    Arrival-Date: Tue,  6 Nov 2007 10:46:07 +0200 (EET)
    
    Final-Recipient: rfc822; mma@mgn.ru
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; host relay.mgn.ru[62.165.51.253] refused to talk to
        me: 501 5.7.1 <webmail.local>: Helo command rejected: Host not found
    --end of sample--

    Is there any way to tell Zimbra Postfix to use FQDN when talking to other mailservers?

    As I see, only few MTAs checks this now, because my server succesfully exchanges mails with LOT of servers on internet without problems for almost half-year, but some mails fail...

    Thank you,
    McBurtnieks
    Last edited by McBurtnieks; 11-14-2007 at 06:58 PM. Reason: problem solved

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  3. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 05:32 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  5. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 04:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •