Results 1 to 9 of 9

Thread: imapsslserver: broken pipe

  1. #1
    Join Date
    Nov 2007
    Posts
    9
    Rep Power
    8

    Default imapsslserver: broken pipe

    Just installed zimbra on rhel5 (running as a xen VM), and was testing from an outlook client using IMap, and started getting the following errors:

    2007-11-08 15:54:05,418 INFO [ImapSSLServer-10] [] ProtocolHandler - Handler exiting normally
    2007-11-08 15:54:51,397 INFO [ImapSSLServer-11] [] imap - [192.200.105.33] connected
    2007-11-08 15:55:27,902 INFO [ImapSSLServer-11] [] ProtocolHandler - Handler exiting normally
    2007-11-08 15:58:28,218 INFO [ImapSSLServer-12] [] imap - [192.200.105.33] connected
    2007-11-08 15:59:08,809 INFO [ImapSSLServer-12] [] ProtocolHandler - Exception occurred while handling connection
    java.net.SocketException: Broken pipe
    at java.net.SocketOutputStream.socketWrite0(Native Method)
    at java.net.SocketOutputStream.socketWrite(SocketOutp utStream.java:92)
    at java.net.SocketOutputStream.write(SocketOutputStre am.java:136)
    at com.sun.net.ssl.internal.ssl.OutputRecord.writeBuf fer(OutputRecord.java:295)
    at com.sun.net.ssl.internal.ssl.OutputRecord.write(Ou tputRecord.java:284)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRe cordInternal(SSLSocketImpl.java:734)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRe cord(SSLSocketImpl.java:722)
    at com.sun.net.ssl.internal.ssl.AppOutputStream.write (AppOutputStream.java:59)
    at java.io.BufferedOutputStream.flushBuffer(BufferedO utputStream.java:65)
    at java.io.BufferedOutputStream.flush(BufferedOutputS tream.java:123)
    at com.zimbra.cs.imap.ImapHandler.sendLine(ImapHandle r.java:2097)
    at com.zimbra.cs.imap.ImapHandler.sendResponse(ImapHa ndler.java:2087)
    at com.zimbra.cs.imap.ImapHandler.sendOK(ImapHandler. java:2073)
    at com.zimbra.cs.imap.ImapHandler.doLOGOUT(ImapHandle r.java:709)
    at com.zimbra.cs.imap.ImapHandler.executeRequest(Imap Handler.java:440)
    at com.zimbra.cs.imap.ImapHandler.processCommand(Imap Handler.java:239)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:221)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:188)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:619)
    2007-11-08 15:59:08,810 INFO [ImapSSLServer-12] [] ProtocolHandler - Handler exiting normally


    I have tried rebooting and getting same errors.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    How much RAM have you got on this server? Which version of Zimbra?
    Last edited by phoenix; 11-09-2007 at 01:09 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Nov 2007
    Posts
    9
    Rep Power
    8

    Default

    I have assigned 1 gig at this point (i can assign a lot more when/if needed). This is the file I used zcs-4.5.9_GA_1454.RHEL5.tgz to install. Where do I go to see what version is running?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    That's the open source version but you can always check the running version with 'zmcontrol -v'. Is that a fixed amount of allocated memory? Can you try it with 1.5GB and see if that helps?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Nov 2007
    Posts
    9
    Rep Power
    8

    Default

    I will try that. I guess Im not that worried about using SSL for my connection, I just want the username and passwords to be encrypted. Can you give me a brief overview of what settings in Zimbra and outlook I need to do this for pop and/or imap. Thanks.

  6. #6
    Join Date
    Nov 2007
    Posts
    9
    Rep Power
    8

    Default

    Happened again:

    2007-11-09 11:01:27,578 INFO [ImapSSLServer-2] [] ProtocolHandler - Handler exiting normally
    2007-11-09 11:05:39,406 INFO [ImapSSLServer-3] [] imap - [192.200.105.33] connected
    2007-11-09 11:06:20,084 INFO [ImapSSLServer-3] [] ProtocolHandler - Exception occurred while handling connection
    java.net.SocketException: Broken pipe
    at java.net.SocketOutputStream.socketWrite0(Native Method)
    at java.net.SocketOutputStream.socketWrite(SocketOutp utStream.java:92)
    at java.net.SocketOutputStream.write(SocketOutputStre am.java:136)
    at com.sun.net.ssl.internal.ssl.OutputRecord.writeBuf fer(OutputRecord.java:295)
    at com.sun.net.ssl.internal.ssl.OutputRecord.write(Ou tputRecord.java:284)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRe cordInternal(SSLSocketImpl.java:734)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRe cord(SSLSocketImpl.java:722)
    at com.sun.net.ssl.internal.ssl.AppOutputStream.write (AppOutputStream.java:59)
    at java.io.BufferedOutputStream.flushBuffer(BufferedO utputStream.java:65)
    at java.io.BufferedOutputStream.flush(BufferedOutputS tream.java:123)
    at com.zimbra.cs.imap.ImapHandler.sendLine(ImapHandle r.java:2097)
    at com.zimbra.cs.imap.ImapHandler.sendResponse(ImapHa ndler.java:2087)
    at com.zimbra.cs.imap.ImapHandler.sendOK(ImapHandler. java:2073)
    at com.zimbra.cs.imap.ImapHandler.doLOGOUT(ImapHandle r.java:709)
    at com.zimbra.cs.imap.ImapHandler.executeRequest(Imap Handler.java:440)
    at com.zimbra.cs.imap.ImapHandler.processCommand(Imap Handler.java:239)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:221)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:188)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:619)
    2007-11-09 11:06:20,084 INFO [ImapSSLServer-3] [] ProtocolHandler - Handler exiting normally

    Seems to only happen when sending.
    Top shows its only using about 700 megs..

  7. #7
    Join Date
    Nov 2007
    Posts
    9
    Rep Power
    8

    Default

    Or do I need to use the connector to use TLS?

  8. #8
    Join Date
    Nov 2007
    Posts
    9
    Rep Power
    8

    Default

    yes, no, maybe?

  9. #9
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    as an asside - could you:

    su zimbra
    zmprov gs zimbra.domain.com | grep Auth
    zmprov gs zimbra.domain.com | grep Mode

    I know it's not what you want - but do you have any problems after you:
    zmprov ms server.domain.com zimbraImapCleartextLoginEnabled TRUE
    Last edited by mmorse; 11-09-2007 at 02:45 PM.

Similar Threads

  1. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  2. Japanese broken on Nokia E61 by Mail for Exchange
    By CJ.deb in forum Administrators
    Replies: 1
    Last Post: 03-30-2007, 11:23 AM
  3. Replies: 12
    Last Post: 03-21-2007, 07:23 AM
  4. How to pipe into a script
    By nexus in forum Administrators
    Replies: 0
    Last Post: 02-20-2007, 01:04 PM
  5. Ubuntu broken.
    By shankariyer in forum Installation
    Replies: 1
    Last Post: 04-12-2006, 12:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •