Results 1 to 6 of 6

Thread: [SOLVED] zimbra does not deliver local mails

Hybrid View

  1. #1
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default [SOLVED] zimbra does not deliver local mails

    Hi there,
    i have zcs-5.0.0_RC1_1538.UBUNTU6.20071002173103. I have two mailservers in split domain setup with zimbra as primary mail system. Mail delivering for local mailboxes or for mailboxes on secondary system worked well until now. But i don't know why.

    If i try to send email for local mailbox, zimbra send email to secondary mailsystem.

    If i try to send email for local-only mailbox, zimbra loop.


    Is this some known bug in RC1? I can't find it in bugzilla.

    Thanks.

  2. #2
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    here are some details:
    ..
    Nov 9 10:25:42 dog postfix/smtp[14845]: BDC377D2CD: to=<admin@dog.ucetnictvi-on-line.cz>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.95, delays=0.06/0.01/0
    .01/0.87, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 992177D2CF)
    Nov 9 10:25:42 dog postfix/qmgr[32704]: BDC377D2CD: removed
    Nov 9 10:25:42 dog postfix/smtp[14849]: 992177D2CF: to=<admin@dog.ucetnictvi-on-line.cz>, relay=none, delay=0.1, delays=0.09/0.01/0.01/0, dsn=5.4.6, statu
    s=bounced (mail for dog.ucetnictvi-on-line.cz loops back to myself)
    ..

    # admin, people, dog.ucetnictvi-on-line.cz
    dn: uid=admin,ou=people,dc=dog,dc=ucetnictvi-on-line,dc=cz
    zimbraMailTransport: lmtp:dog.ucetnictvi-on-line.cz:7025

  3. #3
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    Please, nobody knows why doesn't my zimbra deliver local mesages??

    Thank you.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by boblin View Post
    Please, nobody knows why doesn't my zimbra deliver local mesages??
    The answer to this problem has been posted many times in the forums. Search the forums for 'loops back to myself' and the forums/wiki for mynetworks, you've probably made a change that's caused this problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    Thank you for reply! I already checked these posts in forum and wiki, but didn't find problem in my configuration.

    I also compared my configuration and logs with some another zimbra server and i found that in my case zimbra send email to postfix/smtp instead of postfix/lmtp, but i don't know why and how to debug it

  6. #6
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    I found it!

    When i search ldap from command line:

    $ ldapsearch -D "uid=zimbra,cn=admins,cn=zimbra" -h dog -x -w ***** "(&(zimbraDomainName=ucetnictvi-on-line.cz)(zimbraDomainType=local)(zimbraMailStatus= enabled))" zimbraDomainName


    Nov 15 10:27:38 dog slapd[13507]: conn=86 op=1 SRCH base="" scope=2 deref=0 filter="(&(zimbraDomainName=ucetnictvi-on-line.cz)(zimbraDomainType=local)(zimbraMailStatus= enabled))"
    Nov 15 10:27:38 dog slapd[13507]: conn=86 op=1 SRCH attr=zimbraDomainName
    Nov 15 10:27:38 dog slapd[13507]: conn=86 op=1 SEARCH RESULT tag=101 err=0 nentries=1 text=


    ..but when search ldap postfix:
    Nov 15 10:13:01 dog slapd[13507]: conn=3 op=3 SRCH base="" scope=2 deref=0 filter="(&(zimbraDomainName=ucetnictvi-on-line.cz)(zimbraDomainType=local)(zimbraMailStatus= enabled))"
    Nov 15 10:13:01 dog slapd[13507]: conn=3 op=3 SRCH attr=zimbraDomainName
    Nov 15 10:13:01 dog slapd[13507]: conn=3 op=3 SEARCH RESULT tag=101 err=0 nentries=0 text=


    I found, i had in /opt/zimbra/conf/slapd.conf.in this because of smbldap-passwd:
    access to *
    by self write
    by users read
    by anonymous auth

Similar Threads

  1. QUE Failure
    By tbullock in forum Administrators
    Replies: 31
    Last Post: 07-30-2008, 01:17 PM
  2. Replies: 2
    Last Post: 10-04-2007, 04:20 PM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  4. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 01:11 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •