I’m having the same symptoms as in this post:
http://www.zimbra.com/forums/users/1...g-failure.html but I have not been able to resolve it per the thread. I have checked the wiki mentioned in that same thread, and with that:

Code:
[zimbra@mail root]$ zmprov gs mail.mydomain.com | grep Auth
zimbraMtaAuthEnabled: TRUE
zimbraMtaAuthHost: mail.mydomain.com
zimbraMtaAuthURL: https://mail.mydomain.com/service/soap/
zimbraMtaTlsAuthOnly: FALSE

[zimbra@mail root]$ zmprov gs mail.mydomain.com | grep Mode
zimbraMailMode: mixed
My firewall settings show NAT from my public IP to my server with the following services open: POP3 (110, 995), SMTP (25), Web Server (80), HTTPS (443), IMAP (143, 220, 585, 993) Zimbra Mgt (7071) and VNC (5900).

I’ve tried configuring Outlook Express but can’t send messages. I receive the following server time out error:

Code:
Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'mail.mydomain.com', Server: 'mail.mydomain.com', Protocol: SMTP, Port: 25, Secure(SSL): Yes, Socket Error: 10053, Error Number: 0x800CCC0F
As far as the client set up, I’ve tried both POP3 and IMAP with “outgoing server requires authentication” turned on and off.

I can receive messages just fine. Web UI or Outlook Connector users have no issues what so ever.

One other fact is one of my users who is at the Office and behind the firewall sent me an e-mail using Outlook Express without issue.(?)

Any help with this will be greatly appreciated…