I'm trying to get the Simple Shell Script Method from HERE working on my server.

I've kept the script the same except for altering the backup folder directory

The problem is, when I run it as root (testing it out see if it'll be ok with CRON) it all seems to run ok, but after the backup is complete I su to the zimbra account and do a zmcontrol status check and it says that the stats module is stopped.

I can stop/start Zimbra as the zimbra user OK, it's just that doing it from sudo causes stats to not start.

Any ideas?



My other problem was trying to get the perl backup script from HERE working instead, but I seem to not have all the necessary modules installed.

First I ran "yum install perl" just to make sure it was installed. I then ran the script and it complained about some IO/Scalar.pm being missing. Did some googling then yum installed perl-IO-Stringy. The script then complained about Proc/ProcessTable.pm being missing, googled then yum installed perl-Proc-ProcessTable.

Now the script is failing saying it can't find File/Rsync.pm but I can't seem to find a perl package for that, and I'm pretty sure rsync is installed on the system anyway.

Am I missing something? Is there a perl rsync module? Are there more modules I need to install or is there a package that has all that I need in it?

Thanks for any help!