Results 1 to 2 of 2

Thread: [SOLVED] External LDAP auth not works

  1. #1
    Join Date
    Nov 2007
    Rep Power

    Default [SOLVED] External LDAP auth not works

    (I solved this but leave message for future search)


    I'm installed zcs-4.5.9_GA_1454.FC5.tgz on FC5 x86. Now I'm trying to get external authentication working.

    I do setup in 'Authentication Configuration Wizard' and authentication test failed.

    External LDAP is fedora-ds-1.1.0.

    ldapsearch to fedora-ds with same setting works fine, tested uid exists.

    I'm trying debug this issue and found error: search base should be stripped. Log from FDS:
    conn=76 op=1 SRCH base="ou=test,dc=mydomain\0a" scope=2 filter="(uid=vvyttest)" attrs=ALL

    Full error message:

    javax.naming.NameNotFoundException: [LDAP: error code 32 - No Such Object]; remaining name 'our search base'
    at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.jav a:3030)
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt
    at com.sun.jndi.ldap.LdapCtx.searchAux( 812)
    at com.sun.jndi.ldap.LdapCtx.c_search( 35)
    at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_sea rch(
    at com.sun.jndi.toolkit.ctx.PartialCompositeDirContex
    at com.zimbra.cs.account.ldap.LdapUtil.searchDir(Ldap
    at com.zimbra.cs.account.ldap.LdapUtil.ldapAuthentica te(
    at com.zimbra.cs.account.ldap.Check.checkAuthConfig(C
    at com.zimbra.cs.service.admin.CheckAuthConfig.handle (
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:85)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:220)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at ternalDoFilter(
    at Filter(
    at org.apache.catalina.core.StandardWrapperValve.invo ke(
    at org.apache.catalina.core.StandardContextValve.invo ke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke (
    at org.apache.catalina.core.StandardEngineValve.invok e(
    at org.apache.catalina.valves.AccessLogValve.invoke(A
    at org.apache.catalina.connector.CoyoteAdapter.servic e(
    at org.apache.coyote.http11.Http11Processor.process(H
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt
    at Socket(
    at ead.runIt(
    at org.apache.tomcat.util.threads.ThreadPool$ControlR

  2. #2
    Join Date
    May 2006
    Rep Power


    Welcome to the forums,
    Quote Originally Posted by vyt View Post
    (I solved this but leave message for future search)
    -I'm going to append solved to the thread title

    Stick around, we hope you enjoy the forums!

Similar Threads

  1. External Ldap AUTH
    By charlesr in forum Administrators
    Replies: 0
    Last Post: 10-26-2007, 09:01 AM
  2. About external LDAP problem, urgent!
    By bylong in forum Administrators
    Replies: 5
    Last Post: 08-24-2007, 07:10 PM
  3. External LDAP Problem
    By facerw in forum Installation
    Replies: 7
    Last Post: 05-08-2007, 04:29 AM
  4. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 02:17 PM
  5. LDAP External Auth Fedora Directory Services
    By prpatrol in forum Administrators
    Replies: 3
    Last Post: 08-14-2006, 06:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts