I had a production box that was rooted and needed to be rebuilt. It's a small server with 20-some-odd users so it wasn't a huge deal.

The box was originally running zcs-3.x.x, and over the course of the last two years has been gradually updated to 5.0 RC1. (from 4.5.7)

Typically when I move a Zimbra install, I do the following:

- stop zimbra services as user: zimbra
- 'killall -9 -u zimbra' as root
- tar -pczf mybackup.tar.gz /opt/zimbra
- move mybackup.tar.gz to /opt on new machine
- do a vanilla install of EXACT SAME version of Zimbra
- rename /opt/zimbra and extract backup to /opt
- run ./install.sh again
So after doing this, I encountered problems starting the MTA - it was asking for a password, and the log showed errors consistent with either permissions issues, and/or another program listening on the SMTP port.

So I did the usual stuff, ran /opt/zimbra/libexec/zmfixperms as root, rebooted, made sure nothing was using Port 25.... Still no MTA.

Finally, I ran the 'zmmtactl start' command as user: zimbra, and found a ton of errors that referenced /opt/zimbra/postfix-2.2.9 - and a lightbulb went on!

I fixed the problem by renaming the folder /opt/zimbra/postfix-2.2.9 to something else, and then creating a symlink that pointed that folder to /opt/zimbra/postfix- and MTA started!

I don't know if this should be a bug, or even how to search for it but I thought I should definitely get it out here in case it helps someone else.