Results 1 to 3 of 3

Thread: [SOLVED] Queue Temporarily Suspended - can't connect to

  1. #1
    Join Date
    Jul 2007
    San Jose, CA
    Rep Power

    Default [SOLVED] Queue Temporarily Suspended - can't connect to

    This situation may be related to this old thread (which doesn't really show a solution), but since I saw it today with 4.5.9 I wanted to post this for comments and info.

    This morning I had my entire MTA queue suspend everything that was supposed to be delivered. Each message had a status in the mail queue of "Delivery temporarily suspended", and here's a sample entry from /var/log/mail.log:
    Nov 21 10:58:14 mail postfix/qmgr[1288]: 4DA9B3D0C57: to=<>
    , relay=none, delay=3645, status=deferred (delivery temporarily suspended: connect to[]: Connection refused)
    zmcontrol stop and start did not accomplish anything, and neither did zmfixperms. However, the thread above suggested "something to do with amavisd", so I tried disabling, and immediately re-enabling, the "Enable spam checking and antivirus" checkbox from the AS/AV tab, global settings, in the UI. Within a minute of doing this all the deferred mail went through.

    I don't have any idea what caused this to hang; however, earlier this morning I changed my spam settings to a lower tag percent (using the UI), and did NOT stop/restart spam filtering. It appears that the queue hung when I did this.

    There may be a bug to report in this; I'll wait for further confirmation from other users first. But in the meantime, if you find your formerly-working MTA suspended, try stopping and restarting antispam/antivirus from the UI and see if it kicks it loose for you.

    Happy Thanksgiving everyone!


    Note: Please see this wiki for complete instructions and descriptions of this issue. The problem may also manifest itself with the warning:
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: X.XX Recommended version: Y.YY
    DON'T PANIC! Read ``
    Last edited by dwmtractor; 06-26-2008 at 08:58 AM. Reason: Link to Wiki

  2. #2
    Join Date
    Feb 2007
    Rep Power


    We experienced the same problem overnight and in to this morning, with the same errors in /var/log/mail.log. The only conclusion I came to was that it was related to the spam/AV services.

    On Thursday evening I upgraded the server to 4.5.10. On Friday evening, I realized that the spam and anti-virus services were running (we have ProofPoint as a separate perimeter MTA, and it handles spam & AV). I unchecked the options for "Anti-Spam" and "Anti-Virus" on the Services tab of the Server admin web interface and clicked Save. However, I never did a stop/start of zmcontrol.

    A co-worker rebooted the server today, which seems to have resolved the issue.

    This sounds like a bug with reproducible results, based on dwmtractor's post and the issue we experienced today.
    Jonathan Bare, ACSA
    Mid-Atlantic Computer Solutions, Alexandria, Virginia

  3. #3
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    ClamAV can be a bit picky. Sometimes it will download a virus update, and the MD5 will be wrong. If it is, then ClamAV usually goes down, and the system suspends delivery.

    You'll know this is the case if you go to the /var/log/zimbra.log and you see that ClamAV isn't running.

    To fix this, you can delete the defs, and try again:
      su - zimbra
      mkdir /tmp/clamdb
      mv /opt/zimbra/clamav/db/* /tmp/clamdb
      zmprov ms `zmhostname` +zimbraServiceEnabled antivirus
     /opt/zimbra/clamav/bin/freshclam --config-file=/opt/zimbra/conf/freshclam.conf 
     zmamavisctl stop
    zmamavisctl start

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  3. Debian, Zimbra 4, deferred mail Problem
    By tbovingdon in forum Installation
    Replies: 11
    Last Post: 11-25-2006, 01:36 PM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM
  5. Can't send or receive mails from Zimbra
    By ppurama in forum Administrators
    Replies: 4
    Last Post: 11-14-2005, 09:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts