Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Zimbra Locks Up occasionally

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Location
    Dallas, TX, US
    Posts
    14
    Rep Power
    10

    Default Zimbra Locks Up occasionally

    Very weird problem. I have installed Zimbra at a clients site (25 users). They are accessing it via web, Eudora and Thunderbird (Mac). Occasionally, it will lock up and no one inside their network can access the server. After I bump the service (zmcontrol stop ; zmcontrol start), all is well. It appears to be doing this one or two times a day. I have no problems ssh'ing into the machine, and at least one time I was able to check mail from the outside, but no one on the inside could do so until I' had bumped the service.

    They had a very active web server on the same paired T1's which was saturating the network, but we moved that machine and network traffic is down. The main traffic now is e-mail, all handled by zimbra.

    Any suggestions? I see nothing horrible in /var/log/zimbra.log. Any suggestions on where to look next time this happens, or how to troubleshoot this. The client is willing to be without e-mail for a short time if I can successfully troubleshoot the problem.

    Thanks,

    Rod

  2. #2
    Join Date
    Sep 2005
    Posts
    93
    Rep Power
    10

    Default

    What build are you are using?

    With the server in the "locked up" state, please do a thread dump and post the results. You can generate a thread dump by executing:

    Code:
    % kill -3 <tomcat_pid>

  3. #3
    Join Date
    Oct 2005
    Location
    Dallas, TX, US
    Posts
    14
    Rep Power
    10

    Default Which log contains the dump

    Client reported there was a problem, so I sent sig 3. Which log contains the dump, and what am I looking for. I don't want to post the whole log as it is over a meg. I saved messages and zimbra.log.

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default stack traces

    /opt/zimbra/tomcat/log/catalina.out

  5. #5
    Join Date
    Nov 2005
    Posts
    63
    Rep Power
    10

    Default

    I am seeing similar results on an Beta 3 install with ~35 users with ~95% of the access via the web client. I will attempt to grab a dump today also.

  6. #6
    Join Date
    Sep 2005
    Posts
    93
    Rep Power
    10

    Default

    what I think Marc is trying to say is that the catalina.out file will be much smaller and you should be able to snip out just the thread dumps from it -- which will be much smaller and reasonable to post into the forums here. The only thing we (right now) is the thread dump itself...

  7. #7
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    me too! catalina.out attached. i get regular lockups about once a day. the server is currently in testing and being used only by one user using IMAP and one user through webmail (zimbra). version 3.0.0_M4_23.DEBIAN3.1
    Attached Files Attached Files

  8. #8
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default m4 debian3.1

    This is a cvs build?

  9. #9
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    yes, i rebuild from cvs every couple of days. these hangs have been consistent across all builds.

  10. #10
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default cvs builds

    We're syncing a new branch to cvs ('CRAY') that should have a fix for this:

    cvs -d blahblahblah co CRAY

    should have a fix for the IMAP lockups (or wait, and we'll release binary builds today-ish)

Similar Threads

  1. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  2. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  4. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •