Results 1 to 2 of 2

Thread: LDAP fields not visible in Contacts (GAL)

Hybrid View

  1. #1
    Join Date
    Oct 2007
    Location
    Massachusetts
    Posts
    76
    Rep Power
    8

    Default LDAP fields not visible in Contacts (GAL)

    The only attribute/field that is displayed is Email.
    No phone, address, department, etc
    I use "Detailed Cards" format but there are no details but there are no details!

  2. #2
    Join Date
    Aug 2007
    Location
    New York
    Posts
    59
    Rep Power
    8

    Default check the ldap fields

    First look at what zimbra is using to map LDAP attributes to the GAL:

    # zmprov gacf | grep zimbraGalLdapAttrMap
    zimbraGalLdapAttrMap: co=workCountry
    zimbraGalLdapAttrMap: company=company
    zimbraGalLdapAttrMap: description=notes
    zimbraGalLdapAttrMap: displayName,cn=fullName
    zimbraGalLdapAttrMap: givenName,gn=firstName
    zimbraGalLdapAttrMap: initials=initials
    ...

    Then look at what the values are for a specific account to see if they match the Attribute Map:

    For example, the above mapping:
    zimbraGalLdapAttrMap: displayName,cn=fullName
    says that the displayName (if exists) will map to the fullName displayed on the GAL. If displayName doesn't exist or is empty, then it will use cn.

    So look at the account to see if displayName or cn is set:

    zmprov gacf account@domain.name | grep displayName

    zmprov gacf account@domain.name | grep cn

    Hope this helps.
    Jeffrey Turmelle
    International Research Institute for Climate and Society
    Earth Institute at Columbia University


    Release 7.2.7_GA_2942.RHEL5_64_20140314190109 RHEL5_64 NETWORK edition.

Similar Threads

  1. LDAP Filter issue and GAL
    By G-Money in forum Administrators
    Replies: 2
    Last Post: 06-24-2010, 12:13 PM
  2. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  3. External LDAP GAL help (please)
    By dlochart in forum Administrators
    Replies: 24
    Last Post: 07-09-2007, 05:46 PM
  4. All contacts via LDAP in thunderbird, not just GAL
    By kristian.penno in forum Administrators
    Replies: 1
    Last Post: 06-15-2007, 06:11 AM
  5. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •