Results 1 to 5 of 5

Thread: 4.5.x NE to 5.0 NE Migration Testing

  1. #1
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default 4.5.x NE to 5.0 NE Migration Testing

    I see in the 5.0 RC2 announcement:

    "It is not possible to upgrade a current Network Edition install to RC2."

    How then do we test an upgrade?

    In our case we want to migrate our 32-bit SuSE ES9 servers to 64-bit SuSE ES10.

    Our testing plan was to:
    1. zmcontrol stop on 32-bit ES9 production server
    2. rsync /opt/zimbra to USB drive.
    3. Connect USB drive to new hardware and do the standard restore as per the wiki (same 4.5 Zimbra version).
    4. Upgrade testing server from 32-bit SuSE ES9 to 64-bit ES10.
    5. Upgrade Zimbra from 32-bit ES9 to 64-bit ES10. (Doing the LDAP export/re-import as others have reported.)


    But, with the restriction on RC2, we can't test the last step.

    When will be able to do that?

    Thanks!
    Mark

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I know you're going to hate this, but here goes:
    RC2 isn't meant to be run as production.

    We had to block upgrades to prevent users to breaking their systems

    Will it break it? Probably not. . but that's why it's an RC.

    However, there might be a certain script in /zcs-NETWORK-blah/util/ that you can edit

  3. #3
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    Quote Originally Posted by jholder View Post
    I know you're going to hate this, but here goes:
    RC2 isn't meant to be run as production.

    We had to block upgrades to prevent users to breaking their systems

    Will it break it? Probably not. . but that's why it's an RC.

    However, there might be a certain script in /zcs-NETWORK-blah/util/ that you can edit
    No worries, I'll take a look at the script, thanks.

    But I guess the real question is whether an in-place upgrade from 4.5.x to 5.0 will ever be officially supported by Zimbra, and, if so, in which version do you believe/guess/speculate that we will be able to test this officially-supported functionality?

    Thanks!
    Mark

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Excellent question:
    Yes, NE upgrade support from 4.5.x to 5.0 GA will be supported.

    We're thoroughly testing upgrade processes in our QA environments.

  5. #5
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Smile

    Quote Originally Posted by jholder View Post
    Excellent question:
    Yes, NE upgrade support from 4.5.x to 5.0 GA will be supported.

    We're thoroughly testing upgrade processes in our QA environments.
    I couldn't imagine otherwise, but I confess the RC2 announcement did get me a bit nervous!

    Thanks for lowering my systolic blood pressure!
    Mark

Similar Threads

  1. Outlook 2007 Beta Overview
    By GregA in forum Zimbra Connector for Outlook
    Replies: 19
    Last Post: 03-03-2008, 03:24 PM
  2. Downgrade from 5.0 beta to 4.5.x?
    By jbwiv in forum Administrators
    Replies: 7
    Last Post: 11-20-2007, 04:37 AM
  3. Migrating from Zimbra 4.5.x to 5.0 beta?
    By jbwiv in forum Administrators
    Replies: 2
    Last Post: 11-16-2007, 10:24 AM
  4. [SOLVED] ZCS 5.0 Beta Testing
    By link915 in forum Administrators
    Replies: 7
    Last Post: 09-20-2007, 12:34 PM
  5. 5.0 and 4.5.x on same back-end ldap?
    By zaf in forum Installation
    Replies: 1
    Last Post: 06-06-2007, 12:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •