Results 1 to 3 of 3

Thread: zmrestore -restoreToTime not working

  1. #1
    Join Date
    Oct 2007
    Posts
    88
    Rep Power
    8

    Default zmrestore -restoreToTime not working

    Hi:

    I'm testing backup/restore, and noticed that when I ask zmrestore to restore to a point in time, I still get all the messages in that backup.

    Here's the command I'm using:

    zmrestore -a jwasil02@zstore.usg.tufts.edu -ca -pre restore_ -restoreToTime 20071201.110000.000 -lb full-20071208.060004.825

    In this case, the newest messages in my restored mailbox are from 12/8, not 12/1.

    Is this a bug, or am I missing something?

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Fyi, you're trying to restore to a time that's before the full...
    You gave a restoreToTime of 20071201 when full-20071208
    Fulls after the date wouldn't have the incrementals/redologs to the prior time - they are like a one time snapshot of everything - so it's going back as far as it can, which is thought to be better than nothing appearing.
    Is there a full before 20071201 to test off of? Using the -lb command again of course to specify this older full, then it should play incrementals and redologs up till your restoreToTime

    There's other options as well --restoreToRedoSeq & --restoreToIncrLabel
    CLI zmrestore Network Edition only - Zimbra :: Wiki

    Date formats are:
    20070827.104151.000
    20070827.104151
    20070827104151000
    20070827104151
    2007/08/27 10:41:51 000
    2007/08/27 10:41:51
    2007/08/27-10:41:51-000
    2007/08/27-10:41:51

    These options affect redo log replay phase of restore:
    -restoreToIncrLabel <arg> : Replay redo logs up to and including this incremental backup
    -restoreToRedoSeq <arg> : Replay up to and including this redo log sequence
    -restoreToTime <arg> : Replay redo logs until this time
    Without these options, all redo logs since full backup are replayed, and also the logs not yet backed up (those under /opt/zimbra/redolog/archive and /opt/zimbra/redolog/redo.log) if -br option is not specified. The new options allow cutting off the replay at certain point. (Of course, no logs are replayed at all if -rf option is used to restore to full backup only.)
    Last edited by mmorse; 12-12-2007 at 08:09 PM.

  3. #3
    Join Date
    Oct 2007
    Posts
    88
    Rep Power
    8

    Default

    I guess the docs aren't clear about which backup files you'd use if you were doing a point-in-time restore.

    Using the earlier full backup did make it work as expected. Thanks!

    -j

Similar Threads

  1. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 12:41 PM
  2. zmrestore with restoreToTime
    By wfweaver in forum Administrators
    Replies: 5
    Last Post: 11-28-2007, 01:12 PM
  3. Zimlets all not working?
    By jadestorm in forum Administrators
    Replies: 16
    Last Post: 10-28-2007, 08:25 PM
  4. zmrestore restoreToTime problem
    By magsuser2007 in forum Administrators
    Replies: 5
    Last Post: 10-15-2007, 02:41 PM
  5. Zimbra stoped working overnight
    By vlskip in forum Installation
    Replies: 32
    Last Post: 03-07-2006, 01:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •