Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: cannot send email out User unknown (in reply to RCPT TO command)

  1. #1
    Join Date
    Feb 2006
    Posts
    68
    Rep Power
    9

    Question cannot send email out User unknown (in reply to RCPT TO command)

    Hi people,

    Using zimbra on Centos 5, I can receive emails correctly but if I try to send emails to hotmail, yahoo, you name it...i instantly get a bounced email with this info:


    This is the Postfix program at host mail.goldenpartners.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <erick@ptysystems.com>: host ptysystems.com[201.225.227.138] said: 550 5.1.1
    <erick@ptysystems.com>... User unknown (in reply to RCPT TO command)

    Im using a zimbra account called test@goldenpartners.com that can receive all kinds of emails, and then im using this acccount via zimbra web interface to send a test email to any kind of external email (internal works fine).
    My DNS are all ok.

    maybe something is messed up in postfix.

    Suggestions?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Check you DNS A & MX records plus your /etc/hosts file and post some details that they're correct. You should also check the 'mynetworks' setting. Search the forums and wiki as they've all been covered in detail many times.

    BTW, this is probably part of the problem of your server name change and 'too many hops' thread.
    Last edited by phoenix; 12-15-2007 at 11:27 PM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2006
    Posts
    68
    Rep Power
    9

    Default

    ok, here are the details:

    caching nameserver installed
    [root@mail ~]# cat /etc/resolv.conf
    nameserver 127.0.0.1

    [root@mail sbin]# ./postconf -n
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /opt/zimbra/postfix-2.2.9/sbin
    config_directory = /opt/zimbra/postfix-2.2.9/conf
    content_filter = smtp-amavis:[127.0.0.1]:10024
    daemon_directory = /opt/zimbra/postfix-2.2.9/libexec
    disable_dns_lookups = yes
    header_checks = pcre:/opt/zimbra/conf/postfix_header_checks
    mailbox_size_limit = 0
    mailq_path = /opt/zimbra/postfix-2.2.9/sbin/mailq
    manpage_directory = /opt/zimbra/postfix-2.2.9/man
    message_size_limit = 10240000
    mydestination = localhost
    myhostname = mail.goldenpartnership.com
    mynetworks = 127.0.0.0/8
    newaliases_path = /opt/zimbra/postfix-2.2.9/sbin/newaliases
    queue_directory = /opt/zimbra/postfix-2.2.9/spool
    recipient_delimiter =
    relayhost = 127.0.0.1
    sender_canonical_maps = ldap:/opt/zimbra/conf/ldap-scm.cf
    sendmail_path = /opt/zimbra/postfix-2.2.9/sbin/sendmail
    smtpd_client_restrictions = reject_unauth_pipelining
    smtpd_data_restrictions = reject_unauth_pipelining
    smtpd_helo_required = yes
    smtpd_recipient_restrictions = reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unlisted_recipient, reject_unau th_destination, permit
    smtpd_reject_unlisted_recipient = no
    smtpd_sasl_auth_enable = yes
    smtpd_tls_auth_only = yes
    smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
    smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_use_tls = yes
    transport_maps = ldap:/opt/zimbra/conf/ldap-transport.cf
    virtual_alias_domains = ldap:/opt/zimbra/conf/ldap-vad.cf
    virtual_alias_maps = ldap:/opt/zimbra/conf/ldap-vam.cf
    virtual_mailbox_domains = ldap:/opt/zimbra/conf/ldap-vmd.cf
    virtual_mailbox_maps = ldap:/opt/zimbra/conf/ldap-vmm.cf
    virtual_transport = error

    [root@mail sbin]# nslookup
    > mail.goldenpartnership.com
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    Non-authoritative answer:
    Name: mail.goldenpartnership.com
    Address: 190.140.206.214

    [root@mail sbin]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    192.168.1.4 mail.goldenpartnership.com mail2.goldepartnership.com mail

    Comments?
    Attached Images Attached Images

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    They don't really check the details, try the following (run on the zimbra server):

    Code:
    host `hostname`  <-- type as-is with backticks not single quotes
    dig goldenpartnership.com mx
    dig goldenpartnership.com any
    and post the details. Also check the wiki article on mynetworks, check this post as well.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Feb 2006
    Posts
    68
    Rep Power
    9

    Default

    as requested

    [zimbra@mail conf]$ host mail.goldenpartnership.com
    mail.goldenpartnership.com has address 190.140.206.214


    [zimbra@mail conf]$ host `hostname`
    mail.goldenpartnership.com has address 190.140.206.214



    [zimbra@mail conf]$ dig goldenpartnership.com mx

    ; <<>> DiG 9.3.3rc2 <<>> goldenpartnership.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19440
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;goldenpartnership.com. IN MX

    ;; ANSWER SECTION:
    goldenpartnership.com. 12668 IN MX 0 mail.goldenpartnership.com.

    ;; AUTHORITY SECTION:
    goldenpartnership.com. 83966 IN NS ns2.secureoverseas.com.
    goldenpartnership.com. 83966 IN NS ns1.secureoverseas.com.

    ;; ADDITIONAL SECTION:
    mail.goldenpartnership.com. 11966 IN A 190.140.206.214
    ns1.secureoverseas.com. 172380 IN A 203.89.182.61
    ns2.secureoverseas.com. 172380 IN A 203.89.182.62

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Dec 16 11:25:35 2007
    ;; MSG SIZE rcvd: 159

    [zimbra@mail conf]$

    [zimbra@mail conf]$ dig goldenpartnership.com any

    ; <<>> DiG 9.3.3rc2 <<>> goldenpartnership.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53910
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 2, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;goldenpartnership.com. IN ANY

    ;; ANSWER SECTION:
    goldenpartnership.com. 12636 IN MX 0 mail.goldenpartnership.com.
    goldenpartnership.com. 12636 IN A 203.89.182.60
    goldenpartnership.com. 83934 IN NS ns1.secureoverseas.com.
    goldenpartnership.com. 83934 IN NS ns2.secureoverseas.com.

    ;; AUTHORITY SECTION:
    goldenpartnership.com. 83934 IN NS ns2.secureoverseas.com.
    goldenpartnership.com. 83934 IN NS ns1.secureoverseas.com.

    ;; ADDITIONAL SECTION:
    mail.goldenpartnership.com. 11934 IN A 190.140.206.214
    ns1.secureoverseas.com. 172348 IN A 203.89.182.61
    ns2.secureoverseas.com. 172348 IN A 203.89.182.62

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Dec 16 11:26:07 2007
    ;; MSG SIZE rcvd: 203

    [zimbra@mail conf]$


    [zimbra@mail conf]$ postconf mynetworks
    mynetworks = 127.0.0.0/8

    [zimbra@mail conf]$ zmprov getServer mail.goldenpartnership.com | grep zimbraMtaMyNetworks
    zimbraMtaMyNetworks: 127.0.0.0/8
    [zimbra@mail conf]$

    zmprov modifyServer mail.goldenpartnership.com zimbraMtaMyNetworks '127.0.0.0/8 192.168.1.4/32'
    Last edited by eaperezh; 12-16-2007 at 09:49 AM.

  6. #6
    Join Date
    Feb 2006
    Posts
    68
    Rep Power
    9

    Default

    Here are my test:
    from gmail to zimbra

    Dec 16 11:42:03 mail zmtomcatmgr[4916]: status OK
    Dec 16 11:42:12 mail postfix/smtpd[4621]: connect from wa-out-1112.google.com[209.85.146.176]
    Dec 16 11:42:13 mail postfix/smtpd[4621]: 87DC929F83AC: client=wa-out-1112.google.com[209.85.146.176]
    Dec 16 11:42:13 mail postfix/cleanup[4616]: 87DC929F83AC: message-id=<b5e9df9e0712160841l24652e62qd51e7f8a512db1c4@m ail.gmail.com>
    Dec 16 11:42:13 mail postfix/qmgr[4550]: 87DC929F83AC: from=<erick@ptysystems.com>, size=1755, nrcpt=1 (queue active)
    Dec 16 11:42:21 mail postfix/smtpd[4631]: connect from localhost.localdomain[127.0.0.1]
    Dec 16 11:42:21 mail postfix/smtpd[4631]: 63B4A29F83AF: client=localhost.localdomain[127.0.0.1]
    Dec 16 11:42:21 mail postfix/cleanup[4615]: 63B4A29F83AF: message-id=<b5e9df9e0712160841l24652e62qd51e7f8a512db1c4@m ail.gmail.com>
    Dec 16 11:42:21 mail postfix/smtpd[4631]: disconnect from localhost.localdomain[127.0.0.1]
    Dec 16 11:42:21 mail postfix/qmgr[4550]: 63B4A29F83AF: from=<erick@ptysystems.com>, size=2408, nrcpt=1 (queue active)
    Dec 16 11:42:21 mail postfix/smtp[4627]: 87DC929F83AC: to=<eaperezh@goldenpartnership.com>, relay=127.0.0.1[127.0.0.1], delay=9, status=sent (250 Ok: queued as 63B4A29F83AF)
    Dec 16 11:42:21 mail postfix/qmgr[4550]: 87DC929F83AC: removed
    Dec 16 11:42:23 mail postfix/lmtp[4617]: 63B4A29F83AF: to=<eaperezh@goldenpartnership.com>, relay=mail.goldenpartnership.com[192.168.1.4], delay=2, status=sent (250 2.1.5 OK)
    Dec 16 11:42:23 mail postfix/qmgr[4550]: 63B4A29F83AF: removed
    Dec 16 11:42:44 mail postfix/smtpd[4621]: disconnect from wa-out-1112.google.com[209.85.146.176]

    from zimbra to gmail

    Dec 16 11:44:02 mail postfix/smtpd[4621]: connect from localhost.localdomain[127.0.0.1]
    Dec 16 11:44:02 mail postfix/smtpd[4621]: B71E629F83AC: client=localhost.localdomain[127.0.0.1]
    Dec 16 11:44:02 mail postfix/cleanup[5326]: B71E629F83AC: message-id=<18046169.181197823440567.JavaMail.root@mail.go ldenpartnership.com>
    Dec 16 11:44:03 mail postfix/qmgr[4550]: B71E629F83AC: from=<eaperezh@goldenpartnership.com>, size=1075, nrcpt=1 (queue active)
    Dec 16 11:44:03 mail postfix/smtpd[4621]: disconnect from localhost.localdomain[127.0.0.1]
    Dec 16 11:44:03 mail zmtomcatmgr[5458]: status requested
    Dec 16 11:44:03 mail zmtomcatmgr[5458]: status OK
    Dec 16 11:44:05 mail postfix/smtpd[5548]: connect from localhost.localdomain[127.0.0.1]
    Dec 16 11:44:05 mail postfix/smtpd[5548]: E73E329F83AF: client=localhost.localdomain[127.0.0.1]
    Dec 16 11:44:05 mail postfix/cleanup[5326]: E73E329F83AF: message-id=<18046169.181197823440567.JavaMail.root@mail.go ldenpartnership.com>
    Dec 16 11:44:06 mail postfix/smtpd[5548]: disconnect from localhost.localdomain[127.0.0.1]
    Dec 16 11:44:06 mail postfix/qmgr[4550]: E73E329F83AF: from=<eaperezh@goldenpartnership.com>, size=1717, nrcpt=1 (queue active)
    Dec 16 11:44:06 mail postfix/smtp[5459]: B71E629F83AC: to=<erick@ptysystems.com>, relay=127.0.0.1[127.0.0.1], delay=4, status=sent (250 Ok: queued as E73E329F83AF)
    Dec 16 11:44:06 mail postfix/qmgr[4550]: B71E629F83AC: removed
    Dec 16 11:44:07 mail postfix/smtp[5549]: E73E329F83AF: to=<erick@ptysystems.com>, relay=ptysystems.com[201.225.227.138], delay=2, status=bounced (host ptysystems.com[201.225.227.138] said: 550 5.1.1 <erick@ptysystems.com>... User unknown (in reply to RCPT TO command))
    Dec 16 11:44:07 mail postfix/cleanup[5326]: 0B76A29F83B0: message-id=<20071216164407.0B76A29F83B0@mail.goldenpartner ship.com>
    Dec 16 11:44:07 mail postfix/qmgr[4550]: 0B76A29F83B0: from=<>, size=3764, nrcpt=1 (queue active)
    Dec 16 11:44:07 mail postfix/qmgr[4550]: E73E329F83AF: removed
    Dec 16 11:44:07 mail postfix/lmtp[5628]: 0B76A29F83B0: to=<eaperezh@goldenpartnership.com>, relay=mail.goldenpartnership.com[192.168.1.4], delay=0, status=sent (250 2.1.5 OK)
    Dec 16 11:44:07 mail postfix/qmgr[4550]: 0B76A29F83B0: removed

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by eaperezh View Post
    as requested

    [zimbra@mail conf]$ host mail.goldenpartnership.com
    mail.goldenpartnership.com has address 190.140.206.214
    You din't follow my instructions from the post earlier, you've entered the wrong command. Please do it again and enter what I told you in that post.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Feb 2006
    Posts
    68
    Rep Power
    9

    Default

    Sorry, I guess im too tired.


    [zimbra@mail conf]$ host `hostname`
    mail.goldenpartnership.com has address 190.140.206.214

    [zimbra@mail conf]$ dig goldenpartnership.com mx

    ; <<>> DiG 9.3.3rc2 <<>> goldenpartnership.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45206
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;goldenpartnership.com. IN MX

    ;; ANSWER SECTION:
    goldenpartnership.com. 10305 IN MX 0 mail.goldenpartnership.com.

    ;; AUTHORITY SECTION:
    goldenpartnership.com. 81603 IN NS ns2.secureoverseas.com.
    goldenpartnership.com. 81603 IN NS ns1.secureoverseas.com.

    ;; ADDITIONAL SECTION:
    mail.goldenpartnership.com. 9603 IN A 190.140.206.214
    ns1.secureoverseas.com. 170017 IN A 203.89.182.61
    ns2.secureoverseas.com. 170017 IN A 203.89.182.62

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Dec 16 12:04:58 2007
    ;; MSG SIZE rcvd: 159

    [zimbra@mail conf]$

    [zimbra@mail conf]$ dig goldenpartnership.com any

    ; <<>> DiG 9.3.3rc2 <<>> goldenpartnership.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15345
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 2, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;goldenpartnership.com. IN ANY

    ;; ANSWER SECTION:
    goldenpartnership.com. 10280 IN MX 0 mail.goldenpartnership.com.
    goldenpartnership.com. 10280 IN A 203.89.182.60
    goldenpartnership.com. 81578 IN NS ns1.secureoverseas.com.
    goldenpartnership.com. 81578 IN NS ns2.secureoverseas.com.

    ;; AUTHORITY SECTION:
    goldenpartnership.com. 81578 IN NS ns2.secureoverseas.com.
    goldenpartnership.com. 81578 IN NS ns1.secureoverseas.com.

    ;; ADDITIONAL SECTION:
    mail.goldenpartnership.com. 9578 IN A 190.140.206.214
    ns1.secureoverseas.com. 169992 IN A 203.89.182.61
    ns2.secureoverseas.com. 169992 IN A 203.89.182.62

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Dec 16 12:05:23 2007
    ;; MSG SIZE rcvd: 203

    [zimbra@mail conf]$

    I also included the Global settings of the MTA in the image attached.
    Also, I am using a caching DNS server on the zimbra server. I have no internal DNS servers, my cahcing DNS server (bind) then goes out to the internet to resolve.

    my /etc/hosts file
    [zimbra@mail conf]$ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    192.168.1.4 mail.goldenpartnership.com mail

    my resolv.conf file
    [zimbra@mail conf]$ cat /etc/resolv.conf
    nameserver 127.0.0.1
    [zimbra@mail conf]$

    Thanks again.
    Attached Images Attached Images

  9. #9
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    How about remove the localhost & port from 'relay mta for external delivery' & then enable dns lookups.
    (I noticed your server values are set differently from global so be sure they are at least set in server properly. If you 'reset to global' then change global they'll match.)

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by eaperezh View Post
    Sorry, I guess im too tired.


    [zimbra@mail conf]$ host `hostname`
    mail.goldenpartnership.com has address 190.140.206.214
    OK, that's the problem. You have it pointing to your Public IP not your LAN IP, you'll need to set-up a Split DNS as your server is behind a NAT device.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Server platform change RH to Ubuntu issues
    By marke in forum Administrators
    Replies: 5
    Last Post: 11-07-2007, 12:27 PM
  2. Mysql error on install
    By tommygun in forum Installation
    Replies: 17
    Last Post: 05-29-2007, 10:29 PM
  3. ZIMBRA!!!!! Error zmcontrol status and others
    By orison in forum Installation
    Replies: 8
    Last Post: 02-03-2007, 07:52 PM
  4. Zimbra Upgrade FAILED Badly
    By kelley.ch in forum Installation
    Replies: 1
    Last Post: 09-04-2006, 05:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •