Results 1 to 2 of 2

Thread: Setting LMTP host: a better way than setting at user level

  1. #1
    Join Date
    Dec 2007
    Posts
    1
    Rep Power
    7

    Default Setting LMTP host: a better way than setting at user level

    We switched over to Zimbra recently, (zcs-4.5.8_GA_1394 on Ubuntu 6.0.6, single-server) and had several problems with non-obvious configuration settings, which we fixed after digging through forums.

    However for one fix we used, I am sure there is a better alternative.

    Currently, every time we create a new user in our main domain (different from the default domain), we have to force it use the local server for receiving mails off the queue via LMTP, via the following LDAP configuration:
    zmprov ma username@ourhost.co.mz zimbraMailTransport lmtp:192.168.0.250:7025

    ...where 192.168.0.250 is the IP of the server.

    Obviously the downside of this approach is that we have to perform this command-line step every time we create a new user.

    I am sure there must be a better way, either:
    a) Setting a global or domain-level setting which applies to all users
    OR
    b) Setting a template value which all new users take upon creation.

    Unfortunately we could not find such a value and the Zimbra documentation is especially unclear on what are the correct values you can put in the several LMTP-related fields you can set via the webadmin UI. For instance, reading through the forums, some fields appear to require hostname, others FQDN, others IP address, and others IP address plus port.

    If anyone could suggest a better method, or simply point me at an LDAP schema reference which explains the available options, that would be much appreciated.

    Cameron Smith
    Mozambique

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Welcome to the forums,
    Quote Originally Posted by muriwo View Post
    Currently, every time we create a new user in our main domain (different from the default domain), we have to force it use the local server for receiving mails off the queue via LMTP, via the following LDAP configuration:
    zmprov ma username@ourhost.co.mz zimbraMailTransport lmtp:192.168.0.250:7025
    Your much better way-read through: Incoming Mail Problems - Zimbra :: Wiki
    Generally, messing with the zimbraMailTransport settings is not recommended because of the operational headache involved in changing the setting for every new user created on your system and making sure they all stay current and correct. You're better off running a small local DNS.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •