Results 1 to 8 of 8

Thread: new account

  1. #1
    Join Date
    Dec 2007
    Posts
    12
    Rep Power
    7

    Unhappy new account

    I can't add a new account from admin GUI....did somebody already found this promblem....

    the error massege :

    Message: system failure: createAccount
    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver

    but if i created with command line like

    zmprov ca iwansiahaan@maestronic.co.id 123654

    there was no error and account can created ?

    Whats happend with my zimbra ?

  2. #2
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    Do you see any errors in your /opt/zimbra/log/mailbox.log file at the time that error occurs?

  3. #3
    Join Date
    Dec 2007
    Posts
    12
    Rep Power
    7

    Default help

    no there was no error i found in mailbox.log when i created a new account...

  4. #4
    Join Date
    Jun 2006
    Posts
    34
    Rep Power
    9

    Default

    It seems our environment has recently picked up this same problem.

    We are running zimbra-core-4.5.10_GA_1575.FC5-20071117095155 .

    Here's the error in mailbox.log:

    Code:
    2008-01-11 11:45:39,567 INFO  [http-7071-Processor50] [name=admin@XXX;ip=XXX;ua=ZimbraWebClient - FF2.0 (Win)/undefined;] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: system failure: createAccount
            at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:165)
            at com.zimbra.cs.account.ldap.LdapUtil.createEntry(LdapUtil.java:1028)
            at com.zimbra.cs.account.ldap.LdapProvisioning.createAccount(LdapProvisioning.java:715)
            at com.zimbra.cs.account.ldap.LdapProvisioning.createAccount(LdapProvisioning.java:580)
            at com.zimbra.cs.service.admin.CreateAccount.handle(CreateAccount.java:55)
            at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:266)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:163)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:85)
            at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:220)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
            at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:152)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
            at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
            at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
            at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
            at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
            at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
            at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:541)
            at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
            at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
            at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:667)
            at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
            at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
            at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
            at java.lang.Thread.run(Thread.java:619)
    Caused by: javax.naming.NamingException: [LDAP: error code 80 - index generation failed]; remaining name 'uid=XXX'
            at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.java:3049)
            at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2951)
            at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCtx.java:2758)
            at com.sun.jndi.ldap.LdapCtx.c_createSubcontext(LdapCtx.java:774)
            at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_createSubcontext(ComponentDirContext.java:319)
            at com.sun.jndi.toolkit.ctx.PartialCompositeDirContext.createSubcontext(PartialCompositeDirContext.java:248)
            at javax.naming.directory.InitialDirContext.createSubcontext(InitialDirContext.java:183)
            at com.zimbra.cs.account.ldap.LdapUtil.createEntry(LdapUtil.java:1014)
            ... 25 more
    I censored the log with "XXX".

    What gives?

  5. #5
    Join Date
    Jun 2006
    Posts
    34
    Rep Power
    9

    Default

    When I have had problems with LDAP in other applications, what I have done is that I've taken a cleartext dump of the contents, checked that it looks correct, then reset LDAP and ran the dump back in with ldapadd. This has usually fixed problems. Is it possible to try this with the Zimbra LDAP?

  6. #6
    Join Date
    Jun 2006
    Posts
    34
    Rep Power
    9

    Default

    Trying to create an account with "zmprov ca" yields an error too..

    ERROR: service.FAILURE (system failure: createAccount)

  7. #7
    Join Date
    Jun 2006
    Posts
    34
    Rep Power
    9

    Default

    This thread: http://www.zimbra.com/forums/adminis...dap-index.html seems to be about the same error message, but the solution (upgrade to 4.5.6) is not viable in my case.

  8. #8
    Join Date
    Jun 2006
    Posts
    34
    Rep Power
    9

    Default

    In my case this issue was solved by advice given in this thread:

    http://www.zimbra.com/forums/adminis...s-problem.html

Similar Threads

  1. One account not receving email
    By EnglishDude in forum Administrators
    Replies: 12
    Last Post: 04-30-2010, 06:19 AM
  2. Replies: 4
    Last Post: 12-21-2007, 05:43 AM
  3. Replies: 3
    Last Post: 09-18-2007, 06:55 AM
  4. Zimbra account x AD account
    By emersonlb in forum Administrators
    Replies: 2
    Last Post: 09-05-2007, 10:21 AM
  5. Problem sending mail from another account in Outlook
    By UTSCSE in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 01-25-2007, 04:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •