Page 1 of 6 123 ... LastLast
Results 1 to 10 of 64

Thread: No data in server statistics

Hybrid View

  1. #1
    Join Date
    Jan 2006
    Posts
    9
    Rep Power
    9

    Default No data in server statistics

    I have just installed Zimbra M3 on fedora core4. Everything is working fine except no data is showing up under server statistics - it just shows "Data not yet available" (server has been up and running for several days now)

    I have installed logger and SNMP and both services is running.

    Any suggestions?

    Thanks

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    It does take a day or so for all the cron jobs to fire. Is it still not working for you?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Dec 2005
    Location
    Peterborough, UK
    Posts
    140
    Rep Power
    10

    Default What reports on what?

    What's the difference between the "Server Statistics" item, and it's child item of the "Hostname"? The reason I ask is that I get statistics from "Server Statistics", but when I expand it and select the hostname I get "Data Not Yet Available" - the server has been up for about 3 months.

  4. #4
    Join Date
    Jan 2006
    Posts
    9
    Rep Power
    9

    Default No data in server stats.

    KevinH: Sorry I forgot to mention that i do get some data/grafs in the main "Server Statistics" (not grafs but rough bars) but just like FunkyPenguin I also don't get data in any of the child items "myhostname.com".

    The server has been up for 8 days now.

  5. #5
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Well looks like a bug. It should show per server stats and then total stats. We'll take a look.

    Try this:
    su - zimbra
    logmysql
    use zimbra_logger;
    select distinct(host) from mta_aggregate;

    Is your hostname (as listed in the admin console) listed in the db?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  6. #6
    Join Date
    Dec 2005
    Location
    Peterborough, UK
    Posts
    140
    Rep Power
    10

    Default

    KevinH,

    My host is listed in the db when I run through the commands:

    Code:
    mysql> select distinct(host) from mta_aggregate;
    +------+
    | host |
    +------+
    | hawk |
    +------+
    1 row in set (0.01 sec)
    I still get no information on the individual host. Would it make any difference which product I'm using? I'm running the OSS version, I thought it could be due to not running the Network version.

  7. #7
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default hostname

    That's actually the problem - the hostname in the db is "hawk", which I suspect that the zimbra host name (as specified in ldap) is hawk.domain.com -

    bug 5508

  8. #8
    Join Date
    Dec 2005
    Location
    Peterborough, UK
    Posts
    140
    Rep Power
    10

    Default

    Would that mean that to get per server stats the db would need to show the fqdn of the server?

  9. #9
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default server stats hackery

    This is a bug we're going to have to fix on our end, though there's a possible workaround.

    Create a server (zmprov cs hawk) and restart tomcat.

    That will give you the server in your list for stats (of course, then you'll have this lame pseudo-server sitting around, can't get status, etc).

    But you'll be able to see the graphs.

    FWIW - the fix we have to come up with is some way to map the hostname as known to syslogd to the hostname as known to zimbra.

  10. #10
    Join Date
    Dec 2005
    Location
    Peterborough, UK
    Posts
    140
    Rep Power
    10

    Default

    Would I be correct in thinking that on a single server setup like mine the workaround isn't a big deal, as the combined stats is for the sum total of one box, however on a multi server setup there are benefits?

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 11:27 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  4. Replies: 1
    Last Post: 04-25-2007, 08:12 AM
  5. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 10:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •