Results 1 to 9 of 9

Thread: zcs 5.0 or 4.5.10 - which is smarter for now

  1. #1
    Join Date
    Dec 2006
    Posts
    58
    Rep Power
    9

    Default zcs 5.0 or 4.5.10 - which is smarter for now

    Ok, so I've been testing a 4.5.10 deployment on a etch box, and its been working more or less as I'd expect...

    We'll be migrating 3500 email accounts to this box, and some of the new features in 5.0 are desirable, so when I heard foss 5.0 was out, I went ahead. Upgrade path failed miserably, but I suspected that might be the case as per announcement. (fine anyhow, because as of now, theres nothing in the mail store etc)

    So I get a fresh copy of foss 5.0 going on this debian etch box, and it runs well, infact quite a bit better imo. However I've noticed some bugs that I cant quite understand how they werent caught. This to me would have been noticeable in like 5secs. (clicking To: in message composer throws a js error in ajax version in any browser) (this._selectDiv has no properties
    Zimbra
    Line 2326)

    This bug is kind of a show stopper and I imagined it'd be a much easier bug to fix, but can I expect maintenance release soon? And should upgrade be more successful or should I just go with 4.5.10, and hope that their will be significant progress in the 4.5.10 to 5.0 migration in the future?
    Last edited by ronnyek; 12-27-2007 at 12:09 PM.

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Dirk had the same 4.5.10 Debian4etch setup: http://www.zimbra.com/forums/install...ebian-4-a.html
    The answer in regards to 'At the time, upgrading from SUSE 9 ZCS 4.5.x to SUSE 10 ZCS 5.0, from Fedora Core 4 and 5 ZCS 4.5.x to Fedora 7 ZCS 5.0, and from Debian 3.1 ZCS 4.5.x to Debian 4.0 ZCS 5.0 are not supported.':
    Quote Originally Posted by jholder View Post
    It means: Don't do it yet. It will break your system.
    In a few weeks, we're going to release a transition build for those who want to migrate (deb 3.1->4.0/FC4/5->F7, etc)
    However, I can't reproduce your error on a ubuntu6 box that went 4.5.10 > 5.0GA After hitting the 'To:' button the address picker works fine as in the attached pic: (noErrorOpeningAddressPicker.png)
    Last edited by mmorse; 04-14-2008 at 10:14 PM.

  3. #3
    Join Date
    Dec 2006
    Posts
    58
    Rep Power
    9

    Default

    upgrade stuff isnt a supprise, the bug itself is infact a bug, and due to the fact that I have gal turned off. GAL access being turned off shouldnt affect the ability to show personal contacts should it?

    (I also noted this in bugzilla)

  4. #4
    Join Date
    Dec 2006
    Posts
    58
    Rep Power
    9

    Default

    Mike, try turning off access to GAL for that particular user and see how it goes. I tried re-enabling gal, and the error goes away.

    As for the upgrade procedure, I understand 100%. My question was simply is the 4.5.1 migration to 5.0 going to be smoother than say the 5.0-5.x that fixes some of these whimsical bugs?

    And if not, early 2008 for those bug fixes is what... q1, or EARLY EARLY 2008?

  5. #5
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    That would make sense, because the GAL comes up first to pick from, but I still can't reproduce even if I uncheck features > Global Address List Access.
    It properly shows that I can select from just 'contacts' or 'personal and shared contacts' and hides 'Global Address List' (noErrorOpeningAddressPickerGALAccessFeatureDisabl ed.png)
    Though again, I stick to platforms that have corresponding NE builds heavily tested by QA, and am trying this on Ubuntu & CentOS(RHEL) not Debian.
    PMWeb 5.0
    Last edited by mmorse; 04-14-2008 at 10:38 PM.

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Moved your below post from the other thread:
    Quote Originally Posted by ronnyek View Post
    upgrade stuff isnt a supprise, the bug itself is infact a bug, and due to the fact that I have gal turned off. GAL access being turned off shouldnt affect the ability to show personal contacts should it?
    (I also noted this in bugzilla)
    Ah so there is an open bug on this? Then it woulds seem that you've mastered the elusive 'bugzilla search skill' - got a link?

  7. #7
    Join Date
    Dec 2006
    Posts
    58
    Rep Power
    9

    Default

    Bug 18252 - GAL disabled: Using "To:" button on new account in Compose window hangs compose

    Yeah, I didnt mean to jump in pointing fingers... I guess I can keep GAL on then disable for each provisioned user if that will solve the problem.

  8. #8
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Cool, Matt just changed the title from:
    Using "To:" button on new account in Compose window hangs compose > GAL disabled: Using "To:" button on new account in Compose window hangs compose
    & they can reproduce against qa60 so it looks like that will be addressed.
    As to 4.5.10 vs 5.0 you'll have to decide

  9. #9
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    Personally, I think the 5.0 looks good so far. A few things here and there I'm sure but nothing's been a breaker for me yet.

    I wouldn't want to plan for a major version upgrade just after you get up and running. I don't know how smooth the 4.5.10 -> 5.0 path is, but I remember at one point one of the RC's wasn't compatible with 4.x or something. I'd rather have a couple small bugs that can be patched with the next subrev than have 3500 mailboxes that may get lost in a major version upgrade.

    That being said, a lot of the 5.0 packages are for newer versions of OS's. You may not be able to upgrade, and may instead have to re-migrate.

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 05:52 AM
  2. Outlook 2007 Beta Overview
    By GregA in forum Zimbra Connector for Outlook
    Replies: 19
    Last Post: 03-03-2008, 04:24 PM
  3. ZCS 5.0 FOSS is Released!!!
    By jholder in forum Announcements
    Replies: 1
    Last Post: 12-21-2007, 12:21 PM
  4. Replies: 41
    Last Post: 10-29-2007, 03:36 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •