Results 1 to 3 of 3

Thread: Documents tab gives "HTTP ERROR: 500"

  1. #1
    Join Date
    Aug 2006
    Belgrade, Montana
    Rep Power

    Default Documents tab gives "HTTP ERROR: 500"

    ZCS Version: Zimbra 5.0 RHEL4 i386 Open Source edition (have upgraded just fine from many, many previous versions)

    I doubt this is a problem that many have run into because I think it is self-inflicted. It is hard to describe but I'll do my best. The problem existed before I upgraded to 5.0 so I don't believe it is related to the upgrade from 4.5.10 to 5.0 but the changes between the versions (switching from Tomcat to Jetty) may have altered the symptoms/error messages and what the fix might be.

    When I was first trying out Zimbra (2-ish years ago?), I wasn't sure if I wanted it to host mail for my domain ( so the first Zimbra domain I created was so it would be for rather than

    So, after using Zimbra for a while and falling in love... I decided I wanted to use it for my entire domain so I created a new domain named, changed the MX for the domain... and all was right with the world.

    Then at some time after that... I decided to delete the Zimbra domain. I have/had reasons to do so but I'll not go into them because they aren't relevant to this discussion. Anyway... before deleting the Zimbra domain I edited all of the accounts that had been created on it and took out the "mail." part and that worked fine.

    Some time later I noticed that after deleting the domain I had a few, non-critical side effects. I believe these are related to the situation I describe above but I'm not positive. Anyway... I didn't use the Document feature previously other than playing around with it a bit to see what it was like. It seems that after deleting the Zimbra, the Documents feature is broken and I get an "HTTP ERROR: 500" error... followed by a bunch of text that is only readable by Zimbra programmers.

    I'm sure there is a simple fix to this issue but given that it probably isn't that common, finding out what the simple fix is may not be easy.

    I've also noticed that my server stats information is mostly blank. I'm not sure if this is related or not... as I've had little blips of problems with the stats in the past but never looked into them.

    Have I explained the problem and what I think caused it well enough to be helpful? If not, please let me know and I'll try my best to clarify as needed.

    Here's the complete output of the error page if it could be helpful in resolving this issue:

    HTTP ERROR: 500

    error: no such account

    Caused by: error: no such account
    at ROR(
    at .java:448)
    at com.zimbra.cs.session.WikiSession.getInstance(Wiki
    at com.zimbra.cs.service.formatter.WikiFormatter.getT emplate(
    at com.zimbra.cs.service.formatter.WikiFormatter.getT emplate(
    at com.zimbra.cs.service.formatter.WikiFormatter.hand leWikiFolder(
    at com.zimbra.cs.service.formatter.WikiFormatter.form atCallback(
    at com.zimbra.cs.service.formatter.Formatter.format(F
    at com.zimbra.cs.service.UserServlet.doAuthGet(UserSe
    at com.zimbra.cs.service.UserServlet.doGet(UserServle
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:707)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.RewriteHandler.handle(Re
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$RequestHandler.he aderComplete(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:514)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(

    Powered by Jetty://

  2. #2
    Join Date
    Oct 2005
    Rep Power

    Default Our installation did the same thing! (Error 500)

    We just disabled documents as we don't use it but none the less...

  3. #3
    Join Date
    Aug 2006
    Belgrade, Montana
    Rep Power

    Default Ok it's fixed now

    Basically I turned off the documents feature per another forum posting... then I deleted the previous account that was associated with the documents. Then I created a new account... then I added the documents feature back telling it to use the new account I had created... then I had to initialize the documents using the template.

    It's kind of a blur now... so sorry for not posting the recipe.

    Here's the URLs that I found helpful.. both wiki pages:
    Documents - Enabling for 4.0 Upgrade - Zimbra :: Wiki
    Documents - Disabling or Removing - Zimbra :: Wiki

Similar Threads

  1. [SOLVED] Can't open documents (4.5.7 > 5.0rc2)
    By RJB in forum Administrators
    Replies: 3
    Last Post: 12-13-2007, 10:38 AM
  2. Documents & Notebooks Woes
    By torusgrp in forum Administrators
    Replies: 0
    Last Post: 05-11-2007, 11:19 PM
  3. Replies: 26
    Last Post: 02-12-2007, 07:23 PM
  4. Documents Feature Messed up
    By frogstarr78 in forum Installation
    Replies: 1
    Last Post: 11-07-2006, 07:14 PM
  5. Hosted Demo Documents Tab -- Hang
    By JasonChase in forum Administrators
    Replies: 2
    Last Post: 09-06-2006, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts