Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Howto Clean up GAL entries?

  1. #1
    Join Date
    Sep 2006
    Location
    Brisbane
    Posts
    132
    Rep Power
    9

    Default Howto Clean up GAL entries?

    Our GAL still displays addresses for old employee's that have since been removed from the system.

    If I search the GAL for them they don't appear but like alaises they are appearing in the to fields autocomplete when composing new mail. I would dearly like to clean all these up.

    Ideas?

  2. #2
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    8

    Default

    If the former employees were removed from the zcs system, and are still showing up in the "To:" field, I would suspect they are still in your E-mailed contacts folder. Have you checked your E-mailed contacts folder?

  3. #3
    Join Date
    Sep 2006
    Location
    Brisbane
    Posts
    132
    Rep Power
    9

    Default

    I have double checked my personal and email contacts address books and these users do not appear in them. I have also checked an numerous accounts that would never have emailed them ie a new dummy account as well and every time I goto compose a new message these stale addresses are being displayed by the autocomplete.

    The users in question where removed using the Admin GUI.

  4. #4
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    8

    Default

    Are you using external ldap?

  5. #5
    Join Date
    Sep 2006
    Location
    Brisbane
    Posts
    132
    Rep Power
    9

    Default

    no internal

  6. #6
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    8

    Default Apologies for the delay

    Any luck with this?

    Have you looked in ldap?

    su - zimbra
    ldapsearch -x -H ldap://<servername>:389 "uid=<username>"

    Do you see the username(s) (that was deleted) in the output of this command?

  7. #7
    Join Date
    Sep 2006
    Location
    Brisbane
    Posts
    132
    Rep Power
    9

    Default

    Yep I tried ldapsearch -x -H ldap://<servername>:389 "uid=<username>"

    it doesn't return anything, so one would assume it must be coming from the personal or emailed contacts address books but the old accounts in question aren't present in them.

    To double check this I've created a new dummy account and the old accounts are still being presented in the To field by autocomplete when composing a message.

    I haven't gotten any further then that.

  8. #8
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Are you sure the contacts aren't in your address book? That is actually a quite common problem.

  9. #9
    Join Date
    Sep 2006
    Location
    Brisbane
    Posts
    132
    Rep Power
    9

    Default

    John to confirm they aren't I even created a brand new test account that has never emailed anyone and they are appearing.

    Is there a way to check the contents of my local address books besides the web interface? As they also definitely do not appear in contacts or emailed contacts address books in the web gui when I check them.

  10. #10
    Join Date
    Oct 2005
    Location
    Netherlands
    Posts
    55
    Rep Power
    10

    Default

    Noticed this exact same behaviour accidently today whilst first cleaning up my personal-address book (merging/deleting entries) and then a couple of hours later a 'wrong' entries pop's up in the autolookup addressfield whilst composing a new message.
    Indicates maybe somekind of server- or clientside caching-problem?
    Using ZCS Network-edition 5.0.16 on Ubuntu 6.06.2 LTS and 8.04 LTS

Similar Threads

  1. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 08:34 AM
  2. Howto config zimbra gal with Outlook Express?
    By dehylus in forum Administrators
    Replies: 1
    Last Post: 11-26-2007, 01:14 AM
  3. Not all GAL entries in Outlook!
    By Lionel in forum Zimbra Connector for Outlook
    Replies: 10
    Last Post: 09-12-2007, 01:37 AM
  4. Calendar entries uneditable...
    By Guest6400 in forum Administrators
    Replies: 2
    Last Post: 03-30-2007, 04:57 PM
  5. GAL not correct for Outlook
    By Richard in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 03-07-2007, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •