Results 1 to 6 of 6

Thread: Postfix Mail Queue and Zimbra

  1. #1
    Join Date
    Jul 2006
    Location
    New York, NY
    Posts
    122
    Rep Power
    9

    Question Postfix Mail Queue and Zimbra

    After a recent upgrade to 4.5.10 NE I started receiving emails mostly status reports and logwatch reports to admin@mail.server.com. After searching I found the problem was the upgrade change the smtp address to admin@mail.server.com as opposed to admin@server.com.

    No biggie cleared that right up, but now I have a queue filled with email that I can't flush, at least not easily. When I run any of the postfix commands other than `mailq` I get "mail system is down." This is queue is separate from the one that Zimbra uses i.e. If I `su - zimbra` and run `mailq` it tells me Zimbra's mailq which I can check in the Admin Gui.

    It only happens on this one server, my other MTA's are fine and mailq as root and as Zimbra return the same thing.

    Anyone have anyway to do this?

    I did notice this in the main.cf file located at /etc/postfix/main.cf
    Code:
    postfix/main.cf:myhostname = mailbox.talkpoint.com
    postfix/main.cf:mydestination = mailbox.talkpoint.com, localhost.talkpoint.com, localhost
    Last edited by glitch23; 01-07-2008 at 10:26 AM.
    Because we all can't be geniuses, I'll go first.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    what about postqueue -f?

    Also, what does your /var/log/zimbra.log say?

  3. #3
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Another one to try is the postsuper command.

  4. #4
    Join Date
    Jul 2006
    Location
    New York, NY
    Posts
    122
    Rep Power
    9

    Default

    postqueue -f returns:
    Code:
    postqueue: fatal: Cannot flush mail queue - mail system is down
    postsuper -d (delete) worked they were mostly av notices since that also needs to be changed after the upgrade. Had to do them one at a time, but they are all gone now.

    Thanks.
    Because we all can't be geniuses, I'll go first.

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Can you post your /var/log/zimbra.log

    Also, what header greeting do you get if you telnet to localhost 25 ?

  6. #6
    Join Date
    Jul 2006
    Location
    New York, NY
    Posts
    122
    Rep Power
    9

    Default

    I wasn't able to find anything referring to those postfix messages or queue ID's anywhere in zimbra.log. I suspect it has something to do with the packages Ubuntu Dapper installs by default. Originally in order to get Logwatch to work I had to link /opt/zimbra/postfix/sbin/sendmail to /usr/sbin/sendmail.

    The output from telnet is:
    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mailbox.server.com ESMTP Postfix
    named changed to server.com to protect the innocent.
    Because we all can't be geniuses, I'll go first.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •