Results 1 to 7 of 7

Thread: Shared calendar only displays portion

  1. #1
    Join Date
    Oct 2007
    Location
    San Jose
    Posts
    27
    Rep Power
    8

    Default Shared calendar only displays portion

    Searched for this but didn't see it. My attached image shows it the best - when you double-click on an appointment on a shared calendar to read the full message it only displays the top portion, cutting off the calendar display. You can't close it and the only way to see the full calendar is to log out and back in. It only happens occasionally and only on calenders you don't have manager access to.

    Any ideas?
    Attached Images Attached Images

  2. #2
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    10

    Default

    Sounds like this bug:

    Bug 21116 - Calendar headers won't disappear after viewing a shared calendar event
    Bug 21473 - can't open exchange appointments (dupe)

    This was fixed in 5.0 GA - if you're running 5.0 and still see the same bug, can you please provide some more info:

    - What browser?
    - If Firefox, append "?dev=1" to the url and try to repro.
    - If you're able to repro, open the javascript console (via Tools menu of the browser window) and post any JS *errors* (not warnings)

    Thanks.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Nov 2007
    Location
    Belgium
    Posts
    35
    Rep Power
    8

    Default

    I'm working with 5.0.1GA and have this problem on IE and firefox...

    Firebug says:
    Code:
    E has no properties
    (no name)()zimbra (line 2671)
    (no name)(div#DWT430.ZmMailMsgView, "<HTML><BODY>\n<PRE style="font-family: monospace; font-size: 14px">\n</PRE>\n</BODY></HTML>", false, undefined)zimbra (line 2750)
    _renderCalItem(ZmAppt startDate=Sat Jan 12 2008 14:41:53 GMT+0100)Calendar_all.js.z... (line 4583)
    set(ZmAppt startDate=Sat Jan 12 2008 14:41:53 GMT+0100, undefined)Calendar_all.js.z... (line 4555)
    (no name)(ZmAppt startDate=Sat Jan 12 2008 14:41:53 GMT+0100)zimbra (line 4500)
    (no name)()zimbra (line 587)
    (no name)(4, ZmMailMsg _evt=ZmEvent _evtMgr=AjxEventMgr type=MSG, AjxCallback obj=ZmCalViewController args=[1], ZmCsfeResult _data=Object _isException=false)zimbra (line 2859)
    (no name)()zimbra (line 587)
    (no name)(AjxCallback obj=ZmAppt args=[3], ZmCsfeResult _data=Object _isException=false)zimbra (line 1475)
    (no name)()zimbra (line 587)
    (no name)(AjxCallback obj=ZmMailMsg args=[1], ZmCsfeResult _data=Object _isException=false)zimbra (line 1339)
    (no name)()zimbra (line 587)
    _handleResponseSendRequest(Object soapDoc=AjxSoapDoc asyncMode=true, ZmCsfeResult _data=Object _isException=false)Startup1_2_all.js... (line 7069)
    (no name)()zimbra (line 587)
    _runCallback(AjxCallback obj=ZmRequestMgr args=[1], AjxSoapDoc _soapURI=http://www.w3.org/2003/05/soap-envelope, Object)Startup1_1_all.js... (line 9302)
    (no name)()zimbra (line 587)
    __handleResponse(AjxRpcRequest id=__RpcCtxt_0 __httpReq=XMLHttpRequest, AjxCallback obj=Object args=[2])Startup1_1_all.js... (line 600)
    onreadystatechange(undefined)Startup1_1_all.js... (line 581)
    [Break on this error] undefined
    And i can't close the "window" portion with close

  4. #4
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    10

    Default

    The error you posted is helpful but as you can tell, somewhat cryptic.

    Can you try the following:

    -Load the web client with "?dev=1" appended to the url.

    This will loaded the web client in debug mode (and also popup a debug window)

    - Open the JS error console
    - Try to repro the bug
    - Post the non-obfuscated JS error

    Thanks!
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    Nov 2007
    Location
    Belgium
    Posts
    35
    Rep Power
    8

    Default

    Code:
    ZmMailMsgView.prototype._createDisplayImageClickClosure =
    function(msg, idoc, id, iframe) {
    	var self = this;
    	var func = function() {
    		var images = idoc.getElementsByTagName("img");
    		for (var i = 0; i < images.length; i++) {
    			if (images[i].getAttribute("dfsrc")) {
    				// If we just loop through the images, IE for some reason,
    				// doesn't fetch the image. By launching them off in the
    				// background we seem to kick IE's engine a bit.
    				if (AjxEnv.isIE) {
    					var args = [images[i], i, images.length, msg, idoc, iframe, self];
    					var act = new AjxTimedAction(null, ZmMailMsgView._swapIdAndSrc, args);
    					AjxTimedAction.scheduleAction(act, 0);
    				} else {
    					images[i].src = images[i].getAttribute("dfsrc");
    				}
    			}
    		}
    		diEl = document.getElementById(id);
    		if (diEl)
    			diEl.style.display = "none";
    		this._htmlBody = idoc.documentElement.innerHTML;
    		if (!AjxEnv.isIE) {
    			self._resetIframeHeightOnTimer(iframe);
    		}
    
    		ZmMailMsgView._resetIframeHeight(self, iframe);
    	----->msg.setHtmlContent(this._htmlBody);
    		msg.showImages = true;
    	};
    	return func;
    };
    the error console of firefox showed me this line...

    Dont know if it 's what you need...

    I stay open to find the right part of code if you need!

  6. #6
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    10

    Default

    Strange.

    This bug is similar to bug 21116 but the JS error is different.

    Do you know if the appointment on the shared calendar was created via Outlook?

    Can you provide repro steps beginning with when/how the original appointment was created?

    Thanks.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    Join Date
    Nov 2007
    Location
    Belgium
    Posts
    35
    Rep Power
    8

    Default

    This is a shared Google Calendar...
    So the appointment was created there.

    But it happens too on machines here from zimbra's shared calendar...

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. zcs 5.0 rc2 shared calendar not working
    By wtchan in forum Users
    Replies: 1
    Last Post: 11-30-2007, 05:19 AM
  3. [SOLVED] Shared calendar not able to edit
    By garfabian in forum Installation
    Replies: 1
    Last Post: 09-17-2007, 09:55 AM
  4. Shared mailbox and shared calendar question
    By illscientific in forum Administrators
    Replies: 3
    Last Post: 12-12-2006, 08:28 AM
  5. Outlook connector sync fails for shared calendar -- release 4.03GA
    By nyamada in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 11-21-2006, 02:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •