Results 1 to 6 of 6

Thread: How can I remove "Display Name" from an account

  1. #1
    Join Date
    Jul 2007
    Location
    New York, NY
    Posts
    46
    Rep Power
    8

    Default How can I remove "Display Name" from an account

    Hi, I was trying to remove "Display Name" from an account for some reasons. But I can't do it either by UI or command line. It gave me the errors below

    Message: invalid request: LDAP schema violation: [LDAP: error code 65 - object class 'organizationalPerson' requires attribute 'cn']
    Error code: service.INVALID_REQUEST
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Sender

    Is that possible to do this?

    Thanks

  2. #2
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Since display name is the cn for the account in LDAP it is impossible to remove it completely. A workaround that might or might not fit what you are looking for is to set the display name to " " (a space) or some non-printable character. This will make the display name appear blank, however this will only work for one account (unless you find other characters to use that don't show up).

  3. #3
    Join Date
    Jul 2007
    Location
    New York, NY
    Posts
    46
    Rep Power
    8

    Default

    But I have a question. Why does the default accounts like admin, spam, ham, and wiki all have no "Display Name"? They should have CN with something else, right? Can I follow those accounts' style/method?

    Thanks

  4. #4
    Join Date
    Dec 2006
    Location
    Melbourne, AU
    Posts
    58
    Rep Power
    8

    Default

    It looks like when you use zmprov to modify the 'displayName' attribute, it also tries to change the 'cn' attribute in LDAP as well. So, while you simply want to remove the displayName attribute, using zmprov won't work, since it's also trying to remove the cn and as the error reports, that would be an object class violation.

    Using the 'ldapmodify' command line may help, if you're confident enough in feeding in the right information, and know the right credentials to authenticate to your ldap configuration.

    An ldif along the lines of:

    Code:
    dn: uid=YOURUSERID,ou=people,dc=YOUR,dc=DOMAIN,dc=NAME
    delete: displayName
    should do the trick.

    That said, I'd probably want confirmation from a Zimbra employee before you proceed.

  5. #5
    Join Date
    Jul 2007
    Location
    New York, NY
    Posts
    46
    Rep Power
    8

    Default

    Can I file this as a bug/enhancement? Since we have system accounts with no "Display Name", why don't we just simply remove "Display Name" once created?

    Thanks
    Chadsel

  6. #6
    Join Date
    Dec 2006
    Location
    Melbourne, AU
    Posts
    58
    Rep Power
    8

    Default

    May as well give it a try - you can do so from bugzilla.zimbra.com

Similar Threads

  1. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 07:34 AM
  2. One account not receving email
    By EnglishDude in forum Administrators
    Replies: 12
    Last Post: 04-30-2010, 06:19 AM
  3. Remove Account names from GAL
    By g8se in forum Administrators
    Replies: 6
    Last Post: 05-25-2009, 01:38 AM
  4. zmfixperms not working
    By Rick Baker in forum Administrators
    Replies: 3
    Last Post: 10-15-2007, 10:25 AM
  5. Replies: 3
    Last Post: 09-18-2007, 06:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •