Results 1 to 9 of 9

Thread: Another Hide Alias in GAL Question

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default Another Hide Alias in GAL Question

    I'm preparing to upgrade to version 5.0.1 over this coming weekend, and the issue of when, where, and how aliases are hidden in the GAL has me concerned and confused.

    When version 4.0 came out bug 10456 appeared, where all aliases were showing up when searching the GAL. This bug was later fixed so that aliases did not show up at all in the GAL searches. There is also another bug/RFE, 14919 that is "assigned" to hide aliases on a per alias basis. In testing the GA version of 5.0 (and 5.0.1) I found that aliases were showing up again when do address auto-complete in a "compose new message" window; in other places the aliases are still hidden. (Although I have since found that they also show in the IM window). I created yet another bug (23298) for this issue. So far my bug hasn't generated much interest; still marked as "new", only one vote (my own), and only one other person commenting.

    There seems to be some indication, based on some comments on bugs 23298 and 14919, and also from this thread that I started, that this is either the intended behavior or that it will be fixed when bug/RFE 14919 is "fixed".

    My questions are: A) Why would this ever be the intended behavior; to hide aliases in most spots, but not in the address auto-complete? Am I the only one that finds the extra alias addresses showing up annoying and confusing? B) As far as this issue being fixed with 14919, I am afraid that this won't be the case. If alias hiding is already working in most places, but not in address auto-complete, how is hiding aliases on a per alias basis going to change this? I'm thinking if the current "hide alias" code is allowing aliases to show up in address auto-complete it will continue to do so, even if there is a check box to hide individual aliases.

    Any thoughts or comments on this issue are welcome.

  2. #2
    Join Date
    Nov 2006
    Location
    Manchester, UK
    Posts
    59
    Rep Power
    9

    Default

    No, I find this annoying too and was very pleased when bug 10456 was fixed and released.

    Add you're votes to the bugs, seems that 10456 (at least) has been re-opened.

  3. #3
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    As far as I can tell, bug 10456 has not been re-opened. Status shows "VERIFIED"; resolution shows "FIXED". The last two comments mention the issue returning in version 5, and the last one refers to yet another bug (23687). This one sure seems like a duplicate of the one I created (23298), but I guess I'll vote for it.

  4. #4
    Join Date
    Nov 2006
    Location
    Manchester, UK
    Posts
    59
    Rep Power
    9

    Default

    Sorry, yes has re-opened as bug 23687

  5. #5
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Thanks. My bug has been opened since 12/27, and as I said in my first message in this thread, hasn't generated any interest. I don't care whether my bug (23298) gets marked as a duplicate of 23687, or vise-versa; or whether they both get closed and 10456 gets re-opened. I just want the issue solved. Hopefully this will draw some attention from the Zimbra folks.

  6. #6
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    soxfan, you're not alone.

    Customers who were happy to have the aliases not showing (bug fixed in 4.5.x) are now (very) unhappy to have them showned again...

    The way it worked once "fixed" was just nice.

Similar Threads

  1. Replies: 0
    Last Post: 11-29-2007, 12:57 PM
  2. Hide aliases in GAL
    By Dirk in forum Administrators
    Replies: 5
    Last Post: 11-15-2007, 03:25 PM
  3. Search by COS? and hide cos from GAL
    By krolen in forum Administrators
    Replies: 5
    Last Post: 09-19-2007, 09:38 AM
  4. Hide from GAL
    By vcolombo in forum Administrators
    Replies: 8
    Last Post: 06-20-2006, 08:48 AM
  5. GAL Question
    By tbullock in forum Administrators
    Replies: 13
    Last Post: 05-26-2006, 01:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •