Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Deactivated Users / User Counts

  1. #1
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default Deactivated Users / User Counts

    We have a bunch of old email accounts from former employees. I've migrated their emails over from my old mail server, but they are now taking up accounts on my Zimbra server. Well, I think they are, sometimes the account numbers don't make sense.

    Perhaps that should be my first question, how exactly are the 'accounts' counted? When I add a user, then delete it, the 'accounts used' stays incremented by one until I restart the ZCS server. I just restarted my server, and it currently says "0 accounts" used, whereas before I restarted it the count was 76. (it goes back to 76 after creating an account) Does it count all accounts except ham/spam/admin/wiki? Does it count deactivated (closed) users? Currently my server is giving me a number that isn't truly accounted for by any of those. (unless it counted the closed account twice)

    Or, when these accounts are archived with ZAD can/does it remove them from the server? I'm looking at potentially 35 accounts that I need to keep for the auditors etc, and I don't want those to count towards my licenses.

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Sounds like the admin console isn't pulling the total in properly, but besides that:
    -ham/spam/wiki/resources/distribution lists don't count
    -the admin is a user
    -closed accounts still count against license #'s (it's like a soft delete just in-case a few weeks later you need them back)
    Active -Active is the normal status for a mailbox account. Mail is delivered and users can log into the client interface.
    Maintenance - When a mailbox status is set to maintenance, login is disabled, and mail addressed to the account is queued at the MTA. An account can be set to maintenance mode for backing up, importing or restoring the mailbox.
    Locked - When a mailbox status is locked, the user cannot log in, but mail is still delivered to the account. The locked status can be set, if you suspect that a mail account has been hacked or is being used in an unauthorized manner.
    Closed - When a mailbox status is closed, the login is disabled, and messages are bounced. This status is used to soft-delete an account before deleting it from the server.
    LockOut - Users who try to log in and do not enter their correct password are locked out of their account after a specified number of consecutive failed login attempts. An account’s status is automatically changed to Lockout. How long the account is locked out is set by COS or Account configuration, but you can change the lockout status at any time.
    -archive accounts count (it's a licensed product, so you'll need to have enough licenses to cover both the users as well as regular accounts).
    -you could:
    a) rely on backups of those accounts
    b) imapsync them to a FOSS box or something
    c) take a zip of their mail - like: http://www.zimbra.com/forums/adminis...end-users.html

  3. #3
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    One thing Mike... I've always had an issue with the deleted accounts being counted towards the total, and have to restart the server to solve this. While not a major issue, it can sure be annoying at times.

    Can you help with some bugzilla magic to see if there's a bug filed I don't see?

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    I'm not hitting the right search terms either - go ahead and make one under admin console "deleted accounts don't update license count till server restart".
    (I assume we're just talking about the # in the admin console licence tab - or are you physically unable to create users till you restart?)

  5. #5
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    No, I'm unable to create users until I restart. This is both from the admin console, and from zmprov.

    Code:
    [zimbra@gto ~]$ zmprov ca aa8@bexp3d.com ThIsPassWorDWiLLnoTbEuSEd givenName none sn blank displayName 'test account'
    ERROR: service.LICENSE_ERROR (number of accounts exceeds the limit: 100)
    Bug 24009 - deleted accounts don't update license count till server restart
    Last edited by p24t; 01-25-2008 at 01:58 PM. Reason: add bug link

  6. #6
    Join Date
    Feb 2007
    Posts
    28
    Rep Power
    8

    Default

    Quote Originally Posted by mmorse View Post
    b) imapsync them to a FOSS box or something
    If zmmailboxmove worked across network and open source versions, as I described here, it would be really easy and convenient to use a second ZCS server as the archive location. We will probably have to go the imapsync route in the near future to off-load some very large, defunct accounts and data from our NE server. I can't wait to read through the error logs... :-|
    Jonathan Bare, ACSA
    Mid-Atlantic Computer Solutions, Alexandria, Virginia

  7. #7
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    Rather than imapsync to a foreign system, you ought to be able to do a zmbackup -a deletedacct@example.com -f and archive the resulting /opt/zimbra/backup/sessions/full-XXXXXXX somewhere.

  8. #8
    Join Date
    Dec 2007
    Location
    Guelph, On
    Posts
    6
    Rep Power
    8

    Default Upgraded license count not reflected without restart.

    Quote Originally Posted by p24t View Post
    No, I'm unable to create users until I restart. This is both from the admin console, and from zmprov.

    Code:
    [zimbra@gto ~]$ zmprov ca aa8@bexp3d.com ThIsPassWorDWiLLnoTbEuSEd givenName none sn blank displayName 'test account'
    ERROR: service.LICENSE_ERROR (number of accounts exceeds the limit: 100)
    Bug 24009 - deleted accounts don't update license count till server restart

    We're in 5.0.9 and I just got the same error after installing a license update. Still ran into the high-water mark even though admin console and zmlicense all say I've got 2500 accounts left. Opened a support ticket, but I better book the restart maintenance window.
    Gerrit Bos
    CCS, U. of Guelph
    Ontario, Canada

  9. #9
    Join Date
    Dec 2006
    Posts
    13
    Rep Power
    9

    Default License_Error

    Hey Guys,

    Looks like we're running into this. We upgraded last september to 7.1.3 using:

    zcs-NETWORK-7.1.3_GA_3346.RHEL5_64.20110928134534.tgz

    We've deleted several accounts, and the count within zimbra administrator decreased, but the "License error encountered" popup keeps coming up with an incorrect count.

    Message: AccountsLimit exceeded: 126/125 Error Code:
    service.LICENSE_ERROR Method: [unknown] Details:soap:Reciever

    Is anybody else still seeing this?

    Thanks,
    Raul

  10. #10
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    503
    Rep Power
    7

    Default

    I have the same problem. It was supposed to be fixed here: Bug 24009 – deleted accounts don't update license count till server restart. I will reopen this bug.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 10:19 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •