Results 1 to 6 of 6

Thread: [SOLVED] ZCS 5.0.1 OS Edition certificate problems - Followed threads, still have pro

Threaded View

  1. #1
    Join Date
    Aug 2006
    Location
    Belgrade, Montana
    Posts
    16
    Rep Power
    9

    Default [SOLVED] ZCS 5.0.1 OS Edition certificate problems - Followed threads, still have pro

    Greetings,

    I've read the relevant threads on this problem... but none of them work for me.

    SSL Certificate Problems - Zimbra :: Wiki
    http://www.zimbra.com/forums/70910-post26.html

    I did an upgrade from 4.5.10 to 5.0.0 and then to 5.0.1 some time ago. The upgrades went fine. After running for a few weeks though, I had a certificate expire.

    The system in question is running RHEL 4 Update 6 and the RHEL 4 i386 version of ZCS 5.0.1 OS Edition.

    Anyway, it appears my mailboxd certificate expired today. I logged into the admin console looked at the certs and it said that there were three of them, two of them were still good into 2012 (if I remember correctly) but that the one for mailboxd was expired as of today. I tried using the cert install feature of the admin console and checked "reinstall" or "overwrite" or whatever it was. That failed. After the failure, I seemed to have two certs and no cert for mailboxd. After that inbound and outbound mail stopped working.

    So, I tried following the instructions at the first URL above... and there were two missing commands... zmcreateca and zmcreatecert are MISSING. There are sections to the document that say are for upto 4.5 and others that say they are for 5+. I followed them all as much as possible... but with missing commands... it wasn't going to work.

    Then I found the second URL mentioned above. All of the instructions worked... and my system was now able to send and receive mail (inbound and outbound worked again)... but I can NO LONGER login to the admin console AND the web certificate is still expired... so the fix didn't fix anything... and only made the situation worse.

    How do I fix this?

    While there are lots of instructions, they are basically a jumbled mess... and in many ways non-functional. I've been running Zimbra for over two years and have had to fix expired certs twice before... on pre-5 systems and the instructions worked.

    Please help.

    I considered deleting my cert dirs and trying to do an install/upgrade of the same version on top of itself but decided that since I have a certain level of functionality, I don't want to make it any worse.

    Thanks in advance!
    Last edited by dowdle; 02-08-2008 at 09:12 PM. Reason: To add the word SOLVED

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 05:52 AM
  2. zcs 5.0.1 on os x client - not working
    By comptekki in forum Administrators
    Replies: 3
    Last Post: 01-14-2008, 09:04 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  4. Replies: 41
    Last Post: 10-29-2007, 03:36 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •